Plex Transcoding EAC3 5.1 to AAC... Why?



Hi All

I am a very new user to Plex so please bare with me!

I recently downloaded Plex to solve a problem whereby my PS4 could not play videos from a USB containing EAC3 5.1 audio. My setup is a PS4 connected via HDMI to an AV Receiver (Yamaha RXV-479) which in turn is connected to my television. I have downloaded Plex onto my PC and the Plex app on the PS4 to enable me to stream the EAC3 5.1 videos to my PS4 through the app. The only problem is that when I do this, the audio playback of said video sounds very compressed. It's hard to explain but it doesn't sound like the source audio when played on my PC. Now when I go to check what's happening on my PC it says that it's transcoding the audio from EAC3 5.1 to AAC. Why is it doing this? Is there no way my AV receiver can handle the audio? I have tried every setting and checked every forum post similar to this but to no avail.

Has anyone had a similar experience?


I was tired to crackly audio coming from the AAC transcode, so I enabled eac3 and ac3 as passthrough in the Playstation 4 xml profile a couple days ago (and restarted the Plex Server). I'm not sure why I would want to transcode to AAC if I can passthrough?

VideoProfile protocol="hls" container="mpegts" videoCodec="h264" audioCodec="aac,ac3,eac3" context="streaming"

My PS4 Pro goes to my TV, then via Optical out to a powered set of stereo speakers, so YMMV.


I have already tried doing this but the Plex Server is still hellbent on transcoding the EAC3 5.1 audio to AAC. It doesn't seem to be passing through the audio to the receiver at all. Are there any other ways to force audio pass through? Do you have any screenshots of your settings you could show me?


Where do you find the Playstation 4 xml profile?