Plex won't play certain episodes, no matter what quality or type of file.

server-unraid

#1

A couple of months ago i moved from a windows setup to unraid. The move has been pretty much problem free, and everything is (or at least was) working as it should until a few days ago when the strangest problem showed up.

As of about thursday/friday, Plex seems to refuse to play certain episodes of certain shows. Notice i said episodes, and not files, and that's because it doesn't seem to matter what file type is used.

So let's say "my favorite tv show" has it's latest episode up. Sonarr grabs it, downloads it, places it in the proper folder where Plex indexes it etc, etc, etc.

I go to play the file and nothing happens. It just hangs. Tried multiple clients (roku's, android phones/boxes, web player across multiple browsers on multiple pc's etc). Wired/wireless, direct play or forced transcoding - doesn't matter... the show just hangs and never starts playing. Never craps out with an error, just sits there and never starts.

The downloaded mkv plays fine in VLC and when scanned and played through my old win server. Still, the first thought was - something is up with the file. So i went ahead and downloaded a different release - same problem. Tried different qualities from different indexers, and even tried a version converted with handbrake to mp4 - no effect. I can see that Plex is indexing the file properly with each change (resolution and file name/size change is shown appropriately etc), but still - it just hangs. I even tried taking an episode of a different show, renamed it to make Plex think it's the one i was having issues with before, and that one doesn't want to play either.

So basically, Plex decided that it is not going to play a certain episode and no matter what i do to the actual file and what i replace it with, it just refuses to play it. This only happens on the unraid/ Plex combo. My old win server has no issues picking up the episode and any of the changes i've made from unraid and playing it on any and all the devices/clients i tried.

To make things even more confusing, this is not a system wide problem, and only affects random episodes. So yesterday was sunday, which is a pretty busy tv night, and like a dozen different things came in. Out of them only 2 are suffering from this problem. There was 1 out of about 8 on thursday, about the same on friday etc. In other words, only a small and seeming random number of files are affected, and only on the plex/unraid combo.

I've ran the "docker safe permissions" and "new permissions" to make sure this is not some wacky permissions issue. I've replaced the file with every version that i could find, or even create myself to make sure it's not a file issue. So far, the problem persists, and i am starting to run out of ideas.

Again, very few, seemingly random shows/episodes are affected and only on the unraid/plex combo. My old win server pointed to the same folder/file plays everything just fine.

I'm still new to unraid, so not sure where to go from here and would greatly appreciate some guidance.

thanks....


#2

After posting this, i started reading a thread about codec errors in the most recent Plex docker version. I decided to delete all the codecs and let plex refresh them with the latest version.

Dumping the regular codec folder didn’t do anything, but junking the EasyAudioEncoder seems to have fixed my problem completely.

Same episodes that were crapping out are now playing ok, and everything is working as it should again etc, etc, etc.


#3

Thank you SO MUCH for this! The same issue has been bugging me for days and deleting the codecs as well as the EasyAudioEncoder has solved the issue!

@PashaG said:
After posting this, i started reading a thread about codec errors in the most recent Plex docker version. I decided to delete all the codecs and let plex refresh them with the latest version.

**Dumping the regular codec folder didn’t do anything, but junking the EasyAudioEncoder seems to have fixed my problem completely. **

Same episodes that were crapping out are now playing ok, and everything is working as it should again etc, etc, etc.