Plexamp: No Music Servers - Error


#1

After successful login, I’m receiving error message.!


#2

Error message above.


#3

LOL on that error message… truth. That’s how it usually is here on the forum - can’t always get the answer to our problems.


#4

do you have the plex media server installed?


#5

You need a media server, which is signed in, and with at least one music library.


#6

I have a similar issue, only libraries owned by others are shown as available. All libraries are remote.

Is there a settings window anywhere?


#7

You only need to specify the library if you want to see the recently played/added for that particular library. Otherwise you should be able to access all music content.

To show the hub for a particular library, right click on the PlexAmp icon in the system tray, then select source.


#8

@Bemis said:
I have a similar issue, only libraries owned by others are shown as available. All libraries are remote.

Is your local server signed in and accessible? Plexamp writes an Application.log file which should contain pretty good information about how it’s looking for servers.

Is there a settings window anywhere?

Settings are for applications which aren’t strongly opinionated :lol:


#9

Somewhat off-topic…but that’s one of the best error messages I’ve ever seen. Kudos.


#10

Does Plexamp only work with local servers? I’m remote form my servers at the mo, and Plexamp wont connect. I have PMP & Web logged in in the background.


#11

@clowg said:
Does Plexamp only work with local servers?

No, should work with remote, shared, and plex cloud servers.

If you can’t get it to work, have a look in Application.log, it should talk about trying to connect to your servers and that might provide clues.


#12

I’m having the same issue. I have Plex Cloud, Cloud Sync, Remote server from friends and two local servers. Occasionally, Plex Cloud does show up, and other clients can tell Plex Cloud to play on Plexamp, but no audio actually plays.


#13

I have the same problem but I can see in the Application.log the following which seems to be the problem:
Dec 19, 2017 07:36:34.083 WARN - DEVICE: Server connection https://212.24.97.204:32400 didn’t work for Storage: unable to verify the first certificate

My server is using a Let’s Encrypt certificate. What certificate store do you app use? Is it possible to add more logging about which part of the certificate chain it cannot verify? I guess it is the first part which is “DST Root CA X3”.


#14

@julemand101 said:
My server is using a Let’s Encrypt certificate. What certificate store do you app use? Is it possible to add more logging about which part of the certificate chain it cannot verify? I guess it is the first part which is “DST Root CA X3”.

Ah, interesting, that might be it. We do manual DNS checking to work around rebind protection, so I’m a bit surprised at that log, any chance you can send a more complete log over (DM or otherwise)?


#15

Similar issue here when using CloudFlare in front of the server.

I can view contents of the music libraries. However, I get a blank page and no audio when attempting to play anything. This behaviour has been reproduced on multiple machines running Windows 10.

From plexmediaserver.log

Dec 19, 2017 15:13:00.487 [0x7fd1f9fff700] VERBOSE - Auth: We found auth token (xxxxxxxxxxxxxxxxxxxx), enabling token-based authentication.
Dec 19, 2017 15:13:00.487 [0x7fd1f9fff700] DEBUG - Auth: authenticated user 16206545 as ewan2395
Dec 19, 2017 15:13:00.487 [0x7fd1f1bff700] DEBUG - Request: [172.17.0.1:53252 (WAN)] GET /playQueues?includeLoudnessRamps=1&uri=library%3A%2F%2Fxxx%2Fdirectory%2F%252Flibrary%252Fmetadata%252F35046%252Fchildren&shuffle=1&type=audio&commandID=4 (11 live) GZIP Signed-in Token (ewan2395)
Dec 19, 2017 15:13:00.487 [0x7fd1f1bff700] VERBOSE -  * Host => *****.********.***
Dec 19, 2017 15:13:00.487 [0x7fd1f1bff700] VERBOSE -  * X-Real-IP => 141.101.98.252
Dec 19, 2017 15:13:00.487 [0x7fd1f1bff700] VERBOSE -  * X-Forwarded-For => 90.222.121.103, 141.101.98.252
Dec 19, 2017 15:13:00.487 [0x7fd1f1bff700] VERBOSE -  * X-Forwarded-Proto => https
Dec 19, 2017 15:13:00.487 [0x7fd1f1bff700] VERBOSE -  * Connection => upgrade
Dec 19, 2017 15:13:00.487 [0x7fd1f1bff700] VERBOSE -  * Accept-Encoding => gzip
Dec 19, 2017 15:13:00.487 [0x7fd1f1bff700] VERBOSE -  * CF-IPCountry => GB
Dec 19, 2017 15:13:00.487 [0x7fd1f1bff700] VERBOSE -  * CF-RAY => 3cfb4da99e69350c-LHR
Dec 19, 2017 15:13:00.487 [0x7fd1f1bff700] VERBOSE -  * CF-Visitor => {"scheme":"https"}
Dec 19, 2017 15:13:00.487 [0x7fd1f1bff700] VERBOSE -  * Accept => application/json
Dec 19, 2017 15:13:00.487 [0x7fd1f1bff700] VERBOSE -  * X-Plex-Client-Identifier => bbd513bb-74ba-4cf9-9c5a-55f92bf83f10
Dec 19, 2017 15:13:00.487 [0x7fd1f1bff700] VERBOSE -  * X-Plex-Device-Name => Workstation
Dec 19, 2017 15:13:00.487 [0x7fd1f1bff700] VERBOSE -  * X-Plex-Platform => Plexamp
Dec 19, 2017 15:13:00.487 [0x7fd1f1bff700] VERBOSE -  * X-Plex-Platform-Version => v7.9.0
Dec 19, 2017 15:13:00.487 [0x7fd1f1bff700] VERBOSE -  * X-Plex-Product => Plexamp
Dec 19, 2017 15:13:00.487 [0x7fd1f1bff700] VERBOSE -  * X-Plex-Version => 1.0.0
Dec 19, 2017 15:13:00.487 [0x7fd1f1bff700] VERBOSE -  * X-Plex-Provides => client,player,pubsub-player
Dec 19, 2017 15:13:00.487 [0x7fd1f1bff700] VERBOSE -  * X-Plex-Token => xxxxxxxxxxxxxxxxxxxx
Dec 19, 2017 15:13:00.487 [0x7fd1f1bff700] VERBOSE -  * X-Plex-Device => Windows
Dec 19, 2017 15:13:00.487 [0x7fd1f1bff700] VERBOSE -  * User-Agent => axios/0.16.2
Dec 19, 2017 15:13:00.487 [0x7fd1f1bff700] VERBOSE -  * CF-Connecting-IP => 90.222.121.103
Dec 19, 2017 15:13:00.487 [0x7fd1f1bff700] VERBOSE -  * includeLoudnessRamps => 1
Dec 19, 2017 15:13:00.487 [0x7fd1f1bff700] VERBOSE -  * uri => library://xxx/directory/%2Flibrary%2Fmetadata%2F35046%2Fchildren
Dec 19, 2017 15:13:00.487 [0x7fd1f1bff700] VERBOSE -  * shuffle => 1
Dec 19, 2017 15:13:00.487 [0x7fd1f1bff700] VERBOSE -  * type => audio
Dec 19, 2017 15:13:00.487 [0x7fd1f1bff700] VERBOSE -  * commandID => 4
Dec 19, 2017 15:13:00.487 [0x7fd1f1bff700] VERBOSE - Auth: tokens were refreshed recently enough
Dec 19, 2017 15:13:00.488 [0x7fd1f9fff700] DEBUG - Completed: [172.17.0.1:53252] 403 GET /playQueues?includeLoudnessRamps=1&uri=library%3A%2F%2Fxxx%2Fdirectory%2F%252Flibrary%252Fmetadata%252F35046%252Fchildren&shuffle=1&type=audio&commandID=4 (10 live) GZIP 0ms 379 bytes (pipelined: 5)

plexamp log:

Dec 19 11:39:40: client: [0] opened from 127.0.0.1:18285
Dec 19 11:42:44: client: [0] opened from 127.0.0.1:18471
Dec 19 15:10:21: client: [0] opened from 127.0.0.1:21100
Dec 19 15:11:57: client: [0] opened from 127.0.0.1:21178

#16

When I’m on a local computer to Plex server, it loads fine. But when I’m on a remote machine to the server, I receive the error I posted.

Here is the log.log from Plexamp.

Dec 18 11:48:05: client: [0] opened from 127.0.0.1:61231
Dec 18 11:51:20: client: [0] opened from 127.0.0.1:61729
Dec 18 18:50:13: client: [0] opened from 127.0.0.1:49449
Dec 19 09:32:10: client: [0] opened from 127.0.0.1:56128


#17

When you’re local it’s probably just using that connection.

To anyone who’s running into this problem:

  • Does your log have a similar error to DEVICE: Server connection https://xxx didn't work for? What is it?
  • Do you have custom cert/DNS setup? What is it?

I’m sure there’s a common pattern here :slight_smile:


#18

I simply can’t login. I click sign in, am redirected to a Plex login page, enter the correct credentials but continually get the following error. Same in all browsers.


#19

@slampman ~ assuming you’re still having the issue, can you capture the URL before it redirects and send it to me in a DM?


#20

@elan said:
When you’re local it’s probably just using that connection.

To anyone who’s running into this problem:

  • Does your log have a similar error to DEVICE: Server connection https://xxx didn't work for? What is it?
  • Do you have custom cert/DNS setup? What is it?

I’m sure there’s a common pattern here :slight_smile:

I’m facing the same issue, but I do not have a custom cert/DNS setup. I haven’t tried it local yet. My error for that part of the log is a socket hang up.