Problem with PMS not connecting, only localhost available

server-nvidia-shield

#1

Hi guys first time poster here.... About 4 days ago after working perfectly i got the error message that i could only login through insecure connection then it set up a localhost where i am able to watch everything locally but not through my actually PMS. I literally changed nothing in regards to Plex and after reading a few articles i see it has happened to many people.... I just dont even know where to begin as i cant even access my server to look at settings and possibly change them. Can someone please help me where to even begin here i am totally lost!


#2

Shield attached to Synology NAS which is available to me on my network and seems to be connected as i can stream locally through locahost connection…


#3

@RealDeal78 said:
i am able to watch everything locally but not through my actually PMS

i don’t know what this means. using the generic Photos&Video app on the Shield or something?

in the Plex Android TV app can that see the server? does it say your shield server is running in its settings?


#4

Im probably not saying it right… few days ago i was unable to log into my server i have setup with all my remote users… Went to login and shows unavailable now. When i tried to log in to the plex.tv web app it said only insecure connection is available so i logged in that way and it had me setup a ‘localhost’ server and i am able to watch media locally on my sheilds in my house through this ‘localhost’ server. My original server shows unavailable on all the apps and the plex.tv web app as well…


#5

i literally just paid for a lifetime membership a week ago i hope im not disappointed because everything has been working PERFECTLY for 8 months since i set it up and suddenly overnight im having issue and i havent changed anything.


#6

sounds like something with a server update did not happen correctly and it created a new server.

in the Plex Android TV app on the Shield does it say it is running?


#7

If I understand correctly, you can use the Plex app on the Shield TV (or the Plex Web on a computer, or a Plex app on your phone, etc) on your local network just fine, but you can’t remotely access your Plex Server?


#8

Yes it says the Plex Media Server is running


#9

The only place i can access my media is at home on my sheild tvs (2) (no tablet no phone) through the ‘localhost’ server that was created after plex.tv web app forced me to login through an ‘insecure connection’ and it had me go through the steps to setup a different local server… No remote access at all and not able to use plex apps other than at home on my sheilds…


#10

I take that back i can access from my ipad but not my android phone (plex app) through ‘localhost’ server i was forced to create on my own network Original server just shows offline and cant access it…


#11

you have more than one shield? does it say running on both?


#12

Correct i have 2 shields and both show PMS running


#13

Please make sure you are connecting to the Shield TV that has the Plex Server you’ve been using. It sounds like you have picked the incorrect Plex Server in the selection area on the Plex client.


#14

Here is an example when using the web client.


#15

I only had 1 server set up through my living room shield then it made me create another one 4 days ago because of this ‘insecure connection’ crap. I understand what you are saying but that is not the issue. My original server ive had setup for 8 months appears like several of those other servers above in the picture (rysenkiller and Plex Cloud) . Its in red and unavailable for me for even connect to… This alternate server ‘localhost’ i was forced to create 4 days ago is the only server i am able to access and i can only access it at home and nowhere else.


#16

Have you restarted the Shield TV that has the original Plex Server on it?


#17

Oh yea i have rebooted the shield, my router my NAS. I have had small issues in the past where simple reboots of all equipment involved solved the issue but definitely not this time


#18

I think your old servers config got wiped somehow from your shield but the record of it did not go away from plex.tv because you never signed out of it.

so your new server config probably named “localhost” is isntalled on it now.

Do you know how to get your token? If not https://support.plex.tv/hc/en-us/articles/204059436-Finding-an-authentication-token-X-Plex-Token

go here http://<localhostIP>:32400/servers?X-Plex-Token=<YOURTOKENVALUEHERE>

where <localhostIP> is the IP of your shield running the server
and <YOURTOKENVALUEHERE> is your token ( do not share your token on the forums or anywhere)

when you go to that URL it will list all servers that are not removed from your account with their IP address ( if you post the result do not post the “machine identifier” here )

I am going to guess you have two servers ( localhost and some other) with the same local IP and the only reason the old one is showing up as unavailable is that is it was not removed from plex.tv as i mentioned above

i am betting remote access is getting confused because of the two records going to same IP


#19

So maybe when i went through that process it created this new server and killed the old one i had setup so essentially i should just delete the old one and go on with life with the new one i created???


#20

Yeah. go to the devices page and remove the old one. If you were sharing with anyone you will need to reshare. hopefully remote access starts working when you remove the old one but if not please let us know.