SD quality shows stutter/low framerate on Android TV App

android-tv
fire-tv

#1

Lately the Android TV App has been acting out on my TV a lot. The biggest problem i currently face is that all shows i have that is in SD quality, has a lot of stuttering/suffering from low framerate. The audio is fine, but the picture is really choppy. This hasn't always been the case, and has only been an issue after the last Plex app update for my TV.

The server is not doing anything out of the ordinary when playing SD quality shows on my Android TV. I have tried using the PS4 app instead on the TV, and playback is fine there, so it must be something with the Android TV app.

If i play the shows on my tablet, or PC there is no stuttering either.

The TV is a Philips 49PUS6432/12. I have tried to uninstall and reinstall the app on my TV, but it didn't fix it. Anyone have a suggestion?


#2

What version of the app do you have installed? There were some stuttering issues, but they were fixed in 6.13.7.


#3

i’ve noticed the same on the mobile version too.
in the mobile app when i told it to use the default android media player the problem went away.

so it seems like this new exoplayer is causing the problem.


#4

@rwoffice said:
What version of the app do you have installed? There were some stuttering issues, but they were fixed in 6.13.7.

6.13.7.3458


#5

Still stuttering after the last update. Annoying that i have to use my PS4 to watch shows when the Android TV app should just work.


#6

This should be fixed in 6.14, if it’s not would you be able to grab some logs and produce a sample video that has the issue?

Steps for making a sample are available here: https://support.plex.tv/articles/201035968-generating-sample-files-from-media/ and information for fetching logs can be found here: https://support.plex.tv/articles/201573117-android-android-tv-fire-tv-logs/


#7

@sixones said:
This should be fixed in 6.14, if it’s not would you be able to grab some logs and produce a sample video that has the issue?

Steps for making a sample are available here: https://support.plex.tv/articles/201035968-generating-sample-files-from-media/ and information for fetching logs can be found here: https://support.plex.tv/articles/201573117-android-android-tv-fire-tv-logs/

Here is the logs. I uploaded 2 sample files. One is one of the SD shows that are really choppy on Android TV but not on any other platform. One is a different SD show that is not choppy on Android TV for some reason.


#8

@OliverTeglhus said:

@sixones said:
This should be fixed in 6.14, if it’s not would you be able to grab some logs and produce a sample video that has the issue?

Steps for making a sample are available here: https://support.plex.tv/articles/201035968-generating-sample-files-from-media/ and information for fetching logs can be found here: https://support.plex.tv/articles/201573117-android-android-tv-fire-tv-logs/

Here is the logs. I uploaded 2 sample files. One is one of the SD shows that are really choppy on Android TV but not on any other platform. One is a different SD show that is not choppy on Android TV for some reason.

Do you have any other MPEG4 video’s you could try to play? Your Hawaii video is using the MPEG4 codec which seems to play fine on my devices that have an MPEG4 decoder as well as with the Plex MPEG4 software decoder. It might be that the Philips TV has a bad MPEG4 decoder in which case we can blacklist the decoder and ensure we use software decoding or transcoding.


#9

@sixones said:
Do you have any other MPEG4 video’s you could try to play? Your Hawaii video is using the MPEG4 codec which seems to play fine on my devices that have an MPEG4 decoder as well as with the Plex MPEG4 software decoder. It might be that the Philips TV has a bad MPEG4 decoder in which case we can blacklist the decoder and ensure we use software decoding or transcoding.

Yea, and they all stutter, but it’s just wierd because it’s only recently it has been happening. The same shows i have been able to watch for quite a while without issues.

Do you want me to make a couple more samples of different shows?


#10

I can confirm this is happening for me as well. I have 3 Firetvs on 3 different TVs. 2 Pioneer Elites and 1 Panasonic THX Plasma. All have this stutter and all work fine when using the same tv with either a PC or xbox. This issue just apeared a few weeks ago and I figured it would be fixed by now but it hasn’t so I thought I would bump this thread.


#11

Just bought a fire stick, fresh install of Plex around the first of the month, some media have this as well as a few other problems. Have not had many issues I can recall with any of my Roku products.

I have 5 gb MKV files that dont have the issue, and 175 MB .avi files that do.


#12

@Fraker1 @macgyverc3 Are all the videos you are having issues with using the MPEG4 video codec? If you could share a sample that would be a big help.


#13

here is one I know has problems

Format : AVI
Format/Info : Audio Video Interleave
File size : 350 MiB
Duration : 42mn 59s
Overall bit rate mode : Variable
Overall bit rate : 1 138 Kbps
Director : TSV Productions

Video
ID : 0
Format : MPEG-4 Visual
Format profile : Advanced Simple@L5
Format settings, BVOP : 1
Format settings, QPel : No
Format settings, GMC : No warppoints
Format settings, Matrix : Default (H.263)
Muxing mode : Packed bitstream
Codec ID : XVID
Codec ID/Hint : XviD
Duration : 42mn 59s
Bit rate : 989 Kbps
Width : 624 pixels
Height : 352 pixels
Display aspect ratio : 16:9
Frame rate : 23.976 (24000/1001) fps
Color space : YUV
Chroma subsampling : 4:2:0
Bit depth : 8 bits
Scan type : Progressive
Compression mode : Lossy
Bits/(Pixel*Frame) : 0.188
Stream size : 304 MiB (87%)
Writing library : XviD 64

If you need something else let me know. Thanks.


#14

@macgyverc3 said:
If you need something else let me know. Thanks.

A sample video https://support.plex.tv/articles/201035968-generating-sample-files-from-media/


#15

Ok, i’ve made a sample file but i cannot test to make sure it’s still choppy with a poor frame rate as I am not home but my wife says it’s still choppy.

It does play just fine through my browser on plex but not through the fireTV plex app.


#16

Any update Sixones?


#17

I’m still investigating and have found an issue, it seems that some devices like the Fire TV don’t actually support MPEG4 videos at a normal resolution. If this indeed the issue you are seeing it should be fixed in 6.16.


#18

thanks for the update. please lets us know when the update is released and we will test.


#19

excatly the same problem for me.

TV is also a Philips: 49PUS7181


#20

@sixones said:
I’m still investigating and have found an issue, it seems that some devices like the Fire TV don’t actually support MPEG4 videos at a normal resolution. If this indeed the issue you are seeing it should be fixed in 6.16.

still the same issue on the 6.16 beta :frowning: