Probably not especially helpful, but response from Synology who had Support Level Remote Access to my 425+.
"Upon our review, both the DS425+ and DS423+ are equipped with the Intel Celeron J4125 processor, which supports hardware transcoding.
Based on the error message you provided — avcodec_open2 returned -38 for encoder ‘h264_vaapi’ — this typically indicates that FFmpeg (via the VAAPI module) failed to initialize hardware acceleration due to a “function not implemented” or “no such device” error.
This suggests that the system was unable to correctly access or enable Intel VAAPI at the OS level.
As Plex Media Server is a third-party application, we recommend reaching out to Plex support to verify if there are any known limitations, dependencies, or required drivers for hardware transcoding on newer Synology NAS models.
Please don’t hesitate to contact us if you need any assistance."
Also Rusty from synoforum.com has a Synology Beestation Plus running the same 5.10.55+ kernel and J4125 cpu, and Plex HW Transcode appears to work with no issues.
Hello, thanks EZTutty! First of all, it’s good that Synology is aware of the problem and if hardware transcoding works on the Beestation + (which uses Linux 5.10.55+), I have good hope that our problem will be solved fairly quickly! It would be good if Synology compared the drivers they use for the DS425+ DSM and for the Beestation+!
I just hope it’s not the 2.5 Gb network port that’s preventing the use of the J4125’s igpu. Unlikely because these two things have nothing to do with each other, and I’m not a hardware specialist, but when I think about it, the only difference between the DS423+ and the DS425+ at the hardware level is this network port. The good functioning of the Beestation plus under Linux 5.10.55+ still gives me a little hope. I’ll be curious to see if the DS225+ (J4125 and 2.5GB network port) has the same issue. As I wrote earlier, I’ll be available from August 18th to do more advanced testing.
Given we have the exact DMESG output showing the failure of the i915 communication, I will forward that too when their Engineering team reaches out to me.
At this point, yes, we must wait for them to fix DSM and issue and update.
I’m curious @ChuckPa. Can you share what the output of the command I provided above should look like, from a working Intel-based Synology NAS? sudo dmesg | grep -i i915
Just curious about the comparison. It won’t be completely apples-to-apples of course owing to the differing kernel versions. I don’t currently have an Intel-based Synology NAS or I’d do it myself.