"This sever is not powerful enough to convert video" only with external subtitles




I get the error: "This sever is not powerful enough to convert video" when trying to watch videos with external subtitles. Few days ago external subtitles worked on the very same setup.

I am sure the cause is external subtitles. I first added a movie without subtitles to the library, it played fine. I added subtitles, got the error. Same quality videos without external subtitles still work.

I've read about the hardware permission reset with the new DSM, however uninstalling and reinstalling PMS didn't fix it for me.

Here's the list of the things I tried:

  • uninstalled and re-installed PMS (both from Synology Market Place, and also manually to
  • Made sure to set up local playback quality in the client at 20 Mbps 1080p
  • Made sure H264 level is 5.1 (recommended option)
  • Restarted PMS and TV multiples times
  • Updated of the TV software (no updates)
  • Made sure PMS has permission on the video folder

Here's my spec:

  • Samsung TV UE49KU6400 Tizen 2.4.0 with Plex client 3.2.2
  • Synology DS216j with DSM 6.1.5-15254
  • PMS
  • Local LAN 1Gb

Anyone else having this issue? Any idea on how to fix it?

Thanks for any help!


if the Plex client considers it cannot play the subtitle (which apparently happens more frequently then it might be necessary for a number of reasons), it’ll tell the Plex Media Server to burn the text into the video stream – technically this requires the video to be re-encoded (“transcoding”). This process is quite exhaustive and can be too much for your NAS.

If the TV should be able to deal with the subtitles (e.g. if you play them from a USB stick attached to the TV)… try to activate the Plex DLNA server (Settings > Server > DLNA) and check if you can playback the movie incl. the subtitles with the native “videos” app or a DLNA client on the Smart TV. This helped me on my Sony Android TV until they recently introduced a new video player in the client which is now capable of this.


Yes, I am aware full transcoding cannot be done by my NAS, but I was sure it could handle “partial transcoding” (don’t know if this is the right name for it) of just the subs (which are SRT).

Thank you for the suggestion. In fact I have tried with another DLNA media server on the same NAS and movies work, including external SRT subs. Anyway, after your post I start to wonder if it might be a plex client problem, rather than server. In fact, in the plex client forum there’s a lot of complaining about not working subtitles. For me its even stranger since SRT worked for a year, and now just don’t any longer.

Anyway, I’ll investigate a bit more and post if find anything. Other suggestions are of course very welcome.


just wait for PMS 1.11.* version:


The DS216j is ARMv7 powered and therefore not capable of transcoding. See the Plex - NAS compatibility guide, link in my signature.

Subtitles require transcoding when not supported by your Plex client and since your NAS is not capable of that, you will get an error message as you have already noted.

In order to play subtitles from your NAS you will need to re-encode the video and ‘burn’ the subtitle into the video permanently. That means you will have no control over the subtitle, you cannot turn it off and you cannot move it’s postion on the screen. The only way to remove the subtitle is to replace the video file.

Or, you may have to switch to using the built-in DLNA player on your TV (assuming your TV has a DLNA player). However, there is no guarantee that the DLNA player on your TV will handle subtitles.

An alternative would be to use a STB that supports subtitles. An Nvidia Shield running Plex Media Player or an Odroid C2 running RasPlex/OpenPHT or the latest Roku with Plex app come to mind. You should avoid an Apple TV as they have very limited format support.