TV Shows not being marked as watched after watching


#1

In fact, the episode rewinds about 4 minutes and remains showing unwatched.
If you try to manually mark the item as watched, it doesn't work. (typically doing this on Plex on Apple TV)
It also doesn't work trying to mark a watched item as unwatched
If I do it using Plex media Player ( Mac OS X) the I get the error
"There was an unexpected error marking an item as watched"
I've tried doing it form every angle (whole season, on the server, on Apple TV, on iOS etc, same result)
This is getting really annoying- being unable to easily determine which shows are watched or not
any ideas/solutions?
PMS 1.13.0.5023
Mac OS X 10.13.4
(Sorry if this is a no-no but I also posted this on general community forums, I thought since I was a plex pass member I should post it here)


#2

Am I the only one having this issue? ( with items not being marked a watched?)


#3

PMS 1.13.2.5102 (updated yesterday)
macOS 10.13.4
Roku Ultra w/Plex Client 5.3.4

Mine works fine. It worked fine before updating to the latest release.

Do you have the Trakt Plug-in installed? That has messed with the Watched status in the past. Otherwise my inklings would lean towards a database problem.


#4

Make sure you don’t have somewhere a second Plex client, which sits in perpetual pause mode on this very episode.


#5

Unfortunately it happening on EVERY TV Show, but interestingly enough not on movies !
I have 3 TV libraries, and have tried to delete the libraries and recreate, but same issue. The “unwatched status” seems to stay with the episode/shows even when changing(deleted- new) libraries

Also- did double check- no other plex clients running


#6
  1. activate debug logging (not ‘verbose’!)
  2. quit Plex Server
  3. wait 1 minute
  4. start Plex Server
  5. wait 5 minutes
  6. fetch log files and attach them here

Or inspect them yourself. Take a look at the Plex Media Server.log file and seek for messages about database corrupt or malformed.
If you find these, you may have to repair your database.
https://support.plex.tv/hc/en-us/articles/201100678-Repair-a-Corrupt-Database


#7

Didn’t find any reference to corrupt or malformed DB, here are the log files as requested ! thanks


#8

I see this rather concerning error in your log:

May 25, 2018 15:33:47.711 [0x7000057ec000] ERROR - SQLITE3:0x700004ca9590, 266, statement aborts at 35: [insert into metadata_item_views (account_id,guid,metadata_type,library_section_id,grandparent_title,parent_index,parent_title,'index',title,thumb_url,viewed_at,grandparent_guid,origina
May 25, 2018 15:33:47.712 [0x7000057ec000] ERROR - Exception inside transaction (inside=1) (../Library/MetadataItem.cpp:8695): sqlite3_statement_backend::loadOne: disk I/O error
May 25, 2018 15:33:47.712 [0x7000057ec000] ERROR - SQLITE3:0x700004ca9590, 1, statement aborts at 1: [ROLLBACK] cannot rollback - no transaction is active
May 25, 2018 15:33:47.712 [0x7000057ec000] ERROR - Failed to roll back transaction (../Library/MetadataItem.cpp:8661): Cannot rollback transaction. cannot rollback - no transaction is active
May 25, 2018 15:33:47.712 [0x7000057ec000] ERROR - Soci Exception handled: sqlite3_statement_backend::loadOne: disk I/O error

This indicates an issue with your hard disk in the server.


#9

OttoKern, thanks for spotting that in my logs, I cloned the drive to new mac and during the process CCC( carbon copy cloner) reported a disk error where the Library.db file was, so I had to delete it. I then had to rebuild all my libraries fro scratch, but it has solved the problem.


#10

@jreadwin said:
OttoKern, thanks for spotting that in my logs, I cloned the drive to new mac and during the process CCC( carbon copy cloner) reported a disk error where the Library.db file was, so I had to delete it. I then had to rebuild all my libraries fro scratch, but it has solved the problem.

You could have restored one of the backup copies, thus avoiding a complete re-build:
https://support.plex.tv/articles/202485658-restore-a-database-backed-up-via-scheduled-tasks/


#11

Doh !, I hadn’t even noticed those, may still try that, thanks