Why can't PMP stay full screen (Windows 10) (Not answered as stated :( )

plex-media-player

#1

A time ago plex had an annoying issue that it wasn’t staying full screen after turning off and on the tv and or receiver and that issue seems to be back? After closing PMP and starting it up again it directly goes to full screen again.
Also Only toggle the “full screen” option in settings menu fixes how the screen looks.

Is there anyway to prevent this?


#2

Append --tv --fullscreen to the shortcut.


#3

@Xen0sys said:
Append --tv --fullscreen to the shortcut.

Thanks @Xen0sys for the "solution".

Keep wondering why there are multiple ways to say PMP has to be fullscreen?
Can someone explain?


#4

Seems the solution from @Xen0sys worked a couple of times but now it's doing the same thing as before!

What can i do about it?


#5

FWIW I have this issue as well. Worked fine until v1.2.0 and I have my Win10 PC connected to an AVR as well.


#6

@ffhjansen said:

@Xen0sys said:
Append --tv --fullscreen to the shortcut.

Thanks @Xen0sys for the "solution".

Keep wondering why there are multiple ways to say PMP has to be fullscreen?
Can someone explain?

Plex recently added an alternative Web/Desktop UI mode for PMP which you can switch between with F11 & Shift+F11. Using --tv --fullscreen still works for me. There are also --desktop & --windowed flags you can use interchangeably.


#7

@Xen0sys said:

Plex recently added an alternative Web/Desktop UI mode for PMP which you can switch between with F11 & Shift+F11. Using --tv --fullscreen still works for me. There are also --desktop & --windowed flags you can use interchangeably.

What is the difference between the "TV" flag and the "desktop" flag? I found that when I used the "--desktop --fullscreen" flags I could get PMP to play full screen on my TV so it kind of behaved like the pre 1.2 version, but perhaps there is something going on I don't understand yet.


#8

@KaraokeAmerica said:

@Xen0sys said:

Plex recently added an alternative Web/Desktop UI mode for PMP which you can switch between with F11 & Shift+F11. Using --tv --fullscreen still works for me. There are also --desktop & --windowed flags you can use interchangeably.

What is the difference between the "TV" flag and the "desktop" flag? I found that when I used the "--desktop --fullscreen" flags I could get PMP to play full screen on my TV so it kind of behaved like the pre 1.2 version, but perhaps there is something going on I don't understand yet.

--desktop uses the Web/Desktop UI while --tv forces the standard PMP TV UI.


#9

Getting a bit sick of these command line arguments!
I just want my PMP to stay full screen and on top.
Full screen worked in previous versions so let it work again now!


#10

@ffhjansen said:
Getting a bit sick of these command line arguments!
I just want my PMP to stay full screen and on top.
Full screen worked in previous versions so let it work again now!

You can try tweaking C:\Users\[USER]\AppData\Local\PlexMediaPlayer\plexmediaplayer.conf

"preventSystemScreensaver": true,
"alwaysOnTop": true,
"fullscreen": true,


#11

@Xen0sys said:

--desktop uses the Web/Desktop UI while --tv forces the standard PMP TV UI.

I'm going to have to play with this more. Right now I'm using the --desktop flag and it looks like it did prior to this latest update. What is the difference between "TV" UI and "Desktop" UI?


#12

@KaraokeAmerica said:

@Xen0sys said:

--desktop uses the Web/Desktop UI while --tv forces the standard PMP TV UI.

I'm going to have to play with this more. Right now I'm using the --desktop flag and it looks like it did prior to this latest update. What is the difference between "TV" UI and "Desktop" UI?

Yeah I don't think your flag is being recognized.


#13

@Xen0sys said:

@ffhjansen said:
Getting a bit sick of these command line arguments!
I just want my PMP to stay full screen and on top.
Full screen worked in previous versions so let it work again now!

You can try tweaking C:\Users\[USER]\AppData\Local\PlexMediaPlayer\plexmediaplayer.conf

"preventSystemScreensaver": true,
"alwaysOnTop": true,
"fullscreen": true,

Thanx @Xen0sys for your advise but the options were already on.


#14

@ffhjansen said:

@Xen0sys said:

@ffhjansen said:
Getting a bit sick of these command line arguments!
I just want my PMP to stay full screen and on top.
Full screen worked in previous versions so let it work again now!

You can try tweaking C:\Users\[USER]\AppData\Local\PlexMediaPlayer\plexmediaplayer.conf

"preventSystemScreensaver": true,
"alwaysOnTop": true,
"fullscreen": true,

Thanx @Xen0sys for your advise but the options were already on.

Submit an issue: https://github.com/plexinc/plex-media-player/issues


#15

@Xen0sys said:

@KaraokeAmerica said:

@Xen0sys said:

--desktop uses the Web/Desktop UI while --tv forces the standard PMP TV UI.

I'm going to have to play with this more. Right now I'm using the --desktop flag and it looks like it did prior to this latest update. What is the difference between "TV" UI and "Desktop" UI?

Yeah I don't think your flag is being recognized.

I am traveling for business right now. I'll look into it more when I get home the end of the week.


#16

I programmed a button which presses CTRL+SHIFT+F but wish it wasn't necessary.

support.plex.tv/hc/en-us/articles/208052807-Controlling-the-App


#17

@tobiashieta is this issue being solved in the next release also?


#18

@ffhjansen said:
I programmed a button which presses CTRL+SHIFT+F but wish it wasn't necessary.

support.plex.tv/hc/en-us/articles/208052807-Controlling-the-App

I haven't tried this, but for any key-combo to work, wouldn't the Plex window still have to be in "focus" in Windows vernacular?


#19

F11 works for what I want, but would rather have hit alt-enter. Oh well.


#20

In 1.2.1 you can set Layout to "TV" (instead of Auto) and then backslash will switch between windowed mode & full-screen like it did in older versions.