Newest version of Plex Media Player broke something on 23.976fps playback

plex-media-player

#1

PMP just auto updated and now playback is horribly jerky when refresh rate switches to 23.976. I found an older version of PMP (2.8 I think) and reverted back to that, and all is well. I then went round to the other 4 machines in the house to stop them auto updating, by amending the conf file, before opening the player.

Windows 10 machine, Nvidia GTX1050 graphics card, not using Open GL, auto refresh rate switching. Everything playing back at 23.976 is very jerky as in unwatcheable. When I get the playback stats up, the clock numbers are miles too high.

I appreciate that this is a bit of a sparse report, but unfortunately, I don't have time to re-install the broken version and collect logs, post them here, and then uninstall it, and re-install an old version that works properly.

I assume I can't be the only one with this issue, so hopefully a developer can re-create it and issue a fix via a new PMP update?

If you do need any more specific details, let me know and I will do my best to get them.

Thanks!


#2

Same issue. Also Windows 10. Nvidia 1080TI. It’s really getting frustrating that with each new version of PMP something new gets broken. 1 step forward, 6 steps back. I think I’m done with PMP. Not worth the hassle.


#3

Can you guys post a logfile ?
Another hint is about the OpenGL flag. Could you try enable or disable it depending on which one you are using ?


#4

@LongChair said:
Can you guys post a logfile ?
Another hint is about the OpenGL flag. Could you try enable or disable it depending on which one you are using ?

Hello LongChair, and thanks for looking into this. I know that asking us to post a log file is a simple request, and if I had more time, I would happily do that. And I am not being deliberately unhelpful as I really want this fixed. But I am just a (paying) end user, and I am a bit frustrated about the issue, as yesterday, after a long day at work, I spent my whole evening on this, and by the time, I had executed a workaround, there was no time to watch any media as I had to get to bed.

This is a busy family household, where we work, and don’t want to use our limited free time in fiddling about with trying to get Plex working properly.

As I said in my first post, after spending considerable time troubleshooting the issue, I decided that the new version of Plex Media Player was just broken. So I got rid of it, from four machines, and rolled back to an older version that I had, luckily, saved in one of the machines download folder.

Why don’t Plex make it easier to find previous versions for when this event occurs?

So, to get log files from the broken version, will mean spending another evening deliberately breaking one of the machines, to get the logs, then fixing it again in order to watch some media. But that will likely take up a second evening, so no time to actually watch any media before bed time.

Back to the matter in hand:

  1. OpenGL has never worked for me with refresh rate switching. When it detects 23.976 fps, it switches the TV to 60hz so the video is always very jerky. I did try this in the new version when I was troubleshooting what the problem was, but that behaviour (with OpenGL) hasn’t changed.

  2. It looks like the common theme is Windows 10, an Nvidia graphics card, and refresh rate switching. That doesn’t sound terribly niche, surely someone within Plex must be able to re-create this issue and get you some logs. Do you not have access to a Windows 10 machine and an Nvidia card yourself maybe?

  3. The developers who rolled out the new version of PMP must have made some changes with the code that effects this, is that you? If not, could that be looked into to get some more info about what has changed?


#5

No issues here with Display Mode Switching on the 2.11 release. Win10, Nvidia GTX1030. (not using opengl)

Also fine on my other Win10 machine with a Intel HD4000


#6

I might have left out another key factor - sync mode: display.

The refresh rate switch does happen, then the video playback is very jerky, the sync mode: display stats (which come up when you press i) show that the clock rate is all over the place and not like it is on previous versions of PMP.


#7

@dan-the-man- said:
No issues here with Display Mode Switching on the 2.11 release. Win10, Nvidia GTX1030. (not using opengl)

Also fine on my other Win10 machine with a Intel HD4000

Thanks for the input, do you use sync mode: display?


#8

nope, just the default setting


#9

@dan-the-man- said:
nope, just the default setting

Interesting thanks, Could you try it on one, or both of the the sync mode: display settings and see if you get jerky playback?


#10

Can I bump this please, will it be looked into? Thanks!


#11

Okay, I have re-created the issue on my work desktop. And I attach the log. The issue is only current with sync mode:display.

Also, with this version of PMP on the Channel tab I get 'The server “undefined” does not support the dashboard

EDIT: I tried to add the log and I get a ‘the file failed to upload’ error - please advise. I converted it to pdf, now it uploads.

So, the native format of the log files that PMP supports, cannot be shared with devs without conversion?


#12

After speaking to someone at Plex via the contact us option, I have been advised that changing the log file extension from .log to .txt means that I can upload it to this forum. Who knew?!

Attached is another log file, with a .txt extension, and a screen grab of the issue in action.

@LongChair can you please confirm that you have what you need to look into this issue. Also, are you able to reproduce it on your systems?


#13

Sync Mode Display (resample) or (drop/duplicate)?


#14

Also I noticed that your HW decoding is performing a copyback. Is Hardware Decoding set to Enabled or Enabled (copy-back)?


#15

@Achilles said:
Sync Mode Display (resample) or (drop/duplicate)?

Both


#16

@Achilles said:
Also I noticed that your HW decoding is performing a copyback. Is Hardware Decoding set to Enabled or Enabled (copy-back)?

Copy Back.

Are you able to reproduce the issue?


#17

@lisagood said:

@Achilles said:
Also I noticed that your HW decoding is performing a copyback. Is Hardware Decoding set to Enabled or Enabled (copy-back)?

Copy Back.

Are you able to reproduce the issue?
Haven’t tried with Windows yet—just embedded and MacOS. When I do it will be on Windows 7 as thats my only machine with a Nvidia GTX 1080. Any reason you are using copyback? It is actually carries a performance penalty.


#18

@Achilles said:

@lisagood said:

@Achilles said:
Also I noticed that your HW decoding is performing a copyback. Is Hardware Decoding set to Enabled or Enabled (copy-back)?

Copy Back.

Are you able to reproduce the issue?
Haven’t tried with Windows yet—just embedded and MacOS. When I do it will be on Windows 7 as thats my only machine with a Nvidia GTX 1080. Any reason you are using copyback? It is actually carries a performance penalty.

Right, I would be interested to hear if you can reproduce the issue on the Windows 7 machine with the new version of PMP. Yes, I have reasons for using copy-back.


#19

I reproduced it on Windows 7, although the measured framerate hovered near 48 and not 36. Using Sync Mode audio did not exhibit the issue. Also using Native OpenGL did not exhibit the issue with any method of Sync Mode. I will discuss with @LongChair.


#20

@Achilles said:
I reproduced it on Windows 7, although the measured framerate hovered near 48 and not 36. Using Sync Mode audio did not exhibit the issue. Also using Native OpenGL did not exhibit the issue with any method of Sync Mode. I will discuss with @LongChair.

Great, the same issue as I reported then.

Do you also get the server undefined error message in the ‘new star’ channel tab?