Working DLNA Profiles

server-dlna

#1

A few rules of the road:

1) Use this thread for working profiles only, i.e. profiles that you've tested and are working well for your device. If you have questions about a specific profile or device, please find or create a separate thread dedicated to that device, instead of commenting here.

2) Our intention is to be able to include these working profiles in future releases of PMS, so please don't include any proprietary IP (whatever that would be). By posting in this thread, you're implicitly granting us permission to redistribute. So if you want to explicitly deny us permission, please say so. And if you want your name or handle in the profile comments for attribution, please do that. We're building an ecosystem here, and we want to give as much credit as possible.

3) Be clear which device the profile applies to. Mention any relevant model numbers, version numbers, etc. And make sure your Identification sections are as unique as possible, so there's no conflicts with other devices people might have.

4) If you have a better profile than one that's already posted, first try to discuss your improvements with the original poster (e.g. via private message) and arrive at a unified profile. That way we can hopefully keep the number of duplicate and/or conflicting profiles to a minimum.

5) If you have a software DLNA client (e.g. on a phone) that needs a profile, feel free to include it as well. This isn't just about devices.

6) If you have questions about how to author a profile, please start a new thread or follow up on the profile authorship thread.


Transcoding while using PMS over DLNA
#2

I've attached a working profile for the American version of the LG BP220 blu-ray player, but it probably isn't appropriate for inclusion in a general release because I wasn't able to detect any unique headers or device information for the player. It relies on a User-Agent header string of "IPI/1.0 UPnP/1.0 DLNADOC/1.50" which allows it to work well in my environment (it wouldn't play any videos before) but looks pretty generic to me, so it might incorrectly match other devices out there. This profile will likely work for other LG blu-ray players too. I have primarily tested this with videos, so if someone finds a problem with other media please let me know. Thanks!

LG Blu-ray.zip (1.13 KB)


#3

Managed to get my Sony BDP- S590 figured out. They pulled support for mp4 over the wire. Pulled out all the mp4/h264 profiles and it started transcoding m2t and worked great. This is a very rough first draft that just works. I'm sure there are more options and better quality to come.


xml attachment failed with "This Upload failed" on both basic and flash upload.

Here it is on my dropbox

https://www.dropbox.com/s/8gnwydo6x1nezs7/Sony_Bluray.xml


#4

Do you guys have a profile for PLEX running on a Synology 412+ to play to a Blu-Ray Player : Panasonic SC-BTT490 ?

Hello, I have been going nuts. Ever since Synology updated to DSM 4.3 and the Media Server app lost video trans coding I can't play .MKV files.

I have downloaded iMediashare, Mediahomepro, and other media streaming apps on my TF700 to try to get it to work.

I finally just now threw my hands up in the air and am using handbrake on my MBP and my PC to convert over 1TB of files.... as I watch them. So dumb. 

I have a Synology 412+.

TV :

<span>Panasonic VIERA TC-L47E50</span>

Blu-Ray Player : 

<span>Panasonic SC-BTT490</span>

#5

Hi,

i want to know if is there any news about making mkv work through DLNA with this Samsung Tv Series?
I've tried different tweaks with the Samsung Tv xml but none of them seems to work.


I've noticed that playing mkv & other formats works well with Synology Video Station & UMS WITHOUT ANY transcode/remux.


this is my configuration :

- plex media server Version 0.9.8.6
- Synology DS112 NAS 4.3 DSM
- Samsung TV UE32ES5500


Thanks!

(sorry for my english!)


#6

Hi

Attached you find the client profile for Popcorn Hour media player:

?xml version="1.0" encoding="utf-8"?>

 
 
   
     
     
   

   
     
   

   
   
 

 
   
   
   
   
   
   
   
   
   
   
   
   
 

 
   
     
       
     

   

 

 
   
     
       
       
       
     

   

   
     
       
     

   

   
     
       
     

   

   
     
       
       
     

   

 


 

Br, Jan


#7

Thanks. I don't have a popcorn hour but i tried your conf. It doesn't work with mkv : wrong format.

Any help with you or other members?


#8

Thanks. I don't have a popcorn hour but i tried your conf. It doesn't work with mkv : wrong format.

Any help with you or other members?

This profile is for Popcorn Hour media player only.


#9

I've noticed that only mkv without embedded subs are working.

Will embedded subs be implemented in the future?


#10

I've noticed that only mkv without embedded subs are working.

Will embedded subs be implemented in the future?

Hi

No, also forced subs are working (srt).


#11

Thanks for your answer. It's a shame, i love Plex it,s almost perfect.

This is DLNA settings from various softwares which are working with embedded subs without transcode (if devs are looking)

Synology media server :

        "profileName":"Samsung TV",
        "dlna":"yes",
        "samsungtv":"yes",
        "profile@MPEG_TS_HD_KO_ISO":"ext@m2ts&ts&m2t&tp&mts&trp#resolutionx@1280~1920#resolutiony@720~1080",
        "profile@NDLNA":"ext@mp4#container_type@mp4#video_codec@mpeg4",
        "profileID":{
            "open_user-agent":"SamsungWiselinkPro/1.0"


samsung DLNA profile from Universal Media Server : 


RendererName=Samsung AllShare
RendererIcon=samsung.png 

# ====================================================
# Reported headers:
#
# User-Agent: SEC_HHP_[HT]D5500/1.0
# User-Agent: SEC_HHP_[TV]UE32D5000/1.0
# User-Agent: SEC_HHP_ Family TV/1.0
# User-Agent: SEC_HHP_[TV]PS51D6900/1.0
# User-Agent: DLNADOC/1.50 SEC_HHP_[TV]UE32D5000/1.0
# User-Agent: DLNADOC/1.50 SEC_HHP_[TV]UN55D6050/1.0
# User-Agent: DLNADOC/1.50 SEC_HHP_ Family TV/1.0
#
# Note: the "[TV]PS51D6900" is the default type name.
# It can be edited via the TV menu into any string.
# ====================================================
UserAgentSearch=SEC_HHP

# Recent firmware (0016 and 0019) has been reported to no longer send additional headers info
# Leaving this in for backwards compatibility with older firmware
UserAgentAdditionalHeader=X-AV-Client-Info
UserAgentAdditionalHeaderSearch=(\w{3}_\w{3}_\w{2}-\w{2}\d{2}\w\d{4}/\d.\d)|(\w{3}_\w{3}_\[\w{2}\]-\w{2}\d{2}\w\d{4}/\d.\d)|(\w{3}_\w{3}_

\w{2}-\w{2}\d{2}\w\d{3}/\d.\d)|(\w{3}_\w{3}_\[\w{2}\]-\w{2}\d{2}\w\d{3}/\d.\d) 

Video=true
Audio=true
Image=true
SeekByTime=false
TranscodeVideo=MPEGPSAC3
TranscodeAudio=LPCM
ThumbnailAsResource=true
DefaultVBVBufSize=true
MuxH264ToMpegTS=true
MuxDTSToMpeg=true
WrapDTSIntoPCM=false
MuxLPCMToMpeg=true
MaxVideoBitrateMbps=25
MaxVideoWidth=0
MaxVideoHeight=0
MimeTypesChanges=audio/wav=audio/L16|video/x-matroska=video/avi|video/x-flv=video/mp4|audio/mp3=audio/L16|video/mp4=video/mpeg
TranscodeExtensions=flv,wav
StreamExtensions=mkv,mp3,mp4,avi,mov
SubtitleHttpHeader=CaptionInfo.sec
ChunkedTransfer=false



Samsung DLNA profile from Serviio : 



    
        

org.serviio.upnp.service.contentdirectory.SamsungDLNAMessageBuilder
        

org.serviio.upnp.protocol.http.transport.SamsungWiseLinkProtocolHandler
        
            
                (^TV-\d{2}C\d{3}.*)|(^\[TV\][A-Z]{2}\d{2}(D|E)[A-Z]?\d{3,4}.*)         

    
                (1\.0)|(AllShare1\.0)
               
            
                
                (.*SEC_HHP_BD-[CDE].*)|(.*SEC_HHP_\[(HT|BD)\][CDE].*)
            
        
        
            
                <sec:ProductCap>smi,DCM10,getMediaInfo.sec,getCaptionInfo.sec</sec:ProductCap>
                <sec:X_ProductCap>smi,DCM10,getMediaInfo.sec,getCaptionInfo.sec</sec:X_ProductCap>
            
        
        
            MATROSKA
            AVI
            FLAC
        
        

org.serviio.upnp.service.contentdirectory.definition.SamsungContentDirectoryDefinitionFilter  
        FILE_ATTRIBUTES
        
            
            
            
                
            
            
                                    
            
            
            
            
        
        
                    
            
        
        true
        false
        
            
            
    



#12

TV: VIZIO E320i-A0

The DLNA profile below works with my VIZIO E320i-A0 although the DLNA client that VIZIO uses is terrible and slow. Additionally the Vizio TV does not show in Device Spy or in the DLNA certified devices list so right now the Identification section is a little sparse. If anyone knows of another way to get the information let me know. Because of this I'm not sure if this profile can be distributed with the main Plex server distribution as I saw in this post above that someone had the same User Agent data for an LG blu-ray player.




    
        

#13

It looks like nobody is forwarding the profiles to the developer.

Too sad about this.


#14

I found a tip that will do the trick : in plex agent move opensubtitles;org in top of the list and refresh movie/show in your library.

It will download and add subtitles to your library and they will be ok in Plex Samsung app (instead of embedded sub)

We jus have to wait next big Plex update.


#15

Please can someone post a working sony bravia 2013 profile for windows plex media server?  :rolleyes:


#16

I´m searching for Profile for my WD TV Live Streaming Media Player (Gen 3)

Thx you guys


#17

Jan Frank:

Thanks for the profile.  However, it will need an identification section.  Can you provide that?

mjarends:

Also, thanks.  If you can get more specific in the identification section, I can include that profile.  That said... Does the mpeg/mpeg2video/ac3 transcode target actually work?  Wouldn't mpegts be more appropriate?

beardez:

Can you PM me with the problem you're having?  The in-box profile should work.


#18

mfeingol:

The TV does not show up in Device Spy. Is there another way in which I can pull the identification information from the TV? The DLNA documentation on the TV is non-existent in Vizio's owner manual.

I tested the mpeg transcode target and it worked successfully (I based it on a working profile from Serviio). I can try with mpegts as well. Is one more efficient to transcode than the other?


#19

mjarends:

If you turn on verbose logging for your PMS, you'll see entries like this in Plex DLNA Server.log:


Oct 22, 2013 10:51:41:320 [48536] VERBOSE - Found device PALANTIR: Media: of type urn:schemas-upnp-org:device:MediaServer:1 with 3 services and uuid 144d1bed-a649-4fc8-ba3b-810ffe7455f3 at http://192.168.11.16:2869/upnphost/
Oct 22, 2013 10:51:41:320 [48536] VERBOSE - Device PALANTIR: Media: has service  of type urn:schemas-upnp-org:service:ConnectionManager:1 with id urn:upnp-org:serviceId:ConnectionManager
Oct 22, 2013 10:51:41:320 [48536] VERBOSE - Device PALANTIR: Media: has service  of type urn:schemas-upnp-org:service:ContentDirectory:1 with id urn:upnp-org:serviceId:ContentDirectory
Oct 22, 2013 10:51:41:320 [48536] VERBOSE - Device PALANTIR: Media: has service  of type urn:microsoft.com:service:X_MS_MediaReceiverRegistrar:1 with id urn:microsoft.com:serviceId:X_MS_MediaReceiverRegistrar
Oct 22, 2013 10:51:41:320 [48536] VERBOSE - 3 distinct DLNA devices on network
Oct 22, 2013 10:51:41:321 [48536] VERBOSE - Mapping device: 192.168.11.16 to device 'PALANTIR: Media:' of type 'urn:schemas-upnp-org:device:MediaServer:1' with uuid '144d1bed-a649-4fc8-ba3b-810ffe7455f3'
 
If your Vizio shows up here, then we'll have more data.
 
WRT mpeg vs. mpegts, go with mpegts if it works.

#20

mfeingol:

Just re-tested the DLNA profile by changing the container to mpegts and the entries no longer show up in DLNA. It looks like the Vizio DLNA client only supports playing the mpeg container. Also even after turning on verbose logging the Vizio TV never shows up as a DLNA device when Plex starts. I'm guessing that I won't be able to obtain any more identifying data for the TV. I would tell most people to stay away from it thought as a DLNA client.