Any video with EAC3 audio fails to play

server-docker

#1

Running plex from following image:

https://hub.docker.com/r/linuxserver/plex/

Plex Version 1.9.1.4272

Sep 23, 2017 01:12:30.006 ERROR [Transcoder] Error while decoding stream #0:1: Input/output error
Sep 23, 2017 01:12:30.004 ERROR [Transcoder] [eac3_eae @ 0x150d760] error reading output
Sep 23, 2017 01:12:30.002 ERROR [Transcoder] [eac3_eae @ 0x150d760] EAE timeout! EAE not running, or wrong folder? Could not read '/tmp/pms-66181c4b-c3d6-4b37-b6a2-67b8556d1c86/EasyAudioEncoder/Convert to WAV (to 8ch or less)/030kau81ld0a3bf2eyuxzufr_626-1-21.wav'


#2

Found a fix

Delete codecs folder:

\plex\Library\Application Support\Plex Media Server\Codecs

Restart the docker image and it fixes the issue


#3

Actually i have the same problem.
A restart of the container solves the issue for a while.
But it constantly comes back.


#4

You might want to check your logfile for entries like this:
8192 matches [Notify] Now watching ... 3400 matches [Notify] Failed to add watch for ...

On my system the fs.inotify.max_user_watches was set to 8192 by default. Which is a rather small setting for a large library.
Thus, every registered notification above 8192 simply failed due to os system settings. "Now watching" relates to a filesystem watcher event.

If the same applies to you, see: http://forums.plex.tv/discussion/comment/1419397/#Comment_1419397


#5

@kopfpilot Actually, the problem was with what the eac3 encoder used as a transcode folder.
It used the /tmp directory even though i set the transcode directory to /transcode, which the eac3 encoder didnt adhere to.
So i had to add another volume in the config for the /tmp directory, after that it didnt throw anymore errors


#6

@kopfpilot said:
You might want to check your logfile for entries like this:
8192 matches [Notify] Now watching ... 3400 matches [Notify] Failed to add watch for ...

On my system the fs.inotify.max_user_watches was set to 8192 by default. Which is a rather small setting for a large library.
Thus, every registered notification above 8192 simply failed due to os system settings. "Now watching" relates to a filesystem watcher event.

If the same applies to you, see: http://forums.plex.tv/discussion/comment/1419397/#Comment_1419397

Sorry for missing this.

If you want to increase that value above the default (e.g. 65536) , as root:

echo   "fs.inotify.max_user_watches=65536" >> /etc/sysctl.conf
sysctl -p

#7

@mikefallen said:
Found a fix

Delete codecs folder:

\plex\Library\Application Support\Plex Media Server\Codecs

Restart the docker image and it fixes the issue

Thanks heaps!!!
I recently updated my docker and had the same issue with video files not transcoding when they had EAC3 audio.
I manually set the plex docker to the previous build, deleted the files you mentioned, then started the docker again.
Played the same files, and they started being able to be transcoded again.
Seems to be caused by the latest build (at least for me).