Apple Remote with High Sierra not working

plex-media-player

#1

Hi everyone!

I have updated my Mac Mini to MacOS High Sierra, and when I want to use the apple remote as normal, the up/down buttons are not working but the others are working. I try the up/down buttons in mac without plex and I don't have this issue so is just with plex player.

Could you fix this issue?


#2

Also having this problem. I have tried remapping the buttons but do not know and cannot find the new codes for up and down.


#3

Hey,

I had the same problem and it's easily solved. You need to install https://www.iospirit.com/labs/candelair/

The problem is the IR driver for macOS. This is a replacement driver that makes the remote work how you would expect.


#4

Hmm, I tried updating to the driver you mentioned, but it didn't work for me.

That said, it looks like Kodi ran into exactly the same issue and I ported that code over to the OpenPHT code base (pull request here: https://github.com/RasPlex/OpenPHT/pull/272).

Hopefully the maintainers can get that in sooner than later.


#5

Any advance on a fix for this? Since installing High Sierra, the (old) silver remote does not work? Developers?


#6

I am having the same problem, you cannot navigate up/down which makes using the remote impossible.

Please help


#7

Same here. Plex fix this please.


#8

@“Troy Rippin” said:
Hey,

I had the same problem and it’s easily solved. You need to install https://www.iospirit.com/labs/candelair/

The problem is the IR driver for macOS. This is a replacement driver that makes the remote work how you would expect.

This is great for the new OS but Plex still does not respond to the up or down clicks from the remote. PLEX please fix this…


#9

Looks like the release notes for Plex 2.2 Beta says there is a “speculative fix” which addresses this?

Reference (third bullet in the “Fixed” section): https://forums.plex.tv/discussion/comment/1574271/#Comment_1574271

Can someone with Plex Pass who gets this issue (OSX High Sierra, Apple Remote Up/Down not working) try loading the 2.2 Beta and let us know if it gets resolved?


#10

No luck with the latest beta version 2.2.1.758-5dad2d62 still no up/down function on high sierra with apple remote.


#11

Likewise have the same issue :frowning:


#12

They replied to me on Twitter that they fixed it for the beta available only for Plex users


#13

Anyone knows where to find this beta? Tried the August beta but cannot find the December one that is supposed to fix the issue


#14

I could really use this as well. Any help is appreciated. I tried candelair and now my remote doesn’t work at all and there is no remote options in system preferences --> security --> advanced. When going into system preferences --> candelair it just has an option to restart. After restarting it still says restart.


#15

The dissapointing thing is that they don’t want to acknowledge the issue calling it “Speculative fix for user reported trouble pressing Up and Down on silver Apple IR remotes when using a Mac Mini running High Sierra”


#16

Hesitate to just add a ‘me too’ comment, but couldn’t see a way to upvote this. Unusability of the remote control is a pretty catastrophic issue for a Home Cinema system. Any word on a fix ?


#17

Same here, lifetime plexpass, wish I had not upgraded to High Sierra and got rid of good old plex home theater but everything else seems to be working, but being able to press “menu” and have it open plex, then being able to navitgate with my apple remote is pretty important to usability of things. Hopefully we can get back to that working??


#18

Same here, also lifetime user… Remote has been useless since High Sierra install which has been out since September last year! …also latest version occasionally crashes on Plex screen saver… System - quad core i7 MacMini with 16GB RAM… I’ve been using Plex since the early days but without a remote, in HT mode, it’s a pain in the ■■■■.


#19

A bit of twitter shaming would not hurt guys


#20

Updated to High Sierra this week and experiencing the same issue. I have the same hardware setup as @himey. @pcolom1, I am running the last build of PHT and the up and down arrows don’t work either so it’s not limited to PMP nor OpenPHT.