OpenPHT 1.8.0 and High Sierra Remote Issues

openpht

#1

Hi

Apple seems to have change the way the remote works on High Sierra. My Harmony remote stopped working correctly after the upgrade. Up, Down and Back are some of the keys that are not working.

I tried the candelair driver and it didn't work. Is there any other means to solve it ?

Thanks


#2

Hi

should be this issue here

https://forum.kodi.tv/showthread.php?tid=322037

unfortunately there likely no short term fix for this in openpht from the dev


#3

One user has submitted a fix for this.


#4

I’m running OpenPHT on a MacBook Pro with a Logitech Harmony remote.

Is this one of those issues that affects a handful of people under certain circumstances, or is it pretty much guaranteed that if I upgrade to High Sierra my remote WILL break? I had planned on upgrading but can’t be without a remote for Plex.

I previously figured out how to modify the joystick.Harmony.xml file to remap my remote. I don’t suppose this issue can be solved by remapping the remote?

I know nothing about coding so I don’t understand the “fix” that was posted above, or what to do with it. Is there a fix that is simple enough to be explained to dummies like me?


#5

@clnr said:
One user has submitted a fix for this.
https://github.com/RasPlex/OpenPHT/pull/272

someone try this ?

i can try if you want but don’t kwow which file i have to modify this way :smile: https://github.com/xbmc/xbmc/commit/1c85ba7f44ba9ffe070a732458c105c8025d7157#diff-a3653327954a5d04a64240f50103ec0d

i imagine that this file : tools/EventClients/Clients/OSXRemote/HIDRemote/HIDRemote.m is the path in xboxMediacenter, but in Plex where is the config file … ?


#6

Does anyone know if this might make it into a hot fix in the near future, or is it looking more like we’ll need to wait for the fix to get merged into the Open PHT 2.0 branch? Or is it a relatively easy thing to self-modify on 1.8 by altering a preference file or…? Being an Open PHT user with a Harmony remote, running Plex on a Mac Mini, this is the one thing scaring me off from upgrading to macOS. :#


#7

Check out Remote Buddy… have been using for years and is seriously the best thing for your mac HTPC … amazing and highly customisable app and highly useful beyond Plex.


#8

Does this issue still exist? And if so, what’s everyone’s preferred solution (trying to manually implement the fix from Github, or trying to work around the problem with Remote Buddy, etc.)?

I still haven’t upgraded MacOS High Sierra yet - all because I’m worried that it’s gonna break my Harmony Remote’s compatibility with OpenPHT :’(


#9

On my side I went back on Mac OS Sierra (not high sierra).

Otherwise the following three solutions were not too bad:

  • on high sierra, use remote buddy (but paying)
  • on high sierra, use the Codi player with the plex plugin and the plex server (but I did not have access to the back button which makes a rewind of 7 seconds on a media)
  • the update of plex media player which worked well (but I did not have access to the key back which makes a rewind of 7 seconds)

In spite of everything I appreciate more:

  • Mac OS Sierra
  • Plex Home Theater
  • PLex Media Server
  • Logitech Harmony (with the rewind button 7 seconds running)

I hope that there will be a new solution on max OS 10.14