Buffalo Linkstation Pro Duo with Plex Media Server

other-third-party

#1

[UPDATE]

Plex Media Server 0.9.12 is added to the firmware.
Regular updates on new versions and details of the development is available on the project blog.

---

 

Hi,

 

I've created a version of the Plex Server for the Buffalo Linkstation Pro Duo. Here is the page with the details and the download link at the bottom.

 

The main changes compared to the original firmware is that you can turn on Plex on the MediaServer page and you can launch the Plex web interface from there, by pushing a button.

You can also enable/disable Advanced Power Management on your hard drives. It is advised to disable it, if they aren't already.

 

Many thanks to Orca for supporting and improving the Samsung TV Plex application, I wouldn't have started this if he wasn't there.

 

Please try it and send feedback.

 

- GaryT


#2

Thanks Gary for this. I have the LS-WVL and I did  the 1.68 update, but I'm not able to see the PLEX option under MediaServer. I went through every section and didnt see it at all. Was there anything else I needed to do after the update? I may have missed that.

Thanks.

Capture_zps72508aff.jpg


#3

Hi TeknoBlast and thanks for trying Buffalo + Plex. You are on the right page and I see you have the Orca version. Most probably you need to do a settings reset at System -> Restore/Erase -> Restore Linkstation but let me confirm that before you erase your settings. (If you don't have any data on the NAS, please try it.) I'll get back to you with my findings.

Other features are not affected, the NAS should be usable in every other way. (Although for me Plex is THE feature I need on it. :) )

- GaryT

EDIT:

I tried reverting my test device to the original firmware, clearing out all the settings and then doing an upgrade to the Orca firmware but it shows up properly for me.

Please try the following things:

1. Do another upgrade, with the following difference:

 - when you run LSUpdate, go to the window's own menu and click the "Debug..." option.

 - On the menu that appears, turn on the "Force Update option" and click OK to close the debug window.

Now you can run Update.

2. Do a settings clear by going to System -> Restore/Erase -> Restore Linkstation. This will have the following effects:

- Your web interface settings are going to be cleared and reset to default. This includes timezone, character encoding, services turned on/off and the admin password too, which is reset to the original 'password'.

- Your files and Shared Folders are NOT affected, they will remain on the machine.

Since I couldn't reproduce the issue, this would be a great help even if you can only do number 1. I'll continue to try to reproduce the issue.

- GaryT

EDIT2:

I think I found your issue. I could only reproduce it when I didn't clear my browser cache properly after the upgrade. The browser caches some of the Buffalo site javascript files. Can you please clear your cache and check if that solves it? Also, check your System -> Storage page, your APM column should also show up for the hard drives.

- GaryT


#4

Thanks, I'll try that tonight after I get home from work. Hopefully clearing the cache and option 1 will take care of it.


#5

I've released the Mac updater for people that want to upgrade their Buffalo Linkstation using an Apple OSX device. It can be downloaded from the same page here.

TeknoBlast's issue was definitely because of the browser cache, please make sure you clear your browser cache after upgrade. This is now indicated on the project page too.


#6

Hi, 

I have my plex server up and running on my linkstation, all I get is transcoding not available when I try and play any some files through the web on my pc and on my android device through the plex app. is there a way to force direct play or completely disable transcoding?

edit: I think I may need to format my file names correctly first. Some things work but with wrong names and its combined different shows into one of different qualitys (if that makes sense)

Thanks


#7

Hi McKnight,

Cleaning out your file names is always a good idea, regardless of your issue. :)

Forcing direct play or disabling transcoding is entirely up to the client. Try downloading the Plex Home Theather application to your machine and you will see that it will play all formats because the PC can play anything without transcoding. The web client only played H.264 for me which is natively supported by Chrome (my choice of browser). The same happened to my original iPad, it plays 720p movies with H.264 encoding well but it can't play standard movies with DivX encoding from the Buffalo because Apple doesn't support it. It doesn't make any difference if you force direct play, it is already forcing itself. The client and the server is trying to figure out the best way to play things and the Linkstation as server will state it does not support transcoding, so all that's left is for the client to list what formats it can play natively.

Unfortunately such small devices like the Buffalo Linkstation is not going to support transcoding for a very long time which is a polite way of saying never. This is coming from the developers of Plex, there's nothing I can do about it. There's a thread about it somewhere on this forum.

The original intention for the firmware was to enable Samsung TV users to watch movies without a computer running, if by any chance you have one that calls itself Smart, the Plex client is free to download and it plays virtually anything I throw at it.

Either try to make your media in H.264 or use a client that supports most formats. I only know the Samsung TVs and the Plex Home Theather application that can do this.

Regards,

- GaryT


#8

I have a chromecast on my tv so I was going to use the plex android app to cast to the tv. Is there a list of supported formats for the android app? The majority of my downloads are 720p MKV files.


#9

Chromecasts support the following formats for video:

- H.264 4.1,4.2 and 5

- VP8

For audio it supports several AAC codecs, MP3, Ogg Vorbis and WAV (uncompressed audio).

You can find more detailed information on https://developers.google.com/cast/docs/media

As for video containers (AVI, MKV), I'm not sure but my guess is that Plex should be able to extract the video from the container without transcoding, maybe someone from the development team can answer that.

[EDIT]

I've had the chance to test files against some devices, playing files from the Linkstation:

Roku (Stick), original iPad, Chrome 38.

All of them play MP4 containers with H.264 encoded video and AAC encoded audio from the Linkstation. I have tried 480p, 720p and 1080p movies without issues except for the largest (1080p) movie, which had issues on the original iPad. Most probably the device is under powered.

Only the Roku played the same codecs with the MKV container.

I tried an MKV with H.264 video but AC3 audio, none of the three played that. I have tried AVI with MPEG4 video codec and MP3 audio codec but none of the three played that.

Then I fired up the Plex for Home Theather application which was able to play all movies regardless of codec or container (my PC is an old Core2Quad).

I also turned on my Samsung TV and it also played all the files fine.

So, stick to MP4=H.264+AAC for mobile devices but your PC or Samsung TV will play everything fine.


#10

Is there any way to update to the latest version?

https://plex.tv/downloads

I'm using XBox One client plex app but it requires 0.9.10 version or above.


#11

Hi UndodgyCoder,

Thanks for trying Buffalo + Plex. I was already testing a new development version of the firmware with Plex Media Server 0.9.11 (the latest release) when I found out that Buffalo also updated their firmware to v1.69 (yesterday). I would like to integrate the two together and if Buffalo didn't do many changes, I should be able to do that over the weekend. Stay tuned, it's coming.

Regards,

- GaryT


#12

Hi GaryTomato,

I should be the one thanking you for your awesome work. You rock, mate!

I'm looking forward to it.

Cheers!


#13

Thanks for your work Gary, I haven't had much time to try and sort it out yet but thanks for testing it out.


#14

Hi GaryT,


Excellent work. I have a terastation Is there any way of installing this firmware on my device. I understand it's a long shot, however the idea of having a dedicated plex server on my nas is a compelling idea as it would mean I don't have to leave my laptop on. If there is no way of flashing my device with this firmware as it not a linkstation is there a work around of getting plex on my terastation. I am struggling to find any answers and you seem like the person with the knowledge base that can direct me in the right direction if it is at all possible. Many thanks in advance


#15

Hi Tony,

Originally I thought this shouldn't be a problem as I used some TeraStation code from the Buffalo NAS-Central site to make the firmware programmable, but after looking at the BuffaloTech site, now I'm not sure. Let's try to figure out exactly which product you have.

The latest TeraStations on the BuffaloTech site are TeraStation, Terastation 1000/3000/5000/7000. Which one is yours? There could be older versions that don't show there, can you get the exact model number?

According to the Buffalo site, the following devices use the same firmware:

LS-XHL,LS-CHL,LS-WXL,LS-WSXL,LS-SL,LS-AVL,LS-VL,LS-WVL,LS-QVL,LS-XL,LS-YL,LS-WXBL Series

The Orca firmware should be compatible with all of them but since I had no way to test it, I'm only telling people it definitely works on the Pro Duo. (LS-WVL) Tim on my blog is going to test it with the Pro Quad (LS-QVL) which is on the list.

Regards,

- GaryT


#16

Gary thank you for the reply the model of my terastation is ts-xl/r5. I was hoping the firmware would work. How can I force the firmware to install so I can test it. Also where can i/make a donation for your work many thanks


#17

I have updated the LSUupdater.ini file so the LSUpdater can find the terastion and is currently updating the device. Hopefully all goes well. I will keep you posted


#18

Hi Gary. Unfortantly on reboot the terastation is stuck on initialize sata 3channel. I will have to try and see if I can install the original firmware somehow. If you have any advice it would be much appricated. Many thanks in advance


#19

Just got around to mess with it today and I didnt have to do anything. I logged into my NAS from another computer and the PLEX client was there along with the other media items. So I'm all good here. Thanks all.


#20

Hi Gary. Unfortantly on reboot the terastation is stuck on initialize sata 3channel. I will have to try and see if I can install the original firmware somehow. If you have any advice it would be much appricated. Many thanks in advance

 
Hi Tony,
 
I'm sorry to hear about your troubles, unfortunately this firmware was not meant for the Terastation TS-XL. I have looked up the specs and Plex is compatible with it but we need to look into putting it onto the Terastation firmware. I don't own one (yet), so this will have to wait.
 
As for fixing your NAS, please download the original firmware for your NAS and try to upgrade to it. You might need to modify the TSUpdate.ini as (VersionCheck = 0 and Debug =1 under [Specialflags]).
 
Is this your NAS: http://www.buffalotech.com/products/network-storage/professional-and-business-class-nas/terastation-iii-1
On the "Downloads" tab you will find the latest firmware for your device (v1.64).
Documents: (not much on upgrades): http://d.buffalo.jp/TS-XL/
 
Please send feedback if it was successful. There's a weird "TFTP" method for flashing firmwares but we'd rather check it out in more details before you go down that route.
 
If you are still interested in donating, I have a donate button on the bottom of the page of the firmware. All donations go for the support of this and other Linkstation firmwares. My current goal is to get enough money to buy another type of Linkstation NAS so I can test the firmware on different devices. (suggestions on what to buy are welcome. ;))

Here's the link to donations:

Donate