DS218+ hardware transcode, not working.

server-synology

#1

Using PlexPass, version 1.11.2.4772-3e88ad3ba, up-to-date DSM 6.1.5-15254
installed the 64 bit version

I'm not able to do transcoding in hardware. The CPU is too slow to do it in software, but I was hoping to get 1-2 1080p h.264 streams to transcode.

Anyone know if there is something I need to do, a setting to enable etc etc?

Thanks


#2

Settings - Server - Transcoder - Use hardware acceleration when available


#3

ok, so that was enabled. disabled it, restarted, enabled it, restarted. nothing. Removed plex from the nas, reinstalled from the pkg, enabled hardware accell and now it’s working.


#4

You updated your DSM, didn’t you?

Synology rewrites the hardware access rules, which include the GPU, with each update. There’s nothing I can do to prevent it either.

Uninstall, reinstall, writes the rules again.


#5

I didn’t update DSM.

is the uninstall/reinstall the only option?


#6

Yes, I write the udev rules during installation (as root) which PMS needs to access the GPU. PMS doesn’t run as root and needs them.

Edit: Your metadata (library) is safe. I don’t delete it. programs are stored in a different location than data


#7

Perhaps a script that can be scheduled to run after and update to reset the udev rules after and update could be provided? Just have to set up the scheduled task manually?


#8

I’ve tried to get a way to create a Scheduled Task from the command line. They don’t provide the tools (commands to do it) nor do we get any notification that DSM was updated. I would have to track the changes by querying the version file with each PMS start.

The earliest I can detect I could detect such a change (either permission loss or DSM update) is when PMS starts but by then it’s already too late. The needed rule file (which is only installable by root during installation) is gone. PMS is about to launch but the process is already running as unprivileged user plex.


#9

Great information. However, I’m experiencing the same issue as OP that wasn’t resolved by uninstalling / reinstalling PMS.

Here’s what I’m working with:

  1. Plex Version 1.11.3.4803
  2. DSM 6.1.5-15254 Update 1
  3. DS218+ (INTEL Celeron J3355)

The issue is hardware transcoding does not show up as an option. Here’s what I see:

As suggested I:

  1. Stopped PMS
  2. Uninstalled PMS
  3. Deleted the Plex user account (but did not remove the Plex shared folder)
  4. Reinstalled PMS

Unfortunately, hardware transcoding is still not an available option.

I’ve attached my logs in case they’re helpful. Are there any additional troubleshooting steps I can try?


#10

@aaronwolen

Thanks for posting your logs with your OP.

Good news. Easy resolution here.

  1. Don’t download Plex from Synology. They only offer the 32 bit version. Hardware transcoding requires the 64 bit version.
  2. Download what you need from plex.tv/downloads Synology -> DSM 6+

Your logs verify you have the 32 bit version. It should say X86_64

Feb 27, 2018 13:16:53.208 [0xf3111b40] INFO - Plex Media Server v1.11.3.4803-c40bba82e - synology DiskStation i686 - build: linux-synology-i686 synology - GMT -05:00

#11

Yes! You’re on fire!

I thought by manually installing the updates I was installing the correct versions from Plex, rather than Synology. My mistake. Now that I am actually using the correct version can I still download updates from the PMS notifications indicating a new version is available? Or will I always need to download directly from <plex.tv/downloads>?


#12

Now you caught me in a meeting :slight_smile:

At plex.tv/downloads you will see both Plex Pass (beta) and Public.

When a beta is available, it will be higher than Public. This gives you the option to try one but have public to fall back to.
I personally prefer to keep a copy of what you know works for you handy. (I recommend it as well).

PMS won’t self-install on Linux. I personally prefer to download myself so I know what i’m getting. (I have so many ‘try this’ stuff floating around it gets confusing too >:) )


#13

@aaronwolen said:
Yes! You’re on fire!

I thought by manually installing the updates I was installing the correct versions from Plex, rather than Synology. My mistake. Now that I am actually using the correct version can I still download updates from the PMS notifications indicating a new version is available? Or will I always need to download directly from <plex.tv/downloads>?

If you get the update message in Plex, you can click on it to download and it will download from plex.tv, not Synology.

The version found in Package Center > Multimedia (when Plex is NOT installed) is provided by Synology and in general they only update it when it becomes incompatible with DSM.


#14

Thank you both so much for the help. I can’t tell you how satisfying it is to finally see a (hw) next to my transcoding status.


#15

Hello all. I have exactly the same problem as Aaron. But I don’t really understand how you solved the issue. I had plex server installed trough the synology app store, I noticed it was 32 bits and an old version. So I removed it thought the app store downloaded the 64 bits version from the plex website and installed it manually using the “manual install” function in the app “store”. But still I don’t have the hardware acceleration button.

What am I doing wrong??

Thanks!


#16

Sorry, I forgot to attach my logs. Please find them attached to this post.

Version dowloaded and installed: PlexMediaServer-1.11.3.4803-c40bba82e-x86_64.spk


#17

Have you enabled ‘Use hardware acceleration when available’ in Plex settings > server > transcoder?


#18

@bboudewijns said:
Hello all. I have exactly the same problem as Aaron. But I don’t really understand how you solved the issue. I had plex server installed trough the synology app store, I noticed it was 32 bits and an old version. So I removed it thought the app store downloaded the 64 bits version from the plex website and installed it manually using the “manual install” function in the app “store”. But still I don’t have the hardware acceleration button.

What am I doing wrong??

Thanks!

Hardware transcoding requires an active Plex Pass subscription. As I see your account here, you do not currently have one. Is this correct?


#19

Thanks a lot for your reply. That I didn’t know. Took a pass subscription and now the check box is there.

Thanks again!


#20

You should sign out and back into the forum as well.

It does not yet show your active Plex Pass. Sign out/in refreshes and the forum will let you into all the Plex Pass areas of the forum.