Edited Fields Don't Stay Locked

plex-web

#1

I have an obnoxious issue (as well as a friend) with the Plex Web App, which started happening earlier this year seemingly limited to fields in the "General" and "Tags" sections of movie library metadata. I'm currently working around it somewhat reliably but that makes the issue no less aggravating.

My process for now is to, say, move the (new) file "From Russia With Love (1963).mkv" to my storage device, "Scan Library Files" (for just the one library), and once it finishes successfully matching and processing, I click the pencil icon in the corner of the movie's poster (from the home screen), capitalize a word in the title (lock icon goes orange as expected), click over to Tags and add/remove a thing or two (lock icon goes orange as expected), choose a poster and a background, click Save, and all is well.

However, when I immediately click the edit pencil again, while my changes are still present, the lock icon is no longer orange, meaning the next time that data is refreshed (by the butler or otherwise), the changes to the title and the tags will be lost/reverted (poster and background changes always remain, without issue). This tells me it's likely an issue with the lock feature, as if I simply click the lock icon next to the fields I've modified when I view them that second time, and click Save a second time, everything finally sticks. But that's of course very silly and very time consuming, and needless to say, I'd love to go back to everything working/saving as it should. Thoughts?

Side Note: Every time I scan a library, it first auto-refreshes the last movie that I viewed the full/details page for, instantly eliminating the changes I've made if I haven't re-clicked the lock icons as described above. Likely a separate issue (auto-refreshing the last viewed item on library scan), but it adds to the frustration of the aforementioned issue, so I figured I'd mention it in case it helps in any way.

Thanks! :)


#2

I've noticed this behaviour and think I've sussed it....

You must click 'Save changes' BEFORE you move off the 'General' section part of the edit dialogue box. This should then remember your locked items. Then reopen the box to do tags or similar.

The dialogue box does not seem to work the same as a standard PC box..... which would save all the changes made in any section of the box when you clicked 'Save changes'. PLEX seems to save just those items that are visible when you click Save changes'

Hope that's it...


#3

@geoffmozz said:
You must click 'Save changes' BEFORE you move off the 'General' section part of the edit dialogue box. This should then remember your locked items. Then reopen the box to do tags or similar.
Unfortunately, that process would add even more clicks/time beyond what I'm already doing, but thanks! :)

@geoffmozz said:
The dialogue box does not seem to work the same as a standard PC box..... which would save all the changes made in any section of the box when you clicked 'Save changes'. PLEX seems to save just those items that are visible when you click Save changes'
It worked as expected before this issue began, so I'm certain that they intend for you to be able to click Save once and have it commit all changes, I think it's just a bit broken at the moment, unfortunately.


#4

Agree that this behaviour is bad....I find it a pain in the ***. I'm using vers 3.9.1 and it's how it works as far as I can tell


#5

Same problem here. They stay locked until something changes the locked status back to unlocked.
It usually happens in a matter of hours.
This is a major pain!


#6

see https://forums.plex.tv/discussion/comment/1547066/#Comment_1547066


#7

@OttoKerner said:
see https://forums.plex.tv/discussion/comment/1547066/#Comment_1547066
Appreciate the info, but this is occurring on every single file added, 100% of which are straightforward, normal, highly matchable items. The workaround I described above is still my most efficient "solution", but the fact that this is still a problem makes me wonder if the right people are even aware of it.

I just got done adding ~30 items in fact, and I had to go back into each. and. every. one. a second time to "commit" my changes. So ridiculous.


#8

@"Baby Fishmouth" said:
I just got done adding ~30 items in fact, and I had to go back into each. and. every. one. a second time to "commit" my changes. So ridiculous.

This doesn't sound right.
If you say that your movies are regularly named, why is there the need to manually edit anything?
May I see a set of log files please?
1. activate debug logging (not 'verbose'!)

2. quit Plex Server
3. wait 1 minute
4. start Plex Server
5. wait 2 minutes
6. either refresh one movie or add one movie into your library
7. wait 3 minutes
8. fetch log files and attach them here


#9

If you are pasting the change I found that it doesn't register that a change has been made in the box unless you do manual typing (I lost a lot of changes that way).
You have to manually enter something (like a space) then delete it for the box to register that you have typed something, then the lock appears


#10

@OttoKerner said:
This doesn't sound right.
Try it yourself, using the steps I described in detail in the original post. I see no reason why you wouldn't be able to reproduce it, the issue isn't unique to me.

@OttoKerner said:
If you say that your movies are regularly named, why is there the need to manually edit anything?
Maybe I like every word in a movie's title to begin with a capital letter. Maybe I want to label a movie as a Director's Cut. Maybe it doesn't matter why.

@borochris said:
If you are pasting the change I found that it doesn't register that a change has been made in the box unless you do manual typing (I lost a lot of changes that way).
You have to manually enter something (like a space) then delete it for the box to register that you have typed something, then the lock appears
Yeah, I've seen that behavior in the Summary field, but the Title and Genres fields flip orange immediately upon any modification, so it's unfortunately not that particular issue (although I'd love to see that one fixed as well).

Safe to say after 8 months that nothing's going to be done about this, I guess. Shame, as it's probably a very simple fix. :/