EPG fails to update

server-docker

#1

I just updated to the latest plex dvr and now my epg won't refresh. any suggestions? 12/10/2017


#2

I have this problem too.


#3

Mine is stuck at 3% for the last week or so.


#4

After the recent update, I'm unable to refresh EPG. Anyone else having this issue. I've restarted the server, deleted my hdhomerun and re-added it. Still, no luck.


#5

same here, no EPG and when I click on the HD Homerun Manage Channels in PMS I cant select a "guide channel" from the drop down box. I'm running PMS 1.10.1.4602
EPG is using DVR YOUVIEW GRANADA NORTHWEST
please can someone from PLEX help!


#6

Mine will not update either. i have tried uninstalling and reinstalling the dvr and its still not updating


#7

@ugh1nr said:
Mine will not update either. i have tried uninstalling and reinstalling the dvr and its still not updating

Linking to your other posts where you said a reboot fixed it
http://forums.plex.tv/discussion/308210/is-there-an-issue-with-the-latest-release-with-the-program-guide-not-updating#latest


#8

Having this same issue, rebooted both Plex and HDHomerun several times. Stuck at 3%..


#9

I also have the same issue that a reboot isn't fixing.


#10

This is frustrating. I am on version 1.11.3.4803 the the program guide keeps going away and coming back and when it comes back some of the programming information is missing.

It seems that when the sever refreshes the EPG and it can't do so it deletes all the guide information making the DVR recording useless.

This has been going on for days


#11

There is a Gracenote issue that is awaiting a fix to be released. See this forum thread
http://forums.plex.tv/discussion/306340/there-was-an-unexpected-error-loading-the-program-guide-and-more-errors

This specific problem has been seen on systems with 300+ channels

If it is happening with less number of channels, please provide logs
See
https://support.plex.tv/articles/201643703-reporting-issues-with-plex-media-server/
https://support.plex.tv/articles/200250417-plex-media-server-log-files/


#12

I am running two HD Homerun extend over the air tuners. Each has 52 channels.
I did a Refresh Program Guide and captured the log which is posted here.
I don't know enough to know what to look for so hopefully you spot the cause.


#13

@"an39511@ohioshore.com" said:
I am running two HD Homerun extend over the air tuners. Each has 52 channels.
I did a Refresh Program Guide and captured the log which is posted here.
I don't know enough to know what to look for so hopefully you spot the cause.

Thank you - very useful. There appears to be an issue with CloudFlare. It has been referred to their support team


#14

I seem to be having the same issues since the last PLEX update. I have been able to manually force it to load by deleting the saved EPG file in the plug-ins folder and restarting PLEX. Basically starting from scratch.

Version 1.11.3.4803


#15

@Burning_Beard said:
I seem to be having the same issues since the last PLEX update. I have been able to manually force it to load by deleting the saved EPG file in the plug-ins folder and restarting PLEX. Basically starting from scratch.

Version 1.11.3.4803

There are currently two issues affecting the EPG updates
- a Gracenote issue seen on systems with 300+ DVR channels giving a JSON Parse Error
- a Cloudflare issue giving a rate limiting error and also leading to a JSON Parse Error in the logs

For the gracenote issue, deleting the DVR and recreating or deleting the EPG database or reducing the number of channels would get round the problem. A fix is being produced by Gracenote

The CloudFlare issue is under investigation

Logs would show which of the two it is for your failures

https://support.plex.tv/articles/201643703-reporting-issues-with-plex-media-server/
https://support.plex.tv/articles/200250417-plex-media-server-log-files/


#16

Deleting just the EPG guide seemed to fix my guide not updating. On Linux it was located under /var/lib/plexmediaserver/Library/Application Support/Plex Media Server/Plug-in Support/Databases/tv.plex.providers.epg.onconnect*


#17

Sigh - just waited for EPG to update only to get a blank guide. This is latest Plex on windows. Should I delete the EPG and how?

NM just found the path: C:\Users\jkensy\AppData\Local\Plex Media Server\Plug-in Support\Databases

I deleted the tv.plex.providers.epg.onconnect* files. Interestingly, prior to deletion, the EPG % would just rocket to 3%. This time it climbed 1%, 2%, etc. We'll see.

It worked! Shows trickling in!


#18

@sa2000 said:

@Burning_Beard said:
I seem to be having the same issues since the last PLEX update. I have been able to manually force it to load by deleting the saved EPG file in the plug-ins folder and restarting PLEX. Basically starting from scratch.

Version 1.11.3.4803

There are currently two issues affecting the EPG updates
- a Gracenote issue seen on systems with 300+ DVR channels giving a JSON Parse Error
- a Cloudflare issue giving a rate limiting error and also leading to a JSON Parse Error in the logs

For the gracenote issue, deleting the DVR and recreating or deleting the EPG database or reducing the number of channels would get round the problem. A fix is being produced by Gracenote

The CloudFlare issue is under investigation

Logs would show which of the two it is for your failures

https://support.plex.tv/articles/201643703-reporting-issues-with-plex-media-server/
https://support.plex.tv/articles/200250417-plex-media-server-log-files/

I had 300+ channels saved. I went through and removed a bunch that I don't watch to get it below 300 and the EPG seems to be updating. It is at 5% after about 10 minutes. I will keep an eye on it over the next few days and see if it does the auto updates.
Thanks for the information.


#19

@"an39511@ohioshore.com" said:
I am running two HD Homerun extend over the air tuners. Each has 52 channels.
I did a Refresh Program Guide and captured the log which is posted here.
I don't know enough to know what to look for so hopefully you spot the cause.

Hi

Did you have this setting enabled in the DVR Settings?
Enable more frequent program guide refreshes

We believe it is this which caused the Rate Limiting response from CloudFlare and it is being looked into at the moment to avoid having these extra updates scheduled at the same time

So until it is resolved, unticking that setting should avoid the problem

Of course it you tell me you did not have that setting enabled, then we will need to investigate further


#20

@Burning_Beard said:

@sa2000 said:

@Burning_Beard said:
I seem to be having the same issues since the last PLEX update. I have been able to manually force it to load by deleting the saved EPG file in the plug-ins folder and restarting PLEX. Basically starting from scratch.

Version 1.11.3.4803

There are currently two issues affecting the EPG updates
- a Gracenote issue seen on systems with 300+ DVR channels giving a JSON Parse Error
- a Cloudflare issue giving a rate limiting error and also leading to a JSON Parse Error in the logs

For the gracenote issue, deleting the DVR and recreating or deleting the EPG database or reducing the number of channels would get round the problem. A fix is being produced by Gracenote

The CloudFlare issue is under investigation

Logs would show which of the two it is for your failures

https://support.plex.tv/articles/201643703-reporting-issues-with-plex-media-server/
https://support.plex.tv/articles/200250417-plex-media-server-log-files/

I had 300+ channels saved. I went through and removed a bunch that I don't watch to get it below 300 and the EPG seems to be updating. It is at 5% after about 10 minutes. I will keep an eye on it over the next few days and see if it does the auto updates.
Thanks for the information.

For the 2nd issue - the CloudFlare issue, unticking this setting in DVR Settings in Plex Media Server should help
Enable more frequent program guide refreshes

We believe it is this which caused the Rate Limiting response from CloudFlare and it is being looked into at the