escape button stop working




I used to use the escape button on the keyboard to stop playback and exit the currently playing movie. a recent update appears to have stopped this working. keyboard still works fine in every other app. how can I do this as there is no stop button in the gui only pause.


This is the Nvidia SHIELD Server section of forums. The server doesn’t play anything, it sends files to other players to play. which player are you using?


I have the same problem, and am using Plex media player to attempt to play it (built into my samsung tv). My server seems to be set up correctly since I can open the file on my Unraid box using MPC-HC.


@Neomacer said:
I have the same problem, and am using Plex media player to attempt to play it (built into my samsung tv). My server seems to be set up correctly since I can open the file on my Unraid box using MPC-HC.

there is no such thing as Plex Media Player built into a TV. Plex Media Player only runs on computers or devices like a Raspberry Pi. Guessing you mean our Smart TV app. TV’s don’t have keyboards as far as i know so how you are hitting an ESC key?

The server has nothing to do with play back controls of player app. the server doesn’t play anything it sends files to players

@mramirkhan I still not sure which player app you are talking about



I’m using the official plex media player from the play store. I’m not the only one suffering from this as I posted to the Android TV forum by mistake first

Pressing ESC on keyboard does nothing. Previously this would stop playback and go back to the screen you see before playing. Other apps work just fine (YouTube etc).


@mramirkhan said:
I’m using the official plex media player from the play store. I’m not the only one suffering from this as I posted to the Android TV forum by mistake first

you put it in the right place. This forum section is for Plex Media Server on the Shield, not the Plex for Android TV app or Plex Media Player. I am moving this thread to the Android TV section where it belongs

There is no such thing as “official plex media player from the play store” It doesn’t exist. Plex for Android TV is not Plex Media Player. Plex Media Player only runs on computers and is not available in any app store.

Plex for Android TV does not have any official support for keyboard and never has. It was only designed to work with Android TV controllers.( whether that be the shield controller or other device that runs Android TV) There were no edits to controller mapping in the app. That said apparently Shift+Backspace works in the development emulators so you could try that.


I do apologize for getting the name wrong. I’ll henceforth refer to it as “plex for Android”.

I appreciate there is no official support for keyboards in Plex for Android but the Shield itself does support keyboards officially (

Plex for android worked very well with keyboards up until recently, many of the people on here can testify to that. Something definitely changed and its a change that only affects plex. If you want I’d be happy to uninstall all updates to plex on the shield and video myself using it to show what the ESC button used to vs what it currently does. If I can get access to older versions I’d be happy to install them to tell you when the behavior changed. I think it was a few revions ago. I’m a plex plus user but I don’t think that gives me access to specific versions of Plex for Android to install, just the latest from the play store.

Can I ask how changes are managed to the app?. A while ago the FF and RWD behavior also changed and the version cooked in the ROM of my shield 2015 works much better (imo) than the current implementation. These “sudden” changes are really annoying and its a shame we don’t get to opt out of behavioral changes or even have the ability to control the apps functions via settings. I posted about the FWD/RWD issue before in this very forum.

Anyway, I’ll give your suggestion a whirl regarding shift+backspace and i’ll report back if it works.


You are welcome to install any version available in our release announcement thread for that app.

I don’t know what specific changes to FF/RW you are referring to as they work the same for me as they alway have ( Android is my personal main client i use) In my personal opinion the way other apps like youtube do it suck, but that is just my opinion not any official stance.


The last update also broke my Plex app’s functionality to use esc to back out of a currently playing video. I’m using Plex for Android on a Nexus Player running 8.0.0. Tapping and holding esc doesn’t work, either one. Have to now save Plex to the Leanback Launcher home screen, go into notifications, and press stop from there. The change I noticed that coincided with this functionality breaking was the addition of Picture-In-Picture. Which I honestly don’t really care for or have any use for. I do believe the introduction of PiP to Plex on Android TV disabled this capability.


I too don’t care about pip, but I do care about being able to stop a movie :’(


I can confirm on the latest version of plex pressing windows key +backspace stops playback as before. I can live with this if it continues to work. Shift + backspace did nothing, I also tried alt/altgr and every other combination.


Plex on Android will no longer go back. This is unacceptable.
Shield + USB Keyboard is the standard, and no one who pushed this Plex update bothered checking? Wow. Almost sorry I got the lifetime membership.
I have the same issues as WatchosDesPlexosFernando.
Play anything, and it is impossible to go back to the launcher without closing Plex.
Feels like i’m using some 13 year olds half-broken senior project. I will be switching to Emby and leaving the appropriate review on the app store.



I’m having the same issue. The back button on the Nvidia Shield remote still works, but neither “Stop” (from the last update) nor “Exit” (from mid-April) work on my Harmony remote, nor does “Esc” (from mid-April) on my Adesso keyboard. I also have no need for PiP…just need basic movie controls while using Plex for Shield.


Plex PLEASE fix these, there are probably LOADS of silent users who are suffering. The current lack of controls is giving a sub par experience !


As I mentioned above keyboards aren’t supported for Android TV


Workaround: I have found that if I enable mouse mode, put the mouse in the center of the playing video, mash the left mouse button “a bunch” that after that the ESC key works as intended and exits the video.

The expected way ESC works broke for me at the same time everyone else is reporting it. BKSP/DEL also do not work, and there is no Windows key or CTRL key on my TV remote style keyboard, making WIN+DEL (and CTRL+ESC+DEL) impossible as stated as a workaround in another post.

Please return the function of the ESC/BKSP/DEL keys to previous. Also, if “keyboards aren’t supported for Android TV”, what method of accomplishment should we use to exit a playing video without a touch screen or on-screen Android navigation buttons?

HW: leelbox/Android 7.1/Plex for Android in TV mode.


On my android tablet there is on on-screen stop button. works fine, but the android TV has no such button :frowning:


Been dealing with this too. I had to revert to the base version of Plex for SHIELD to get an experience that wasn’t completely useless. Having to close the app to get a movie to stop playing is absurd. I’d been considering a lifetime pass until this common sense feature was disabled inexplicably.


The version that installs on Shield is getting worse by the release IMO.


I have the same problem. Nvidia shield player and windows as the server. Can’t exit out of movie by pressing escape on the Rii mini 8+ remote. This used to work flawless I believe it was a update when it screwed up, it very much was around the time of picture and picture update. I have a theater down stairs that it also effects running a windows 7 nuc. As the player. With the same but different remote. Please someone look into this problem.