FreeNAS 11 Jail: Plex not showing new media

server-freebsd

#1

Fresh install of FreeNAS 11. I installed this a few days ago, when I re-installed, I added all my existing media. Everything worked fine.

Today, I added a few movies and TV shows after scanning the libraries, neither of them will show up in the Plex library. I can play all of the movies and media via any Plex client I have tried, the new stuff just isn't there. These are all MKV files.

I am following the naming and directory convention recommended by Plex.

I have tried re-starting the Jail.
I have tried re-adding the library in Plex.

I have verified (via shell) that the new files are in /media in the jail.

Any ideas?


#2

I don't want to hijack your thread but this sounds very close to my issue but I am running the latest freeNAS 9.10.UXX

a working pair of plex + sabnzbd + sonarr and suddenly (no major updates made only minor, i.e. new update of sabnzbd and new plex plugin update) newly downloaded media is not seen by plex.

I have manually checked media permissions and also manually tried refreshing all plex libraries and yet new media isn't picked up by plex.

Would also be interested on how to debug plex.


#3

I’m having the same issue with Plex on FreeNAS 11, the permissions are correct, but the plugin doesn’t allow me to add the media (browse outside the jail). Does’t even work if I just type the path in the box.

On another thread, it suggested that I change the security settings that allow external access from the jails to external volumes. I tried that with no success.

sudo sysctl security.jail.enforce_statfs=0

Any suggestions to solve this problem appreciated.


#4

@Billy_Dickson said:
I'm having the same issue with Plex on FreeNAS 11, the permissions are correct, but the plugin doesn't allow me to add the media (browse outside the jail). Does't even work if I just type the path in the box.

Well, you do not access storage outside your jail, you mount the storage into your jail. Go to your FreeNas dashboard where you manage your jails and mount the storage into the jail Plex is using then it will be available from within Plex.


#5

I've followed every steps that youtube provided and tutorials everywhere. I could not find the mounted drive that i should be seeing "/media". There should be two "drives"... Plex and then /media.

so are you saying that i should change my destination from /media to /var/db/plexdata/plex media server instead?

advise please.


#6

after posting this. i made the changes with the jail storage by having source point to the media folders then the destination pointed to /var/db/plexdata/plex media server

sure enough it showed up and i was able to scan and add libraries including tv shows and movies.


#7

I have the same Problems can anybody help me


#8

I have been having this problem for the last couple of version updates. The FreeNAS Plex app no longer shows the mounted storage. You can type it in manually, though, and it works without any issues. It just DOES NOT show up in the browser. I was just coming to finally put in a ticket for this when I saw this thread. It happened to me on FreeNAS 9 and 11.


#9

To the original poster: I seem to have a similar problem. Plex won't index any of the files (mkvs and music) I recently added to my server, all old ones play fine though. Did you ever fix your issue? Any help greatly appreciated.


#10

OK, here is how you make this work!

In FreeNAS, set your Source to point at your media library data set (I have /mnt/godzilla/plexmedia), then your Destination to

Then set your folder in Plex to the same location as your destination from your FreeNAS Jail. I recommend you create directories in your media storage dataset for every library using the Plex naming conventions (Movies, TV Shows, Music, Photos, Home Movies, etc) and you add that folder in the path, but you can use any folder names, you just make sure they match EXACTLY (case sensitive) the folder you created.

Here is the folder setup in your actual data storage (/mnt/godzilla/plexmedia) in my case.

REMEMBER: everything is case sensitive!
Basically, you just make sure your Destination path (Jail mount) is exactly the same as the path in Plex. Use the same path for every library in Plex, Movies, Music, etc.


#11

Hi

I’ve just gotten started with FreeNas 11.1 and I quickly noticed that all the tutorials on youtube I could find on setting up Plex on FreeNas was only for version 9 it seems, and adding the ddestionation folder was different then and is not working for 11.1

So I get that I have to configure the jails storage for plex like below.

Source: /mnt/MediaVolume/Media

Destination: /var/db/plexdata/plex media server

But the issue I am having is that after I change the destination part and save, the Plex plugin refuses to start. I change the “service status” to “on” it just wont turn green. I don’t get an error or anything.

As soon as I change the destination part to /var/db/plexdata/plex media server the plugin goes offline and refuses to start. If I change the destination to say: /media (like almost all of the tutorials tells you to do) I don’t have this issue, but then of course I can’t browse and add my media.

Restarting by rebooting does not help, and the only way I can get it to turn on is deleting thweplugin and reinstalling it.

Anyone come across this issue?

UPDATE: I solved it by reinstalling the plex plugin, starting it and not adding any storage which automatically creates the /var/db/plexdata/plex media server folder structure. After that I just added the storage to the jail and pointed it to /var/db/plexdata/plex media server

I think the issue I was having was adding the storage to the jail with a path to a destination folder structure that didn’t exist. Pretty lame that makes the plugin not start without any sort of error though (in the GUI). Anyways happy I got it working and happy new year fellow Plex and FreeNas enthusiasts.

**UPDATE2: NVM, it didnt work, when trying to turn off and turn on the plex plugin the same issue as above happens. It won’t start.


#12

I think you’re replacing a critical directory with media. Try /var/db/plexdata/plex media server/media


#13

Update3: I just deleted my volumes and started from scratch. Now it works like a charm. Last day of 2017! Let’s go!


#14

Hi all
I ve got the same problem and found solve issue.
When you attach Jail storage you choose your source and for destination /var/db/plexdata/Plex Media Server/FilmMyCloud
For example you add a directory for the mount point because if you select the root Plex Media Server/ directory you have some config file used by plex and they are create on the mountpoint in place the Plex Media Server/ directory
Another Thing i dont know if its a real problem when you saw the processes
ps aux | grep plex
you could be see a unknown UID 972. For that I create a user named plex with Primary group Wheel.
I hope this could be help you to solve this issue.

Kind regards
Sorry for my bad english im french if could i help more tell me if its necessary


#15

@lolotlse solution worked for me!! I had been going mad trying to find a solution! when adding your destination make sure to manually type in the folder where you keep your files i.e. /var/db/plexdata/Plex Media Server/yourmediafolderhere when configuring your storage in the plex jail .