hardware transcoding stopped working with DSM 6.1.5-15254

server-synology

#1

I have a DS418play and it recently updated itself to the latest version of DSM (6.1.5-15254). Now plex is no longer using hw transcoding, when it worked beautifully prior to the update. It seems Synology doesn't let you downgrade to an older version of DSM. I'm running Plex Server version 1.10.1.4602.

Anyone else having this problem or know of fix?

Thanks!
Greg


#2

Greg,
DSM resets the hardware permissions anytime there is an update. Simply uninstall PMS in Package Center and reinstall it. It will re-assert the needed permissions.


#3

I ran into the exact same issue and can confirm this fix works. (Wish I’d have seen this post yesterday)


#4

To all which read this thread. I’ve created an announcement in the Synology forum which explains the why and how .

https://forums.plex.tv/discussion/306910/hardware-transcoding-not-available-after-dsm-update


#5

Thanks! worked like a charm


#6

I just happened across this from a search and my jaw is hanging open…Synology told me about a year ago that Plex would not work at all with any updates of their product so I literally haven’t updated for …too long. Am I understanding from this thread that the latest update to synology works fine with Plex. They are two of my favorite things and I hate that I was told they can’t play together in the sandbox. Please only confirm if you are sure as I can’t afford to screw up my Plex. Thanks


#7

@“Randy’s Movies” said:
I just happened across this from a search and my jaw is hanging open…Synology told me about a year ago that Plex would not work at all with any updates of their product so I literally haven’t updated for …too long. Am I understanding from this thread that the latest update to synology works fine with Plex. They are two of my favorite things and I hate that I was told they can’t play together in the sandbox. Please only confirm if you are sure as I can’t afford to screw up my Plex. Thanks

What model Synology, version of DSM, and what version PMS are you using?


#8

Don’t know why I just see this now.I just posted question-based in your prior post…
I have DS1815+ Currently Running DSM 6.0.2-8451 Update 9. I am running Plex 1.11.2.4772-3e88ad3ba. My Synology Drive reportedly has an Intel Atom Processor C2548 in it, and I maxed out the RAM; although I don’t know that it made it transcode any faster. From your earlier thread, if I understand it, I should be able to upgrade my Synology to the latest version, but I may need to uninstall the PMS first and then reinstall it after I upgrade the Synology Server.

  1. Is this correct?
  2. If I uninstall the PMS and then I reinstall it, won’t I lose all the work I have done fixing erroneous file information and adding album art, etc.?
    I would love to upgrade my NAS, but I am terrified I will hose my Plex if I do.
    Thanks for your help!

#9

Randy,
Yes. The removal of the Plex package (binary executables only) is because of Synology. It has nothing to do with me or Plex. Once we get to DSM 6.1, everything is fine.

  1. Stop PMS
  2. Remove the package in Package Center
  3. Upgrade DSM to current DSM 6.1.6-15266 Update 1
  4. Reinstall the SPK
  5. You’re back in business