Having trouble with some x265/HEVC files with XPLAY on 2017 LG TV



To keep this as short as possible and easy to understand, I will just give bullet points of the symptoms and already tried solutions.

LG 43UJ635V TV (connected wireless AC), QNAP NAS (wired GbE), Mac Mini 2014 running Mac OS Sierra and OpenPHT (connected wireless AC - sits in living room next to the aforementioned TV).

Trying to play SOME x265/HEVC encoded files fails.

The Error:
In XPLAY, when trying to play these files, the following error appears: 'The video could not be loaded, either because the server or network failed, or because the format is not supported'.

  • Transcoding is not a option as my NAS isn't powerful enough to handle transcoding. Plus the TV is more than capable of direct playing of these files.
  • I am able to play x265 10-bit files @ 40mbs; so this is not a TV processing power or wireless network speed bottleneck issue.
  • The files do not even attempt to play, the message pops up immediately after trying to stream the file.
  • The files are low bitrate - ranging from around 1.8mbs to 5mbs.
  • I have tried to compare working x265 files to the ones that won't work using various tools to see if there is something in the details of the video files and nothing stands out.
  • I tried putting one of the files on a USB stick and plugging that into my TV, then using the TV's video/audio player to play the file, which spat out an error saying the file format was not recognised.
  • I am able to stream the files using OpenPHT on a Mac Mini without problem, and the files play perfectly fine in VLC on any computer.
  • The official Plex client for LG TV is a waste of time as that just tries to transcode virtually everything; so i can't even use that as a test.

I am eager to know what is causing some files to fail to play so that I might avoid whatever it is that is causing them to fail in future.

If anyone can offer any advice, it would be greatly appreciated. I can provide more information as required.

Thank you


FYI I did some more checking and it is certainly just x265 that is effect. I played most of my older x264 files of both 720p and 1080p and both play without issue.


Look I’m sorry for bumping, but I can’t believe I’m the only person who is having this issue?

I downloaded a box set of a TV show encoded by the same person and one season out of seven won’t play. Bizarre.

I guess if nobody can help I am going to have to encode a small video using various encoding options to see which makes it fall over, if any.


Same problem here x265 uhd hdr files won’t play on xplay or tv video/audio player can’t explain way


Is this perhaps something to do with the profile levels being used to encode these files? I’ve a feeling Main 10 is only widely supported up to L5.1 while some of the files designed for streaming may be as high as L6. You can check using the MediaInfo app if these are among the ones being rejected.


to me sounds like out of spec files, ie too many reference frames etc, most people who do the encode have no clue what they are actually doing with the settings, and thus the resulting files do not comply with HEVC/H265 spec’s required for hardware decoding.