Help with remote control of rasplex

rasplex

#1

Hi guys,

I am having issues with controlling rasplex using the remote control for my Samsung TV(2016 40inch 1080p) everything has been working since I bought the TV about a year ago. I have tried using a raspberry pi 2 and 3 with rasplex installed but still can't get the remote to work. On the TV I can see the ir light flickering and I can use the remote just fine for the smart hub, settings, other channels and devices. I have also reset the TV to factory default, and replaced remote batteries. I re-imaged and used a different SD card for the pi and no change. I am running 1.7.x. The hdmi and usb power cables have been swapped. Just a reminder the remote works fine on everything else, and the remote worked fine yesterday and for the last year. I can use the plex remote in the Android app and it works fine. Any ideas here guys?

Thanks!


#2

Are each cec device detecting each other? Also have in mind that not all hdmi ports of your tv could support cec


#3

The android app remote works by WiFi so that should not be a factor.

@videotecaCNSU makes a good point. There were also some reports of CEC not working with Samsung TVs some months ago.

I can report it is working with my 2015 Samsung smart TV. You may want to try with version 1.8.0 which is going to drop into the pre-release update soon.


#4

Hi guys,
Sorry for the delay, it must have been a glitch with the TV, I tried a chromecast and it wasn't being detected properly either. i unplugged the TV for a min and plugged it back in and everything worked.


#5

Also @benjaminwolf and @videotecaCNSU Thank you for the suggestions! Its greatly Appreciated!


#6

I also have the problem switching to a Pi 3 and also upgraded to rasplex 1.7 then the usb remote do not work, and what I can see in the logs e.t.c the lircd process only listens to /dev/lirc1 which is the lirc_rpi and not the /dev/lirc0 that is the usb one


#7

@Wesse77 said:
I also have the problem switching to a Pi 3 and also upgraded to rasplex 1.7 then the usb remote do not work, and what I can see in the logs e.t.c the lircd process only listens to /dev/lirc1 which is the lirc_rpi and not the /dev/lirc0 that is the usb one

did you try the experimental package of 1.8 as benjaminwolf suggested?