How are movie extras supposed to show in Plex?


#1

I have a movie called "Petit Bus Rouge" which is a french independent documentary. It came with three extra scenes, that I would like included in Plex. So I've got my files organized like this:

movies\
Petit Bus Rouge (2013)\
Petit Bus Rouge (2013).mp4
A Spectacle in the Mountains-scene.mp4
Rope Jump Part 1-scene.mp4
Rope Jump Part 2-scene.mp4
Sea Stack Flying-scene.mp4

However, when I am browsing in Plex, I see the Main movie, but I can't seem to find any of the extras. Why is this?

Thanks for any help you can offer!


#2

Well, I wanted to edit my post to make it easier to read…but apparently level 1 users can’t do that. So here is the file structure in an easier to read format:

\movies
     \Petit Bus Rouge (2013)
          Petit Bus Rouge (2013).mp4
          A Spectacle in the Mountains-scene.mp4
          Rope Jump Part 1-scene.mp4
          Rope Jump Part 2-scene.mp4
          Sea Stack Flying-scene.mp4

Thanks for any help you can offer!


#3

Your file names are correct.

Now make sure that:
The library where the movie was added actually uses the ‘Plex Movie Scanner’.
(Edit the library, go to the ‘Advanced’ tab to find out)

Then verify that the line ‘Local Media Assets’ has a check mark, in the Agent configuration for the agent that you matched this movie with.
(If you don’t know which agent was used, post the Plex media info XML of this movie here
https://support.plex.tv/articles/201998867-investigate-media-information-and-formats/ )


#4

@OttoKerner said:
Your file names are correct.

Now make sure that:
The library where the movie was added actually uses the ‘Plex Movie Scanner’.
(Edit the library, go to the ‘Advanced’ tab to find out)

Then verify that the line ‘Local Media Assets’ has a check mark, in the Agent configuration for the agent that you matched this movie with.

… and that it is NOT in the top slot of the Agent Lists - at the bottom of the active agents is the correct placement or that mp4 file will cause Plex to burst into flames and crash into a school, killing everyone.


#5

Thanks for the replies! I’ve checked all that, and still not having any luck.

The library where the movie was added actually uses the 'Plex Movie Scanner'.

Confirmed.

Then verify that the line 'Local Media Assets' has a check mark, in the Agent configuration for the agent that you matched this movie with.

I think this is confirmed, but I will post the XML data below, as I’m not positive which agent I matched this movie with. However, under ‘agents’ -> ‘movies’ tab there are three agents listed…personal media, plex movie, and the movie database. All three have ‘local media assets’ checked.

and that it is NOT in the top slot of the Agent Lists.

It WAS in the top slot of the agents list, but I moved it to the bottom of the checked boxes. (There are still unchecked boxes under it) But that doesn’t seem to be the issue either. Still not seeing any extra content when I click on ‘Petit Bus Rouge’ in my movie list.

attached is the xml file of the movie in question. Thanks again for the help!

Finally, if it is an issue with .mp4’s I’d be happy to remux it into an .mkv instead. Could this be causing the issue by chance?


#6

@trevzilla said:
Finally, if it is an issue with .mp4’s I’d be happy to remux it into an .mkv instead. Could this be causing the issue by chance?

No, this is not the issue. In fact, under many circumstances, mp4 is the optimal container format in Plex.

The issue is, that currently, there is no metadata agent assigned to your movie.
It is ‘unmatched’ guid="local://16500"
For the extras to get recognized, you must achieve a ‘match’.

Since this is a documentary, you’ll probably never achieve a match with the Plex Movie agent (it only matches ‘cinema’ movies).
You can match it using the ‘Personal Media’ agent
or you can try the TMDB agent.
Behold: TMDB has it listed https://www.themoviedb.org/movie/209990-petit-bus-rouge

So, enter the preplay page of your movie
click on the ellipsis ( . . . )
‘Match’
‘Search Options’
now change the ‘Agent’ dropdown to ‘TheMovieDatabase’
put the title and the release year into the appropriate input fields, pick your language
‘Search’ … wait a few seconds
click on the only search result


#7

That did it! Awesome! Thanks a ton!


#8

The Movie Database:


Petit Bus Rouge (2013).mp4 <— The Name

As has been previously mentioned - I see…

lol