How to update Plex Media Server using apt-get

server-linux

#1

Hello,
I have tried to update my Plex Media Server following instructions given on that page: https://support.plex.tv/articles/235974187-enable-repository-updating-for-supported-linux-server-distributions/
I have unfortunately not been able to do so.
When I ran sudo apt-get update, I got the following error messages :


Err:9 https://downloads.plex.tv/repo/deb ./public Release
404 Not Found [IP: 2400:cb00:2048:1::6812:9c29 443]
Reading package lists... Done

E: The repository 'https://downloads.plex.tv/repo/deb ./public Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.


Can anyone help me ?
Thank you in advance.


#2

https://forums.plex.tv/discussion/319999/ubuntu-16-debian-8-users-special-advance-announcement


#3

Hi,
Thank you for your answer.
I do not understand what it means. Which file should I edit and how should I change it ?

By the way, I have tried to run sudo apt-get update again and got no error message, this time. However, the Plex Media Server was not updated.

Thank you for your help.


#4

Edit /etc/apt/sources.list.d/plexmediaserver.list and replace ./public with just public so that the end result is deb https://downloads.plex.tv/repo/deb public main

The official doc has also just been corrected :slight_smile:

https://support.plex.tv/articles/235974187-enable-repository-updating-for-supported-linux-server-distributions/


#5

Thank you for your answer.
I did the change that you suggested.
Now, I get this warning message :


[…]
Hit:7 https://downloads.plex.tv/repo/deb public InRelease
Hit:8 http://security.ubuntu.com/ubuntu bionic-security InRelease
Reading package lists… Done
W: Conflicting distribution: https://downloads.plex.tv/repo/deb public InRelease (expected public but got )


Is this important, or can I just ignore it ?


#6

Just ignore it. It will disappear as soon as a server side fix has been deployed.


#7

Thank you. It works now.

By the way, I also realized that, after running sudo apt-get update, I also had to run sudo apt-get upgrade.
As you see, I am a newbie :slight_smile:

Thank you again.


#8

its totally broke no along with lots of other parts in their website, eg the link in the above pose

root@plex:~# curl https://downloads.plex.tv/repo/deb/ ; echo
<html>
  <head>
    <title>Plex Redirect</title>
      <META http-equiv="refresh" content="5;URL=https://plex.tv/downloads">
  </head>
  <body bgcolor="#323232" link="yellow" vlink="yellow">
    <p>&nbsp;</p>
    <center><font size="5" color="white">The page you're looking for was not found.<br>
      You will be redirected automatically in 5 seconds.<p>
      <a href="https://www.plex.tv/downloads">https://plex.tv/downloads</a></font>
    </center>
  </body>
</html>


#9

Please do not cross post. And no, it’s not. curl != apt. apt will just work :wink:


#10

No it wont, the curl was an example of what is wrong

W: Conflicting distribution: https://downloads.plex.tv/repo/deb public InRelease (expected public but got )


#11

That’s a warning. The repo does work (with this warning).