I have installed plex server on synology, but i cannot see servers option in web.

server-synology

#1

I log into plex server using local ip. Undser settings i have "web, users, devices". On home page i have "Looking for server... A server could not be found. Download and install Plex Media Server, and it will appear here."

Device synology ds414. Plex version 1.3.3.3148-b38628e

What could be wrong. I can access my device from http://externalip:32400/web


#2

Hi indreek,

For the moment I am using Synology too. Would you please be just a bit more specific about the details, and perhaps I can help... For example, "I log into Plex server using local ip" from what, your desktop phone, tablet, windows, android, iOS?
"On home page..." is this from a browser, if so which one, or are you within Synology, is this from a desktop, tablet...?
I'd be happy to try to assist, just need a few more details.

Regards,
Plexacardia


#3

Im using windows pc with chrome to access plex

https://dl.dropboxusercontent.com/u/74801088/Capture.PNG
https://dl.dropboxusercontent.com/u/74801088/Capture2.PNG

Indrek


#4

Open Plex in your browser by typing in http://Your-NAS-IP-Address:32400 and then go to settings->devices and delete everything except for the current browser session. Now stop Plex from running on the NAS.

Next, go to https://plex.tv and sign in if not already. Click on the 'launch' button and repeat the above, delete everything except for the current browser session. Then sign out of plex.tv.

Now go back and restart Plex on the NAS. Open Plex in your browser by typing in http://Your-NAS-IP-Address:32400 and then sign in, both in settings->server->general and by clicking on the 'head' icon (top right of screen).

Make sure you have followed the instructions above carefully, if you are still unable to access the server, then follow these steps but only if the above has failed, DO NOT try doing both at the same time:

Stop Plex from running, then open File Station and navigate to: Plex/Library/Application Support/Plex Media Server and delete plexmediaserver.pid (if it exists) and Preferences.xml.

If you do not see the Plex folder in File Station, then see Q7a on the Synology FAQ's page, link in my signature.

Restart Plex, then type http://Your-NAS-IP-Address:32400 into your browser or click on the link in Package Center->Installed->Plex or from the DSM start menu->Plex icon and make sure you log in, both in settings->server->general and by clicking on the 'head' icon (top right of screen).

Hopefully, you will be able to access your server again.


#5

I dont have settings-> server option. I only have web, users, devices.


#6

It feels like NAS is not acting as Plex server.


#7

@indreek said:
I dont have settings-> server option. I only have web, users, devices.

Did you follow my instructions precisely?


#8

Hi, I got exactly the same problem.

Your solution and what I obtained:

_Open Plex in your browser by typing in http://Your-NAS-IP-Address:32400 and then go to settings->devices and delete everything except for the current browser session. _

Now stop Plex from running on the NAS.

Next, go to https://plex.tv and sign in if not already. Click on the ‘launch’ button and repeat the above, delete everything except for the current browser session. Then sign out of plex.tv.

**Now go back and restart Plex on the NAS. **

Open Plex in your browser by typing in http://Your-NAS-IP-Address:32400 and then sign in, both in settings->server->general and by clicking on the ‘head’ icon (top right of screen).

What is this head icon, that you are speaking of?

There are no servers in the settings.

and he is still looking for a server


#9

As indreek commented,
I dont have settings-> server option. I only have web, users, devices.
Logically, there is no server, hence no settings --> server option


#10

I have the same problem on a synology DS916+. If i install on a windows machine everything works perfectly.


#11

@geoorgge said:
As indreek commented,
I dont have settings-> server option. I only have web, users, devices.
Logically, there is no server, hence no settings --> server option

First of all, I don't think you followed my instructions correctly, please read them carefully and try again.

Also, you made no mention of these instructions:

@trumpy81 said:
Stop Plex from running, then open File Station and navigate to: Plex/Library/Application Support/Plex Media Server and delete plexmediaserver.pid (if it exists) and Preferences.xml.

If you do not see the Plex folder in File Station, then see Q7a on the Synology FAQ's page, link in my signature.

Restart Plex, then type http://Your-NAS-IP-Address:32400 into your browser or click on the link in Package Center->Installed->Plex or from the DSM start menu->Plex icon and make sure you log in, both in settings->server->general and by clicking on the 'head' icon (top right of screen).

Hopefully, you will be able to access your server again.

So I assume you haven't followed those instructions?

@geoorgge said:
What is this head icon, that you are speaking of?

The 'head' icon is displayed when you are not signed in, in your screenshot it shows your Gravatar icon, meaning you are already signed in there.


#12

@PietjePuk1727 said:
I have the same problem on a synology DS916+. If i install on a windows machine everything works perfectly.

And what have you tried to correct the problem? Have you followed the instructions posted in this thread?


#13

It is really important to use the ip of your NAS. I used XXXXX.local to connect to plex server. But then you get no server options. You have to use the real ip. Something like 192.168.1.x:32400/web. http://ip.addr.of.syno:32400/web.

Do not use XXXX.local. Then you get no server


#14

HI, I have exactly the same problem and I followed all the instructions precisely but I don't see my Plex server still. Ports are being listened (I checked it with netstat command) but I cant see my server in web browser. Any ideas what could I try?

My Synology is DS415 Play


#15

To augment here,

In some cases where you do not have a settings tab, the cause is the IP address range of the LAN itself.

PMS has internal security for setup. To setup on your home LAN, your LAN must use the address ranges specified in RFC 1918.

These are 10.x.x.x, 172.16.x.x -> 172.31.x.x, and 192.168.x.x. When any other LAN address range is used, PMS will assume your computer is another remote system and not permit setup except via SSH tunnel.


#16

Hi,
I'm using 192.168.1.x address for PMS.

That is what I'm seeing in console:

~$ netstat -an | grep 32400
tcp 0 0 0.0.0.0:32400 0.0.0.0:* LISTEN

~$ ps aux | grep plex
plex 3793 0.1 1.1 239324 7964 ? Sl Sep13 1:40 /var/packages/Plex Media Server/target/Plex Media Server
plex 3811 0.2 1.6 117284 11684 ? SNl Sep13 2:53 Plex Plug-in [com.plexapp.system] /volume1/@appstore/Plex Media Server/Resources/Plug-ins-4b377d295/Framework.bundle/Contents/Resources/Versions/2/Python/bootstrap.py --server-version 1.5.3.3580-4b377d295 /volume1/@appstore/Plex Media Server/Resources/Plug-ins-4b377d295/System.bundle
plex 4760 0.5 0.8 242628 6056 ? Sl Sep13 6:42 /volume1/@appstore/Plex Media Server/Plex DLNA Server
plex 4763 0.0 0.1 54088 800 ? Sl Sep13 0:03 /volume1/@appstore/Plex Media Server/Plex Tuner Service /volume1/@appstore/Plex Media Server/Resources/Tuner/Private /volume1/@appstore/Plex Media Server/Resources/Tuner/Shared 1.5.3.3580-4b377d295 32600 /waitmutex


#17

Any ideas please?


#18

Same issue. steps outlined here don't work.


#19

I have the same issue. I followed the below steps:

  1. Opened Plex in browser by typing in http://192.168.0.204:32400 and then went to settings->devices. The only devices listed were "Plex Web (Chrome)", "Plex Web (Chrome)" and "Plex Auth App (Chrome)". I deleted everything (including the current browser session for good measure).

  2. Stopped Plex from running, by opening File Station and navigating to: Plex/Library/Application Support/Plex Media Server and deleting plexmediaserver.pid and Preferences.xml.

  3. Went to https://plex.tv and signed in. Clicked on the 'launch' button and repeated the above, deleting everything (including the current browser session for good measure).

  4. Opened Plex in browser by typing in http://192.168.0.204:32400 and then signed in. I was signed in via the 'head' icon in the top right corner. However I do not have a Server tab under Settings, only Web, Users and Devices.

Clearly this is an issue. Can someone please help?


#20

A few important things to look at.

  1. Your Syno must have a LAN (RFC 1918 compliant) address to perform initialization ('claim')
  2. If your Syno does not have a compliant address assigned to it, you must ssh tunnel to it. See below
  3. If you r Syno has a compliant address and you are on the same subnet as it continue with the next step
  4. Stop PMS in Package Center
  5. Control Panel - Shared Folders - Edit the Plex share.
  6. Permissions tab
  7. Grant your username permission to R/W the share
  8. Open File Station
  9. Navigate to the Plex share - Library - Application Support - Plex Media Server
  10. Delete Preferences.xml
  11. Start PMS in Package Center.
  12. Now open http://ip.addr.of.syno:32400/web in a fresh browser tab
  13. As you go through 'Sign in' and 'Got it', make certain to use the same Plex.tv account as you're signed in with (upper right corner of browser)
  14. If you have library sections already defined, do not create any more. They will be waiting for you when you exit the first-run setup wizard
  15. At the Dashboard, you will now have Settings - Servers and can adjust your preferences accordingly.

LAN addressing requirements
https://en.wikipedia.org/wiki/Private_network

SSH tunneling. Scroll down to On a Different Network
https://support.plex.tv/hc/en-us/articles/200288586-Installation