I have tried for days, but I cannot get my Plex server accessible from outside the network. Help?

server-netgear

#1

I am using a Netgear R8900 router with built-in Plex server to run my media server.
Manual port forwarding and automatic UPnP both have resulted in unsuccessful connections from outside my network.

Every time I click “retry” the settings menu always turns green for a brief moment before returning to Not available outside your network. Your server is signed in to Plex, but is not reachable from outside your network.

Attached are my server logs. Please help.


#2

Hi, I have the exact same problem. Are you on Windows 10 and recently receive the latest Windows update too? That's the only thing that changed in my setup from working to not working.

I am finding that no matter whether you use custom port or not, port forwarding or not (it all worked previous to the Windows update), the Plex servers are resetting my SSL connections when my server tries to connect.

Image

In the logs I have this line when I try to enable Remote Access:

Jan 10, 2018 23:28:23.760 [2188] WARN - PubSub: Received notifyConnectivity event with incorrect async identifier

Which I see in your logs too:

Jan 10, 2018 14:13:52.097 [0xb2a05530] WARN - PubSub: Received notifyConnectivity event with incorrect async identifier

It seems likely we both have the same problem.


#3

No, my server does not run off of my Windows computer. It runs on my Netgear R8900 router with built-in Plex.
Although I do think we are running into the same issue here. Anyone have any ideas on how to fix it?


#4

I can't believe this hasn't had a single response. One of the main features of our Plex installation is broken and this is the closest thing that exists to a support line. We have evidence between us that the problem is platform agnostic and therefore configuration agnostic.

This was working fine, now your servers just drop our connections. Our logs only have the local side of the story and that clearly says that your system is getting erroneous data from our local servers, but that doesn't exactly help us but it does say that a Plex.TV staffer should be on this one.

What's going on? Will a re-install fix it?


#5

From inside can you browse to http//192.168.1.15:32400

If you go to canyouseeme.org does it show same ip as in your screen shot?

If you test that port on canyouseeme does it show success?

This is all for @gutkinfam
@"riddla26@gmail.com" do you have a form post about your issue?


#6

If you go to canyouseeme.org does it show same ip as in your screen shot?
Yes, It is the same public IP.

If you test that port on canyouseeme does it show success?
The connection always times out. There is always an error.

Thaks for the help @nokdim


#7

@gutkinfam (cc @nokdim) - I suggest you get fresh logs - the logs from jan 10th show some very strange networking behaviour - with about 8 network change indications every second

Extract of 2 second activity
```

Jan 10, 2018 14:23:28.236 [0xb3487530] DEBUG - NetworkInterface: Notified of network changed (force=0)
Jan 10, 2018 14:23:28.236 [0xb3487530] DEBUG - Network change notification but nothing changed.
Jan 10, 2018 14:23:28.407 [0xb3487530] DEBUG - NetworkInterface: received Netlink message len=244, type=RTM_NEWLINK, flags=0x0
Jan 10, 2018 14:23:28.407 [0xb3487530] DEBUG - NetworkInterface: Netlink information message family=0, type=1, index=29, flags=0x11043, change=0x0
Jan 10, 2018 14:23:28.407 [0xb3487530] DEBUG - Network change.
Jan 10, 2018 14:23:28.407 [0xb3487530] DEBUG - NetworkInterface: Notified of network changed (force=0)
Jan 10, 2018 14:23:28.408 [0xb3487530] DEBUG - Network change notification but nothing changed.
Jan 10, 2018 14:23:28.472 [0xb3487530] DEBUG - NetworkInterface: received Netlink message len=236, type=RTM_NEWLINK, flags=0x0
Jan 10, 2018 14:23:28.472 [0xb3487530] DEBUG - NetworkInterface: Netlink information message family=0, type=1, index=29, flags=0x11043, change=0x0
Jan 10, 2018 14:23:28.472 [0xb3487530] DEBUG - Network change.
Jan 10, 2018 14:23:28.472 [0xb3487530] DEBUG - NetworkInterface: Notified of network changed (force=0)
Jan 10, 2018 14:23:28.473 [0xb3487530] DEBUG - Network change notification but nothing changed.
Jan 10, 2018 14:23:28.735 [0xb3487530] DEBUG - NetworkInterface: received Netlink message len=244, type=RTM_NEWLINK, flags=0x0
Jan 10, 2018 14:23:28.735 [0xb3487530] DEBUG - NetworkInterface: Netlink information message family=0, type=1, index=29, flags=0x11043, change=0x0
Jan 10, 2018 14:23:28.736 [0xb3487530] DEBUG - Network change.
Jan 10, 2018 14:23:28.736 [0xb3487530] DEBUG - NetworkInterface: Notified of network changed (force=0)
Jan 10, 2018 14:23:28.736 [0xb3487530] DEBUG - Network change notification but nothing changed.
Jan 10, 2018 14:23:28.806 [0xb3487530] DEBUG - NetworkInterface: received Netlink message len=196, type=RTM_NEWLINK, flags=0x0
Jan 10, 2018 14:23:28.806 [0xb3487530] DEBUG - NetworkInterface: Netlink information message family=0, type=1, index=29, flags=0x11043, change=0x0
Jan 10, 2018 14:23:28.807 [0xb3487530] DEBUG - Network change.
Jan 10, 2018 14:23:28.807 [0xb3487530] DEBUG - NetworkInterface: Notified of network changed (force=0)
Jan 10, 2018 14:23:28.807 [0xb3487530] DEBUG - Network change notification but nothing changed.
Jan 10, 2018 14:23:28.810 [0xb3487530] DEBUG - NetworkInterface: received Netlink message len=196, type=RTM_NEWLINK, flags=0x0
Jan 10, 2018 14:23:28.811 [0xb3487530] DEBUG - NetworkInterface: Netlink information message family=0, type=1, index=29, flags=0x11043, change=0x0
Jan 10, 2018 14:23:28.811 [0xb3487530] DEBUG - Network change.
Jan 10, 2018 14:23:28.811 [0xb3487530] DEBUG - NetworkInterface: Notified of network changed (force=0)
Jan 10, 2018 14:23:28.811 [0xb3487530] DEBUG - Network change notification but nothing changed.
Jan 10, 2018 14:23:28.812 [0xb3487530] DEBUG - NetworkInterface: received Netlink message len=196, type=RTM_NEWLINK, flags=0x0
Jan 10, 2018 14:23:28.812 [0xb3487530] DEBUG - NetworkInterface: Netlink information message family=0, type=1, index=29, flags=0x11043, change=0x0
Jan 10, 2018 14:23:28.812 [0xb3487530] DEBUG - Network change.
Jan 10, 2018 14:23:28.812 [0xb3487530] DEBUG - NetworkInterface: Notified of network changed (force=0)
Jan 10, 2018 14:23:28.813 [0xb3487530] DEBUG - Network change notification but nothing changed.
Jan 10, 2018 14:23:28.900 [0xb3487530] DEBUG - NetworkInterface: received Netlink message len=196, type=RTM_NEWLINK, flags=0x0
Jan 10, 2018 14:23:28.900 [0xb3487530] DEBUG - NetworkInterface: Netlink information message family=0, type=1, index=29, flags=0x11043, change=0x0
Jan 10, 2018 14:23:28.900 [0xb3487530] DEBUG - Network change.
Jan 10, 2018 14:23:28.901 [0xb3487530] DEBUG - NetworkInterface: Notified of network changed (force=0)
Jan 10, 2018 14:23:28.901 [0xb3487530] DEBUG - Network change notification but nothing changed.
Jan 10, 2018 14:23:28.910 [0xb3487530] DEBUG - NetworkInterface: received Netlink message len=244, type=RTM_NEWLINK, flags=0x0
Jan 10, 2018 14:23:28.910 [0xb3487530] DEBUG - NetworkInterface: Netlink information message family=0, type=1, index=29, flags=0x11043, change=0x0
Jan 10, 2018 14:23:28.910 [0xb3487530] DEBUG - Network change.
Jan 10, 2018 14:23:28.910 [0xb3487530] DEBUG - NetworkInterface: Notified of network changed (force=0)
Jan 10, 2018 14:23:28.911 [0xb3487530] DEBUG - Network change notification but nothing changed.
Jan 10, 2018 14:23:28.972 [0xb3487530] DEBUG - NetworkInterface: received Netlink message len=236, type=RTM_NEWLINK, flags=0x0
Jan 10, 2018 14:23:28.972 [0xb3487530] DEBUG - NetworkInterface: Netlink information message family=0, type=1, index=29, flags=0x11043, change=0x0
Jan 10, 2018 14:23:28.972 [0xb3487530] DEBUG - Network change.
Jan 10, 2018 14:23:28.973 [0xb3487530] DEBUG - NetworkInterface: Notified of network changed (force=0)
Jan 10, 2018 14:23:28.973 [0xb3487530] DEBUG - Network change notification but nothing changed.
Jan 10, 2018 14:23:29.116 [0xb3487530] DEBUG - NetworkInterface: received Netlink message len=244, type=RTM_NEWLINK, flags=0x0
Jan 10, 2018 14:23:29.116 [0xb3487530] DEBUG - NetworkInterface: Netlink information message family=0, type=1, index=29, flags=0x11043, change=0x0
Jan 10, 2018 14:23:29.116 [0xb3487530] DEBUG - Network change.
Jan 10, 2018 14:23:29.116 [0xb3487530] DEBUG - NetworkInterface: Notified of network changed (force=0)
Jan 10, 2018 14:23:29.117 [0xb3487530] DEBUG - Network change notification but nothing changed.
Jan 10, 2018 14:23:29.239 [0xb3487530] DEBUG - NetworkInterface: received Netlink message len=244, type=RTM_NEWLINK, flags=0x0
Jan 10, 2018 14:23:29.239 [0xb3487530] DEBUG - NetworkInterface: Netlink information message family=0, type=1, index=29, flags=0x11043, change=0x0
Jan 10, 2018 14:23:29.239 [0xb3487530] DEBUG - Network change.
Jan 10, 2018 14:23:29.240 [0xb3487530] DEBUG - NetworkInterface: Notified of network changed (force=0)
Jan 10, 2018 14:23:29.240 [0xb3487530] DEBUG - Network change notification but nothing changed.
Jan 10, 2018 14:23:29.474 [0xb3487530] DEBUG - NetworkInterface: received Netlink message len=236, type=RTM_NEWLINK, flags=0x0
Jan 10, 2018 14:23:29.474 [0xb3487530] DEBUG - NetworkInterface: Netlink information message family=0, type=1, index=29, flags=0x11043, change=0x0
Jan 10, 2018 14:23:29.474 [0xb3487530] DEBUG - Network change.
Jan 10, 2018 14:23:29.475 [0xb3487530] DEBUG - NetworkInterface: Notified of network changed (force=0)
Jan 10, 2018 14:23:29.475 [0xb3487530] DEBUG - Network change notification but nothing changed.
Jan 10, 2018 14:23:29.735 [0xb3487530] DEBUG - NetworkInterface: received Netlink message len=244, type=RTM_NEWLINK, flags=0x0
Jan 10, 2018 14:23:29.735 [0xb3487530] DEBUG - NetworkInterface: Netlink information message family=0, type=1, index=29, flags=0x11043, change=0x0
Jan 10, 2018 14:23:29.736 [0xb3487530] DEBUG - Network change.
Jan 10, 2018 14:23:29.736 [0xb3487530] DEBUG - NetworkInterface: Notified of network changed (force=0)
Jan 10, 2018 14:23:29.736 [0xb3487530] DEBUG - Network change notification but nothing changed.
Jan 10, 2018 14:23:29.907 [0xb3487530] DEBUG - NetworkInterface: received Netlink message len=244, type=RTM_NEWLINK, flags=0x0
Jan 10, 2018 14:23:29.907 [0xb3487530] DEBUG - NetworkInterface: Netlink information message family=0, type=1, index=29, flags=0x11043, change=0x0
Jan 10, 2018 14:23:29.907 [0xb3487530] DEBUG - Network change.
Jan 10, 2018 14:23:29.907 [0xb3487530] DEBUG - NetworkInterface: Notified of network changed (force=0)
Jan 10, 2018 14:23:29.908 [0xb3487530] DEBUG - Network change notification but nothing changed.
Jan 10, 2018 14:23:29.972 [0xb3487530] DEBUG - NetworkInterface: received Netlink message len=236, type=RTM_NEWLINK, flags=0x0
Jan 10, 2018 14:23:29.972 [0xb3487530] DEBUG - NetworkInterface: Netlink information message family=0, type=1, index=29, flags=0x11043, change=0x0
```
About 12,500 such events in 27 minutes

Look into the networks interfaces setup

Jan 10, 2018 13:55:59.915 [0xb6f5c000] DEBUG - Network interfaces:
Jan 10, 2018 13:55:59.915 [0xb6f5c000] DEBUG - * 1 lo (127.0.0.1) (loopback: 1)
Jan 10, 2018 13:55:59.916 [0xb6f5c000] DEBUG - * 11 br0 (192.168.1.15) (loopback: 0)
Jan 10, 2018 13:55:59.916 [0xb6f5c000] DEBUG - * 23 LeafNets (5.231.23.179) (loopback: 0)

Don't know if that is normal for ReadyNAS


#8

@nokdim, thanks for all your help. Here are the updated logs.


#9

@sa2000, I updated my logs with more recent ones, after I received Version 1.11.3.4803. Is there anything else I can do?


#10

you are still having network issues. your plex setup looks like it correcting maps using UPnP but then the network interface looks like it is flapping ( network is unstable) I am not familiar with the netgear router that you are running plex on, however it seems to be having major problems with maintains a stable network for plex, has the router firmware been updated recently or is there some process using all the resources on the netgear?

Feb 28, 2018 15:42:25.296 [0xb4231530] DEBUG - NAT: UPnP, public address is 72.79.60.213
Feb 28, 2018 15:42:25.298 [0xb4231530] DEBUG - MyPlex: Last published value didn't change, we're done.
Feb 28, 2018 15:42:26.027 [0xb26ad530] DEBUG - NAT: UPnP, found device http://192.168.1.1:2555/upnp/2bd3a591-f151-3ee5-9872-3e552ce39a69/desc.xml with private address <192.168.1.15>
Feb 28, 2018 15:42:26.033 [0xb26ad530] DEBUG - NAT: UPnP, usable device http://192.168.1.1:2555/upnp/2bd3a591-f151-3ee5-9872-3e552ce39a69/desc.xml with private address <192.168.1.15>.
Feb 28, 2018 15:42:26.340 [0xb26ad530] DEBUG - NAT: UPnP, mapped port 18141 to 192.168.1.15:32400.
Feb 28, 2018 15:42:26.340 [0xb26ad530] DEBUG - PublicAddressManager: Mapping succeeded for 192.168.1.15:18141.
Feb 28, 2018 15:42:26.342 [0xb26ad530] DEBUG - MyPlex: Last published value didn't change, we're done.

this first part looks normal but from here on down it look very bad and it keeps going in the logs even though I only posted a small amount

Feb 28, 2018 15:42:26.493 [0xb4431530] DEBUG - Thread: Running async task started by thread 0xb4e42530.
Feb 28, 2018 15:42:26.867 [0xb4c31530] DEBUG - Thread: Running async task started by thread 0xb4e42530.
Feb 28, 2018 15:42:26.873 [0xb4231530] DEBUG - Thread: Running async task started by thread 0xb4e42530.
Feb 28, 2018 15:42:27.422 [0xb30ae530] DEBUG - NetworkInterface: received Netlink message len=360, type=RTM_NEWLINK, flags=0x0
Feb 28, 2018 15:42:27.422 [0xb30ae530] DEBUG - NetworkInterface: Netlink information message family=0, type=1, index=74, flags=0x11043, change=0x0
Feb 28, 2018 15:42:27.422 [0xb30ae530] DEBUG - Network change.
Feb 28, 2018 15:42:27.422 [0xb30ae530] DEBUG - NetworkInterface: Notified of network changed (force=0)
Feb 28, 2018 15:42:27.423 [0xb30ae530] DEBUG - Network change notification but nothing changed.
Feb 28, 2018 15:42:27.562 [0xb30ae530] DEBUG - NetworkInterface: received Netlink message len=360, type=RTM_NEWLINK, flags=0x0
Feb 28, 2018 15:42:27.562 [0xb30ae530] DEBUG - NetworkInterface: Netlink information message family=0, type=1, index=74, flags=0x11043, change=0x0
Feb 28, 2018 15:42:27.562 [0xb30ae530] DEBUG - Network change.
Feb 28, 2018 15:42:27.562 [0xb30ae530] DEBUG - NetworkInterface: Notified of network changed (force=0)
Feb 28, 2018 15:42:27.563 [0xb30ae530] DEBUG - Network change notification but nothing changed.
Feb 28, 2018 15:42:31.597 [0xb30ae530] DEBUG - NetworkInterface: received Netlink message len=160, type=RTM_NEWLINK, flags=0x0
Feb 28, 2018 15:42:31.597 [0xb30ae530] DEBUG - NetworkInterface: Netlink information message family=0, type=1, index=74, flags=0x11043, change=0x0
Feb 28, 2018 15:42:31.597 [0xb30ae530] DEBUG - Network change.
Feb 28, 2018 15:42:31.598 [0xb30ae530] DEBUG - NetworkInterface: Notified of network changed (force=0)
Feb 28, 2018 15:42:31.598 [0xb30ae530] DEBUG - Network change notification but nothing changed.
Feb 28, 2018 15:42:31.608 [0xb30ae530] DEBUG - NetworkInterface: received Netlink message len=160, type=RTM_NEWLINK, flags=0x0
Feb 28, 2018 15:42:31.609 [0xb30ae530] DEBUG - NetworkInterface: Netlink information message family=0, type=1, index=74, flags=0x11043, change=0x0
Feb 28, 2018 15:42:31.609 [0xb30ae530] DEBUG - Network change.
Feb 28, 2018 15:42:31.609 [0xb30ae530] DEBUG - NetworkInterface: Notified of network changed (force=0)
Feb 28, 2018 15:42:31.609 [0xb30ae530] DEBUG - Network change notification but nothing changed.
Feb 28, 2018 15:42:32.728 [0xb30ae530] DEBUG - NetworkInterface: received Netlink message len=160, type=RTM_NEWLINK, flags=0x0
Feb 28, 2018 15:42:32.728 [0xb30ae530] DEBUG - NetworkInterface: Netlink information message family=0, type=1, index=72, flags=0x11043, change=0x0
Feb 28, 2018 15:42:32.729 [0xb30ae530] DEBUG - Network change.
Feb 28, 2018 15:42:32.729 [0xb30ae530] DEBUG - NetworkInterface: Notified of network changed (force=0)
Feb 28, 2018 15:42:32.729 [0xb30ae530] DEBUG - Network change notification but nothing changed.
Feb 28, 2018 15:42:32.731 [0xb30ae530] DEBUG - NetworkInterface: received Netlink message len=160, type=RTM_NEWLINK, flags=0x0
Feb 28, 2018 15:42:32.731 [0xb30ae530] DEBUG - NetworkInterface: Netlink information message family=0, type=1, index=72, flags=0x11043, change=0x0
Feb 28, 2018 15:42:32.731 [0xb30ae530] DEBUG - Network change.
Feb 28, 2018 15:42:32.731 [0xb30ae530] DEBUG - NetworkInterface: Notified of network changed (force=0)
Feb 28, 2018 15:42:32.732 [0xb30ae530] DEBUG - Network change notification but nothing changed.
Feb 28, 2018 15:42:35.451 [0xb30ae530] DEBUG - NetworkInterface: received Netlink message len=164, type=RTM_NEWLINK, flags=0x0
Feb 28, 2018 15:42:35.451 [0xb30ae530] DEBUG - NetworkInterface: Netlink information message family=0, type=1, index=74, flags=0x11043, change=0x0
Feb 28, 2018 15:42:35.451 [0xb30ae530] DEBUG - Network change.
Feb 28, 2018 15:42:35.451 [0xb30ae530] DEBUG - NetworkInterface: Notified of network changed (force=0)
Feb 28, 2018 15:42:35.452 [0xb30ae530] DEBUG - Network change notification but nothing changed.
Feb 28, 2018 15:42:35.683 [0xb30ae530] DEBUG - NetworkInterface: received Netlink message len=164, type=RTM_NEWLINK, flags=0x0
Feb 28, 2018 15:42:35.683 [0xb30ae530] DEBUG - NetworkInterface: Netlink information message family=0, type=1, index=74, flags=0x11043, change=0x0
Feb 28, 2018 15:42:35.683 [0xb30ae530] DEBUG - Network change.
Feb 28, 2018 15:42:35.683 [0xb30ae530] DEBUG - NetworkInterface: Notified of network changed (force=0)
Feb 28, 2018 15:42:35.684 [0xb30ae530] DEBUG - Network change notification but nothing changed.
Feb 28, 2018 15:42:35.684 [0xb30ae530] DEBUG - NetworkInterface: received Netlink message len=164, type=RTM_NEWLINK, flags=0x0
Feb 28, 2018 15:42:35.684 [0xb30ae530] DEBUG - NetworkInterface: Netlink information message family=0, type=1, index=74, flags=0x11043, change=0x0
Feb 28, 2018 15:42:35.685 [0xb30ae530] DEBUG - Network change.
Feb 28, 2018 15:42:35.685 [0xb30ae530] DEBUG - NetworkInterface: Notified of network changed (force=0)
Feb 28, 2018 15:42:35.685 [0xb30ae530] DEBUG - Network change notification but nothing changed.
Feb 28, 2018 15:42:35.725 [0xb30ae530] DEBUG - NetworkInterface: received Netlink message len=164, type=RTM_NEWLINK, flags=0x0
Feb 28, 2018 15:42:35.725 [0xb30ae530] DEBUG - NetworkInterface: Netlink information message family=0, type=1, index=74, flags=0x11043, change=0x0
Feb 28, 2018 15:42:35.726 [0xb30ae530] DEBUG - Network change.
Feb 28, 2018 15:42:35.726 [0xb30ae530] DEBUG - NetworkInterface: Notified of network changed (force=0)
Feb 28, 2018 15:42:35.726 [0xb30ae530] DEBUG - Network change notification but nothing changed.
Feb 28, 2018 15:42:35.727 [0xb30ae530] DEBUG - NetworkInterface: received Netlink message len=164, type=RTM_NEWLINK, flags=0x0
Feb 28, 2018 15:42:35.727 [0xb30ae530] DEBUG - NetworkInterface: Netlink information message family=0, type=1, index=74, flags=0x11043, change=0x0
Feb 28, 2018 15:42:35.727 [0xb30ae530] DEBUG - Network change.
Feb 28, 2018 15:42:35.727 [0xb30ae530] DEBUG - NetworkInterface: Notified of network changed (force=0)
Feb 28, 2018 15:42:35.728 [0xb30ae530] DEBUG - Network change notification but nothing changed.
Feb 28, 2018 15:42:35.728 [0xb30ae530] DEBUG - NetworkInterface: received Netlink message len=164, type=RTM_NEWLINK, flags=0x0
Feb 28, 2018 15:42:35.728 [0xb30ae530] DEBUG - NetworkInterface: Netlink information message family=0, type=1, index=74, flags=0x11043, change=0x0
Feb 28, 2018 15:42:35.728 [0xb30ae530] DEBUG - Network change.
Feb 28, 2018 15:42:35.728 [0xb30ae530] DEBUG - NetworkInterface: Notified of network changed (force=0)
Feb 28, 2018 15:42:35.729 [0xb30ae530] DEBUG - Network change notification but nothing changed.
Feb 28, 2018 15:42:35.729 [0xb30ae530] DEBUG - NetworkInterface: received Netlink message len=164, type=RTM_NEWLINK, flags=0x0
Feb 28, 2018 15:42:35.729 [0xb30ae530] DEBUG - NetworkInterface: Netlink information message family=0, type=1, index=74, flags=0x11043, change=0x0
Feb 28, 2018 15:42:35.729 [0xb30ae530] DEBUG - Network change.
Feb 28, 2018 15:42:35.730 [0xb30ae530] DEBUG - NetworkInterface: Notified of network changed (force=0)
Feb 28, 2018 15:42:35.730 [0xb30ae530] DEBUG - Network change notification but nothing changed.
Feb 28, 2018 15:42:35.770 [0xb30ae530] DEBUG - NetworkInterface: received Netlink message len=164, type=RTM_NEWLINK, flags=0x0
Feb 28, 2018 15:42:35.770 [0xb30ae530] DEBUG - NetworkInterface: Netlink information message family=0, type=1, index=74, flags=0x11043, change=0x0
Feb 28, 2018 15:42:35.770 [0xb30ae530] DEBUG - Network change.
Feb 28, 2018 15:42:35.771 [0xb30ae530] DEBUG - NetworkInterface: Notified of network changed (force=0)
Feb 28, 2018 15:42:35.771 [0xb30ae530] DEBUG - Network change notification but nothing changed.
Feb 28, 2018 15:42:35.772 [0xb30ae530] DEBUG - NetworkInterface: received Netlink message len=164, type=RTM_NEWLINK, flags=0x0
Feb 28, 2018 15:42:35.772 [0xb30ae530] DEBUG - NetworkInterface: Netlink information message family=0, type=1, index=74, flags=0x11043, change=0x0
Feb 28, 2018 15:42:35.772 [0xb30ae530] DEBUG - Network change.
Feb 28, 2018 15:42:35.772 [0xb30ae530] DEBUG - NetworkInterface: Notified of network changed (force=0)
Feb 28, 2018 15:42:35.773 [0xb30ae530] DEBUG - Network change notification but nothing changed.
Feb 28, 2018 15:42:35.773 [0xb30ae530] DEBUG - NetworkInterface: received Netlink message len=164, type=RTM_NEWLINK, flags=0x0
Feb 28, 2018 15:42:35.773 [0xb30ae530] DEBUG - NetworkInterface: Netlink information message family=0, type=1, index=74, flags=0x11043, change=0x0
Feb 28, 2018 15:42:35.774 [0xb30ae530] DEBUG - Network change.
Feb 28, 2018 15:42:35.774 [0xb30ae530] DEBUG - NetworkInterface: Notified of network changed (force=0)
Feb 28, 2018 15:42:35.774 [0xb30ae530] DEBUG - Network change notification but nothing changed.
Feb 28, 2018 15:42:36.501 [0xb4c31530] DEBUG - Thread: Running async task started by thread 0xb4e42530.
Feb 28, 2018 15:42:36.583 [0xb30ae530] DEBUG - NetworkInterface: received Netlink message len=164, type=RTM_NEWLINK, flags=0x0
Feb 28, 2018 15:42:36.583 [0xb30ae530] DEBUG - NetworkInterface: Netlink information message family=0, type=1, index=72, flags=0x11043, change=0x0
Feb 28, 2018 15:42:36.583 [0xb30ae530] DEBUG - Network change.
Feb 28, 2018 15:42:36.583 [0xb30ae530] DEBUG - NetworkInterface: Notified of network changed (force=0)
Feb 28, 2018 15:42:36.584 [0xb30ae530] DEBUG - Network change notification but nothing changed.
Feb 28, 2018 15:42:36.585 [0xb30ae530] DEBUG - NetworkInterface: received Netlink message len=164, type=RTM_NEWLINK, flags=0x0
Feb 28, 2018 15:42:36.586 [0xb30ae530] DEBUG - NetworkInterface: Netlink information message family=0, type=1, index=72, flags=0x11043, change=0x0
Feb 28, 2018 15:42:36.586 [0xb30ae530] DEBUG - Network change.
Feb 28, 2018 15:42:36.586 [0xb30ae530] DEBUG - NetworkInterface: Notified of network changed (force=0)
Feb 28, 2018 15:42:36.586 [0xb30ae530] DEBUG - Network change notification but nothing changed.
Feb 28, 2018 15:42:37.429 [0xb30ae530] DEBUG - NetworkInterface: received Netlink message len=220, type=RTM_NEWLINK, flags=0x0
Feb 28, 2018 15:42:37.429 [0xb30ae530] DEBUG - NetworkInterface: Netlink information message family=0, type=1, index=74, flags=0x11043, change=0x0
Feb 28, 2018 15:42:37.429 [0xb30ae530] DEBUG - Network change.
Feb 28, 2018 15:42:37.429 [0xb30ae530] DEBUG - NetworkInterface: Notified of network changed (force=0)
Feb 28, 2018 15:42:37.430 [0xb30ae530] DEBUG - Network change notification but nothing changed.
Feb 28, 2018 15:42:37.451 [0xb30ae530] DEBUG - NetworkInterface: received Netlink message len=220, type=RTM_NEWLINK, flags=0x0
Feb 28, 2018 15:42:37.451 [0xb30ae530] DEBUG - NetworkInterface: Netlink information message family=0, type=1, index=74, flags=0x11043, change=0x0
Feb 28, 2018 15:42:37.451 [0xb30ae530] DEBUG - Network change.
Feb 28, 2018 15:42:37.452 [0xb30ae530] DEBUG - NetworkInterface: Notified of network changed (force=0)
Feb 28, 2018 15:42:37.452 [0xb30ae530] DEBUG - Network change notification but nothing changed.
Feb 28, 2018 15:42:41.021 [0xb30ae530] DEBUG - NetworkInterface: received Netlink message len=224, type=RTM_NEWLINK, flags=0x0
Feb 28, 2018 15:42:41.021 [0xb30ae530] DEBUG - NetworkInterface: Netlink information message family=0, type=1, index=72, flags=0x11043, change=0x0
Feb 28, 2018 15:42:41.021 [0xb30ae530] DEBUG - Network change.
Feb 28, 2018 15:42:41.021 [0xb30ae530] DEBUG - NetworkInterface: Notified of network changed (force=0)
Feb 28, 2018 15:42:41.022 [0xb30ae530] DEBUG - Network change notification but nothing changed.
Feb 28, 2018 15:42:42.748 [0xb30ae530] DEBUG - NetworkInterface: received Netlink message len=160, type=RTM_NEWLINK, flags=0x0
Feb 28, 2018 15:42:42.748 [0xb30ae530] DEBUG - NetworkInterface: Netlink information message family=0, type=1, index=72, flags=0x11043, change=0x0
Feb 28, 2018 15:42:42.748 [0xb30ae530] DEBUG - Network change.
Feb 28, 2018 15:42:42.748 [0xb30ae530] DEBUG - NetworkInterface: Notified of network changed (force=0)
Feb 28, 2018 15:42:42.749 [0xb30ae530] DEBUG - Network change notification but nothing changed.
Feb 28, 2018 15:42:44.497 [0xb30ae530] DEBUG - NetworkInterface: received Netlink message len=164, type=RTM_NEWLINK, flags=0x0


#11

Getting up to 69 network change RTM_NEWLINK events a second does not look right. There is a network setup issue
Most of the events fall within 1-15 events a second

That a side, we have uPnP Port mapped ok

Feb 28, 2018 16:26:56.535 [0xb26ad530] DEBUG - NAT: UPnP, mapped port 18141 to 192.168.1.15:32400.

But when plex.tv was requested to test out the route into the server through WAN Port 18141 and Public WAN IP 72.79.xxx.xxx, it did not get through - confirmed by the event it sent back to show a connectivity="0" status

Feb 28, 2018 16:27:07.374 [0xaefc0530] DEBUG - EventSource: Got event [data] '<Message address="72.79.xxx.xxx" port="18141" asyncIdentifier="630e51e8-8c4d-45e4-83cf-c917dee993cc" connectivity="0" command="notifyConnectivity"/>'

The test of the connectivity is through a request from back-end systems - normally from an IP address starting with 50.xx.xx.xx or 54.xx.xx.xx

Do you have any whitelisting / blacklisting of IP addresses / regions ?


#12

@plex-linux Thanks for all of your help. Both Plex and the Netgear router have updated within the last week. There is no process that I know of that is consuming the Netgear's resources.

@sa2000 There are no restrictions whatsoever, on the Netgear, or my main Verizon Actiontech router


#13

try a port forward next and selecting manually specify port and entering the public port that is forwarded to 32400 for 192.168.1.15 - instead of the uPnP port that the logs showed

So how is the setup ? The R8900 is a router and you also have another router.
ISP wan connection comes to the R8900 and it has a 192.168.1.xx subnet with 192.168.1.15 is its IP address on that LAN subnet?

and you have Actionech router on another subnet with the plex client apps?


#14

@sa2000 I have tried manually port forwarding, to no avail.

My setup is my Plex server on my Netgear R8900 router which is in AP mode. The Netgear is connected to my Actiontec router provided by my ISP.


#15

you could get screenshots of setup (port forward/remote access server settings and logs after restart) for the port forward case and manually specify port

To eliminate the R8900 why not setup PMS on a laptop and see if the requests from 54.xx.xx.xx / 50.xx.xx.xx come in to the laptop. Then that would confirm the actionec router is not blocking anything

Then go back to testing with the R8900


#16

@sa2000 Thanks for the suggestion. I tried PMS on a PC of mine and it encounters the same problem.


#17

@gutkinfam said:
@sa2000 Thanks for the suggestion. I tried PMS on a PC of mine and it encounters the same problem.

we can switch the investigation to that because it would be a lot simpler - especially as you can run wireshark and see if the packets from connectivity tests are actually coming in and getting dropped before reaching Plex Media Server

Please use port forward remembering with 2 servers on the local network, you would need to have port forwards as per example here

Example
```
PMS1 - WAN Public Port 32410
PMS1 has local IP 192.168.1.10 which is DHCP Reserved in the Actionech router
Port Forward tcp port 32410 to local tcp port 32400 to PMS1 with local IP 192.168.1.10
PMS1 Remote Access Settings: Manually Specify Port ticked and entering 32410 in the box

PMS2 - WAN Public Port 32420
PMS2 has local IP 192.168.1.20 which is DHCP Reserved in the Actionech router
Port Forward tcp port 32420 to local tcp port 32400 to PMS2 with local IP 192.168.1.20
PMS2 Remote Access Settings: Manually Specify Port ticked and entering 32420 in the box
```


#18

I tried that and still encounter problems @sa2000


#19

@gutkinfam said:
I tried that and still encounter problems

As I said, we can switch the investigation to geting it to work on the windows pc as it would be easier - so we start again with getting the information and logs whilst the server setting page for remote access is on the screen as that would instigate a connectivity test when the remote access is enabled

I presume you would have gone through both router and pc reboots

Diagnostics

  • screenshot of router dhcp table showing dhcp reservation for the ip for the pc
  • screenshot of Router port forward entry For the pc plex media server
  • ipconfig /all Output from the pc
  • Screenshot of the server remote access advanced setting fir the pc showing manually specify port ticked and the port forward public port entered
  • Plex media server log file from launch up to time when the remote access fails

Please also try adding this rule to the windows firewall. This is a port rule and s additional to the 3 program rules for Plex

Port inbound rule
Remote port = any
Local port = 32400
Porotocol tcp
Remote ip = any
Programs = any
Action = allow

Also double check that the network connection is not showing as public or unknown network

After examining the logs and the screenshots it may be necessary to repeat with wireshark running on the pc - in that case the wireshark capture saved Pcap file should be zipped and sent by private message so it can be checked against the logs for that time to see if the connectivity request - is reaching the PC


#20

@gutkinfam said:
@sa2000 I have tried manually port forwarding, to no avail.

My setup is my Plex server on my Netgear R8900 router which is in AP mode. The Netgear is connected to my Actiontec router provided by my ISP.

Is the Actiontec also a modem?