Issues Connecting to PS3

playstation

#1

Hello,

I have a Plex media server running at home. I'm at a different location at the moment, and am unable to access my content through a PS3 (which I have used months ago successfully to view my Plex server.) I can view my content through my MacBook as well as my iPhone, so I know the server is running. I can access Netflix on the PS3, so I know it has internet access. I am logged into my Plex account on the PS3. I can see my server in the drop down, but it's highlighted red with a "Connecting" error. When I select it, it eventually times out, and shows me a screen full of text saying how it failed trying to connect to two IPs (one external IP, which is the external IP of my home's internet, and another local IP (which is the local IP of my QNAP on my home network, but doesn't map to anything on the current network I'm on.))

Is the PS3 app somehow caching an expired IP address? Does anyone have any suggestions how I can fix this. Unfortunately I don't have physical or remote (SSH) access to my QNAP. The PS3 isn't my primary device for viewing Plex content. I only use it when visiting the folks. I'm not familiar with the current state of the PS3 Plex app, or how to possibly fix this issue. I also tried signing out and signing back into the Plex client without any luck.

Thanks


#2

I gave up. I tried uninstalling and reinstalling the Plex app, hoping it would fetch the correct IP address to connect to, but it still failed. I confirmed the external IP that is displayed in the "failed to connect" dialog is not reachable via ping. Since my phone and laptop can connect to my Plex server, I'm only more convinced the PS3 isn't getting the most up-to-date address.


#3

I'm having the same error within my home on my home network.

Plex server is on synology nas 415+.

Plex works in Samsung tv, PS4 and xbox360

But not the PS3.

One thing I have done recently is add a vpn to the nas, however that is for external traffic. . I have another PS3 but haven't tried that yet.


#4

I still haven't gotten this to work. The last thing I tried is deleting all of the PS3 entries from the "Devices" tabs in my Plex server's settings page, which forced me to re-link the PS3 just now, but it still fails to find the server. The PS3 is essentially useless now for connecting to the Plex server, which is unfortunate.


#5

Having the same issue, it may be on the ps3 side of things because my gf's ps3 can also access plex fine.


#6

It certainly is frustrating. The only thing left for me to try is to do a full wipe and reset of the PS3. Of course that probably won't prevent this from happening again. I certainly don't want to have to reset it each time this happens.

In my initial post I was hypothesizing that the Plex app was using an incorrect stale IP. I actually confirmed the external IP address it is complaining about in the error dialog is in fact correct. So it's not a caching issue.

Also, I can run the latest Plex media server on my macbook and connect to it through the PS3 when it's on the same network. So I don't think it's a handshaking issue between the PS3 app and the Plex Media Server (unless the QNAP plex media server specifically doesn't allow the PS3 to connect... which I doubt, since my friends have the exact same QNAP model and are running the same Plex media server version, and I can connect to their libraries just fine through the PS3.)


#7

Did you ever get this issue figured out? I’m running into what sounds like the exact same issue. Have Plex Server running on my MacBook, and am able to access content on the Plex app on my iPhone. Not able to connect to Plex server on my PS3, and haven’t been able to since beginning to use a VPN (NordVPN).


#8

We never did. I eventually got my father an AppleTV 4 to run Plex on since I wasn’t able to get it working on the PS3. The AppleTV 4 instance of Plex ran perfectly fine behind the same router, which only further convinced me that the issue was specific to the PS3, and not some internet/router issue. The only thing I didn’t try was a full reset/wipe of the PS3. I have no intention of trying this.