Music Playback Stopping

android-mobile

#1

Nexus 6P
Android 7.0
Client 4.31.2.310 (7deaa753)

When listen to music on my phone, playback occasionally gets stuck. The only way to fix this is to skip forward/back a song. Seeking does not fix the issue. I have reproduced this issue consistently both while stream and playing locally synced content. Please advise on a fix for this bug.


#2

@MovieFan.Plex any thoughts?

It's been nearly three weeks since this issue was opened with no response from PLEX.


#3

Still having this issue on newer app version:

Nexus 6P
Android 7.0
Client 4.32.2.597 (cca92406)


#4

I just had this issue in the web client too.
@MovieFan.Plex any thoughts?


#5

I have the same issue.

Uff

Ciao

Luigi


#6

Sorry, didn't get notified of this thread. The . in my username messes things up.

I'm not aware of this issue, but if you see it in Web and Android, it could be the file. Do you see this with all music file? Would you mind providing me (PM) 1 song that does this so I can check and see if I can reproduce on my end.


#7

I've seen this issue with all of the albums I've listened to lately (probably ~100 songs or so). I've seen the issue happen intermittently through about 40-50% of those.

I can send a file if you think that's what the issue is, but it seems too common among separate files to be tied to the actual audio files. If I listen to the same files on my PC they playback without issue.

Also, if I restart the song in PLEX after it gets stuck, it usually plays through without issue the second time.


#8

Ok, then it's probably not the song. Can you try to recreate the problem then get me the app AND server log right away?


#9

I haven't forgotten about this: I haven't had a chance to collect the logs
lately. I will try to submit them by the end of the week.


#10

I have the same problem.

I have been using the sync feature. I like to listen to music when I ride bike in the mountains. It happens all the time when I am playing local music content on my phone.

NEXUS 6P
fully updated Plex app and Android 7.0

The problem started about 3 weeks ago I think.


#11

Same problem for me and I also have the 6P on android 7.0. Maybe a nougat issue? I just updated to the V5 of the Plex app, maybe that will fix it!


#12

I also have the same issue, also on a 6P running android 7.0.

I've also updated to V5 of the app. I was really happy to see the introduction of local playlists and shuffle and such, but was dismayed by the fact this bug is still present.

How does one get a log from the app and server? I'll happy post them.

Edit: Just wanted to add that I have not had any issues with the web client. I use that a lot to listen to music at work, and have not had any issues at all.


#13

You can find link to instructions on getting the logs in my signature.


#14

Thanks, sorry never even thought to look there. I've attached the zipped log file that I got from the plex app.

From what I can tell from looking at the log myself, and trying to remember what song was playing when it happened, I think it happened sometime after [10-18 19:05:06.201] in terms of the timecode.

I've also included the server logs just in case, but this did occur while I was in 'Local and synced content' mode in the middle of a gym, so not sure the server is really at fault.

Thanks, let me know if you need anymore info.


#15

Could this be related to the revised Doze methodology in Android 7.0? I've noticed similar things in other apps. I will try disabling battery optimization for Plex on my phone and see if this improves things.


#16

Oh thanks for reminding me. I thought of that too, and already disabled battery optimization for plex, prior to this latest incident.

I wouldn't be surprised if it is a nougat issue, but I actually can't compare it very much, as I've only recently started using Plex to host my music. I previously used a Subsonic server for my music, but decided to give plex a shot at it, since it works a little better for audio books, and can keep track of progress through long chapters, something subsonic can't do.


#17

Battery optimization has had no effect for me. Songs still stop.

Keeping the Plex app "on top" also has no effect.

I have been experiment for a few days now but I have not found anything that will make the problem go away.
It only effects "local" music files on the phone.

I have not tested the new 5.0 Android app.
It is not in the Play Store yet.


#18

If it worked perfectly on Marshmallow...I have a feeling its something to do with Nougat. I just updated to 7.1 from the beta program and have already heard that this issue may be fixed. We'll see!


#19

I've noticed this same problem and I have the same setup (Nexus 6P, Android 7.0, etc.). I believe this is actually a problem with the phone (6P) and Nougat (Android 7.0). I've tried music playback in several other apps and they all do the same thing. I've also tried playback locally, streaming, through Bluetooth, headphones, and internal speakers. All the same issue and I've confirmed that the issue seems to exist in all music apps (for me anyways) regardless of if I'm playing through Plex, Google Play, or Amazon Music. SO far I've tried 1) factory reset, still has pausing issue with no additional apps installed 2) removed battery optimization on Plex, same issue 3) disabling "OK Google" constant listening, still same issue 4) disabling ambient display, still same issue. You might give one of the 4 a try (especially disabling OK google) as they seem to be working for some 6P users.

I've contacted Huawei, but they refuse to respond up to this point (sent 5 e-mail and called twice). My guess is that this is a Nougat Bug at this point and hopefully the release of Android 7.1 in December for us will fix the issue. Until then it seems we have no hope.

I'll post if I ever find a solution, but have somewhat given up at this point. Please let us know if you find a solution as well as I'm excited to be able to listen to music on my phone again :)


#20

@MovieFan.Plex is there any word from Plex on this issue? It's been 2 months now with no resolution.