Opera TV is now VEWD, and Plex is no longer working!!!


#1

WTH happened with this? Everything was fine. Then, a week ago, the Opera TV app wouldn't load. Now, it just black screens.

Should it still work? What do I need to do on my BluRay Player?

And, why isn't there a Player area for this specific player?


#2

Agreed. Plex was working fine until Opera TV changed to Vewd. Any help would be appreciated


#3

Could you please state the precise make and model of your smart tv’s please?


#4

My issues are with Opera TV on a Sony BluRay Player (BDP-S3700). I have two of them and get the exact same results on both.


#5

Same. Sony BDPS1700 Blu Ray. I open Plex in the Opera/Vewd store and it says “this needs to open up in a browser window”. I select yes and get a screen that says “device not supported”.


#6

As of this morning, I was able to launch the Plex app via Opera TV on a Sony BDP-BX350. I will be testing the S3700’s again over the weekend (different location).


#7

Same issue. Opera tv changed to vewd - plex won’t open. When you select the app a question prompts if you’d like to open internet browser. If you select “no” blank black screen. If you select “yes” says not supported.


#8

Just to clarify when you select the plex app from vewd(formerly opera tv) black screen (after selecting “no” for internet browser , then after several minutes a message appears “cannot open at this time” if you select “yes” for internet browser message states “not supported”

This is from my Sony Blue Ray Player


#9

Confirmed - still not working on two different Sony BDP-S3700 BluRay players.


#10

Yes same problem here which is how i found this forum chat


#11

My Smart TV is a Hisense 55M7000UWG 55"(139cm) UHD LED LCD Smart TV.
The Plex app was already in favourites when first purchased. I tried removing it and then tried to re-install but there is no longer any Plex app in the Opera Store.
I hope this can be sorted out soon.


#12

I believe you bought a used TV if Plex was already in the favorites. Re-adding it should be simple by launching Opera TV, navigating left to the Apps section, navigating right so you’re able to scroll through the various apps, then navigating down. Plex is there, it just doesn’t work on a number of devices any more.


#13

Until Plex updates their Opera TV (oops, I mean Vewd) app, it won’t work. Vewd broke some things.

In the meantime, there is a workaround to get to Plex through a direct URL. It’s simple and brilliant. It will take maybe 20 minutes to set up the first time, and afterwards it’s about three extra clicks to get in. Make sure to follow the steps carefully, but you can’t really screw anything up even though “developer mode” sounds scary.

mattpilz.com/how-to-unofficially-install-the-plex-app-on-opera-tv-if-its-not-available/


#14

Have you actually tried this on a DVD player where the app isn’t working? Because the browser also doesn’t load on those devices.


#15

This works on devices that don’t even have a browser.


#16

I should clarify, Opera TV itself is technically a browser, but locked-down devices only let you use stock apps. You can’t navigate to a specific URL.


#17

You didn’t answer my question.

Opera TV browser itself doesn’t work on the devices that won’t load the Plex app. And, this isn’t an issue of not being able to find the app, it’s an issue of the app not launching. So, what good is it to forcibly load an app that isn’t going to work?

Have you tried this with any success?


#18

Yes, I have tried this successfully. I watched some downloaded episodes of Inhumans yesterday.

If Opera TV/Vewd is not launching at all, you might need to update your device’s firmware. I had updated my firmware the same day Opera launched Vewd (total coincidence) so I don’t know whether that’s actually the problem.


#19

Not a device firmware issue. Opera TV launches fine. The issue is in launching the Plex app specifically as other apps work. Your recommendations are not related to the issues at hand in this thread.


#20

“Opera TV browser itself doesn’t work on the devices that won’t load the Plex app.”
“Not a device firmware issue. Opera TV launches fine.”

Which is it? Does Opera TV work or not?

If Opera TV launches at all, then the procedure should work. It uses the hidden app called “URL Loader”, not the browser.