Playback Stuttering and Freezing with Plex for XBOX One



I'm seeing almost constant stuttering and freezing on the latest version of the XBOX One PLex client.. when it happens I see this in the log:

Jan 01, 2016 17:35:51 [0x10b681000] ERROR - handle_stream_read error 54 Connection reset by peer
Jan 01, 2016 17:35:51 [0x10b681000] WARN - LongPoll: Got error, closing.
Jan 01, 2016 17:37:19 [0x10b681000] ERROR - handle_stream_read error 54 Connection reset by peer
Jan 01, 2016 17:37:19 [0x10b681000] WARN - LongPoll: Got error, closing.
Jan 01, 2016 17:38:47 [0x10b681000] ERROR - handle_stream_read error 54 Connection reset by peer
Jan 01, 2016 17:38:47 [0x10b681000] WARN - LongPoll: Got error, closing.
Jan 01, 2016 17:40:15 [0x10b49c000] ERROR - handle_stream_read error 54 Connection reset by peer
Jan 01, 2016 17:40:15 [0x10b49c000] WARN - LongPoll: Got error, closing.
Jan 01, 2016 17:41:44 [0x10b681000] ERROR - handle_stream_read error 54 Connection reset by peer
Jan 01, 2016 17:41:44 [0x10b681000] WARN - LongPoll: Got error, closing.
Jan 01, 2016 17:43:12 [0x10b681000] ERROR - handle_stream_read error 54 Connection reset by peer
Jan 01, 2016 17:43:12 [0x10b681000] WARN - LongPoll: Got error, closing.
Jan 01, 2016 17:44:40 [0x10b49c000] ERROR - handle_stream_read error 54 Connection reset by peer
Jan 01, 2016 17:44:40 [0x10b49c000] WARN - LongPoll: Got error, closing.

.. sometimes the app actually freezes during playback. This can take anywhere between 7 seconds to 2 minutes to resolve itself.

I'm about 80% confident that this only occurs on .MKV files. All appear to have AAC encoding, as well (same confidence). Content bandwidth doesn't appear to be the issue: This happens at 1080p, and 720p also.

The Plex Server is a pimped Mac Mini i5 2.5GHz w/ 16GB RAM, and TOTAL CPU never really exceeds 15-20% ... running 1GBE to the XBOne (ie. NOT WiFi). There should be no network or server CPU constraints affecting this issue.

I don't see a lot of matches for this LongPoll issue in the Plex Forums.. this could be an interesting one.


I should add that the big freezes appear every 35 minutes or so. So, three times in a typical movie; once per TV show. Shorter programs (ie. 30 mins) do not typically exhibit this.


This just started happening for me, as well. It's almost as if the server is sending out to the internet, and then Xbox is pulling it down, instead of just streaming locally...


I am also suffering with poor Xbox One (wired) performance. Xbox 360 (Wireless) plays the same REMUX MKV flawlessly.


I am seeing this as well on certain movies.


me too. It is very frustrating. I have turned off Direct Streaming and Direct Play (I think that is what the two options are). Didn't help


Same here! I had to switch over to my appletv one and perfect!
its been doing it a lot and its basically un usable! :(

glad i have the apple tv4


Yeah, this is a pretty big problem. This happens to me whether it's on WiFi or gigabit ethernet. The X1 app is unusable with direct play and it wasn't always like this.

I've switched over to the Chromecast. I can't believe the $30 google gimmick works better than the X1.


I use the Xbox One client for 10 to12 hours a day (stuff playing in the background while working) and I haven't experienced this.

All my media is MP4/X.264 4.0 level with at least a 2 channel AAC audio track as the first track. Just throwing this info out there for diagnostic purposes.



We're aware some users are experiencing stuttering issues (possibly since the dashboard update?) and we are looking into the cause. We're still not sure if it's an issue on our side or on the OS side. Sorry for the inconvenience caused in the meantime!


as of today (1/11/2016 on xbox one and latest updates) my machine didnt bogg or hesitate once... streaming from plex (on a wired pc to my network) to my Xbox One which is wireless...


My system is wired (always wired with media streaming) and its stuttering like crazy! video is unwatchable!
I hope this gets fixed soon


Wireless (~25mbps down, ~15mbps up, 99/100% strength, 0 packet loss)
Wired (Cat5 to gigabit switch. ~60mbps down, ~20mbps up.)
Open NAT
3TB External Storage USB 3.0
Plex client latest update
Xbox Dashboard latest preview build update

AMD FX-4200 Quad-core 3.30 Ghz
16tb DDR3 RAM
1tb 7200rpm Sata (OS & Plex)
5tb 7200rpm USB 3.0 (Media Files)
Ethernet to Wireless Router to Switch (depending on config)
Latest Plex Pass build

FiOptics Gigabit Package with average speedtest results of 600mbps down / 50mbps up from the server
ZyXEL Wireless Router Supports. Ethernet up to 1gbps, Wireless up to 300mbps

Files affected: MKV 720p & 1080p with AC3 5.1. Some files with AAC are affected, but those seem to be more in the 1080p resolution.

Files OK: Any standard resolution files I've tried. XVID 720p seems to playback OK, but I have a limited number of files in this format to sample.

Direct play is completely unusable. Stuttering at the beginning and every 20 seconds. I used to be able to get around this with the D-Pad trick to ffwd or rewind a bit, but this no longer works. Same results on both a wireless & wired setup. No known network issues. WiFi analyzer app & Xbox Network info are both healthy. I've also moved the Xbox to the same room as the router and same results.

Direct stream works on TV shows, but has issues on movies. I assume that the movies are higher bitrate but definitely share a longer run time and larger file size. With movies, it'll play without stuttering but pauses at the same intervals where I would experience the stuttering.

Transcoding works. On the server side it is set to 'Prefer higher speed encoding' to accommodate remote streams. I'm unhappy with falling back to transcoding when up until mid-October, I had no issues direct-playing.

I've also setup a Roku, Chromecast, and an old Logitech Revue in the same area since this started. No issues with those other than certain file format limitations.

My Dropbox is full and don't have much leeway to delete anything due to work obligations (this was asked in the past.) I'd be glad to share a file that gives me an issue if you have any recommendations on a place to dump to. There are definitely plenty of file options as it has been a guarantee that any HD MKV with AC 5.1 will throw the Xbox into fits.


Still experiencing this. There's been one client update since my original post (I think) on the XBone client. What's curious is that there is nothing specific attributable to this in the log files anymore.

Pauses take about 1-3 minutes to resolve, and then play resumes. You can force it to resume by rewinding and pressing play again on the client.


I to am suffering this in last few months and as some one has pointed out, it seems to be .mkv files. Mine has always resolved after a minute or 2, in fact last night i just paused the playback for a few seconds and then it was OK, but still seems an annoying step backwards from the buttery smooth playback I have had for the previous year


Same problem as everyone else. Plex said they were looking at this issue back in January... It's now mid March and the silence is deafening! I don't care if it's a Plex issue or an OS issue, I pay an annual subscription for a product that now doesn't work which worked fine before. It would be nice to at least have some sort of update on this issue or when we can expect it to be resolved. Really not impressed.


Just to let you know where we are (I apologize, I may have posted an update about this issue in a different thread), we are confident the issue is with the Xbox One OS and Microsoft are still investigating. Apologies to all those affected.


Hi Moussa. I am seeing this on Android (Google TV) player as well now.

(Bah.. ignore.. that seems to have been a different issue).


Same issues here, and uf u look around, there's 5 other current threads here w/ the same issues cited: stuttering, freezes, pauses, etc. when will this be fixed already? 3 months should be enough time to have worked this out!


Am also experiencing this issue.