Plex DVR not recording

server-freebsd

#1

I am running a plex server on freeNAS 9.10. After setting up my hdhomerun prime I choose a program to record. It shows in the recording schedule but will not start recording. There are no error messages. I decided to setup a plex server on my windows machine. Everything works fine on it... any clue what could be going on?


#2

Same issue.

The only thing I haven't tried yet is to update. Will see if that works.


#3

Hi guys,

my plex server is running on a Windows 2012 Server, until now everithing was good. Today i've added a HDHomeRun Expand with 4 DVB-C tuners. I can watch TV with the HDHomeRun-App. But when i add a recording to my list, it looks like if the server recordes but there is no file.
One spetiality, i have my HDHomeRun on an other subnet then the server.
Could that be the problem?
There is no write issue, because the user, plex runs with, could write to the location of the recordings.
sorry for me bad english :smile:

hope you could help me.


#4

@swoop124 said:
Hi guys,

my plex server is running on a Windows 2012 Server, until now everithing was good. Today i've added a HDHomeRun Expand with 4 DVB-C tuners. I can watch TV with the HDHomeRun-App. But when i add a recording to my list, it looks like if the server recordes but there is no file.
One spetiality, i have my HDHomeRun on an other subnet then the server.
Could that be the problem?
There is no write issue, because the user, plex runs with, could write to the location of the recordings.
sorry for me bad english :smile:

hope you could help me.

This should be a separate thread.

HDHomerun devices need to be on the same subnet to be discovered. When using the HDHR utility to watch live TV from my laptop I have trouble watching the devices when on different subnets

If you are running out of IP space expand your network. Refer to your network equipment manufacturer for information on how to expand your network.


#5

This happens to me as well. Strange thing is most shows record just fine but a few select shows show "successfully recorded" in the Recording Schedule page but they aren't actually anywhere to be found in the directory it supposedly recorded to. This has happened on Plex for Linux (Ubuntu and CentOS) and Plex in FreeBSD. All were setup fresh i.e., no data from another install moved to the next Plex machine.


#6

The same thing is happening to me. I'm using Windows 2012 R2 Server and sometime it records fine and sometimes it shows "successfully recorded" in the recording schedule, but the file is not saved to my hard drive.


#7

I'm running Plex server on a Windows 7 computer with USB storage. About 50% of the time it records and the other 50% it doesn't. Once it appeared to record but when I tried to watch my show, it said the file was corrupt.


#8

Same problem for me, many recordings are "successfully recorded" but no recording actually available. This has happened on all three different installations I've tried: Ubuntu 17.04, Windows 10 and Mac OS X Sierra.

It seems "married" to some shows (e.g.: two different home improvement shows set to record anything without restriction will never record for me). I thought it was related to some stations that are intermittent in their signal sometimes, but it will record the next show just fine still showing the signal drops in the recordings.

One time I saw it "recording" a show, and when the indicator shown it was done recording, it briefly came up with a red exclamation point icon and then changed over to no icon (not even the "play" icon with "Recorded Successfully" as the status in the details.

This has been happening for me since February.


#9

Same to me with Nvidia Shield TV and Haupaugge DVB-T dual card. It only worked the first time


#10

On FreeNAS, my guess would be permissions. PMS needs to be able to write to the folder you are saving DVR recordings too. I've created a separate DVR folder in my media dataset, as the movies and TV shows folders have permissions so I can copy across content from my Mac, but these won't allow PMS to save to them.


#11

Has anyone found a solution to this? Latest Plex build with win 10 Pro.

Shows will record successfully if scheduled from the 'playing now' or 'upcoming' lists, but when I schedule the program to record from using the search bar, it shows recorded but is not in any folder on the drive.


#12

Anyone looked in their Plex Media Server log file to see if there are any messages indicating a possible reason for the show not appearing?

Perhaps something like the message below that I found the other night in another users log file:
Jul 13, 2017 16:29:41.817 [10368] DEBUG - Garbage Collector: Deleting expired unwatched content for The FBI Files (policy: -30 before 2017-06-13)
Jul 13, 2017 16:29:41.843 [10368] DEBUG - Garbage Collector: Deleting episode 14 - Rebellion in Paradise (beyond window of 30 days old)

In this users case they had a deletion policy of 30 days on the library show settings. Plex uses the original air date of episodes.


#13

@johnm_ColaSC said:
Anyone looked in their Plex Media Server log file to see if there are any messages indicating a possible reason for the show not appearing?

Perhaps something like the message below that I found the other night in another users log file:
Jul 13, 2017 16:29:41.817 [10368] DEBUG - Garbage Collector: Deleting expired unwatched content for The FBI Files (policy: -30 before 2017-06-13)
Jul 13, 2017 16:29:41.843 [10368] DEBUG - Garbage Collector: Deleting episode 14 - Rebellion in Paradise (beyond window of 30 days old)

In this users case they had a deletion policy of 30 days on the library show settings. Plex uses the original air date of episodes.

I just ran into this myself, it was because I misinterpreted the "Keep" setting of the DVR Record Options. I thought setting "Keep" to "Episodes from the past 7 day" meant "Keep episodes that were recorded within the last 7 days", but what it actually means is "Keep episodes that originally aired within the last 7 days". They should probably reword that setting to make it more clear.


#14

@rhithyn said:
Same problem for me, many recordings are “successfully recorded” but no recording actually available. This has happened on all three different installations I’ve tried: Ubuntu 17.04, Windows 10 and Mac OS X Sierra.

It seems “married” to some shows (e.g.: two different home improvement shows set to record anything without restriction will never record for me). I thought it was related to some stations that are intermittent in their signal sometimes, but it will record the next show just fine still showing the signal drops in the recordings.

One time I saw it “recording” a show, and when the indicator shown it was done recording, it briefly came up with a red exclamation point icon and then changed over to no icon (not even the “play” icon with “Recorded Successfully” as the status in the details.

This has been happening for me since February.

Same here. Have this issue for a while. And all of my recordings except for local news are set to keep all recordings.


#15

@SirGio Is the show settings in your library set to keep all? Garbage Collection like the log entries I showed above are looking at the show settings in the library, not the recording settings. Click your library show is being recorded to, click the show, and then click edit and go to the advanced tab.


#16

@johnm_ColaSC I didn't know there were DVR settings at the show level, thanks for that tip, however I checked and all my shows seem to be respecting the initial setup of keeping all episodes and keeping 4 for local news shows.
I might have a different issue than you however I've found similar reports from other users in this forum and in Reddit but with no definitive resolution other than rolling back to previous versions.
I have no experience reading the logs. I just downloaded them through the help section in the Plex web app. Can you please advise which file should I look into?


#17

Plex Media Server log is where to start. Look for anything dealing with the show you are recording. You should be able to see when it starts, then as it is recording Plex will report that it is 1% completed, 2% completed, all the way up to 100% completed. When done recording look for any clues as to if Garbage Collection is running against the show and deleting episodes.


#18

@johnm_ColaSC I was trying to check logs from yesterday but all Plex Media Server log files (1 through 5) had only entries with today’s date. Is there a way to access old logs?
So I decided to schedule a new recording around 15 min ahead of the airing time of a ramdom show and set it to keep all episodes (airing time: 12-12:30pm, name: “Enfoque”).

Since this was a new show never recorded before it did not show up in my DVR library section ahead of the recording, not sure if that’s normal behavior.
Then after the show ended there was no folder created for the show since it did not complete the recording.
Using TextWrangler I filtered the lines from the log with the show name (see attached)

The only thing that caught my attention was the following entry that repeats 4 times:

DEBUG - DVR:Subscription: Failed to resolve subscription for ‘guid: com.gracenote.onconnect://show/378222 thumb: http://tmsimg.plex.tv/assets/p378222_b_v8_ac.jpg title: Enfoque type: show year: 2002’ to library item


#19

No way to access old logs, unless you are backing up the log directory several times a day. The logs are cycled through, when the “Plex Media Server.log” fills up:
“Plex Media Server.5.log” is deleted,
“Plex Media Server.4.log” is changed to “Plex Media Server.5.log”,
“Plex Media Server.3.log” is changed to “Plex Media Server.4.log”,
“Plex Media Server.2.log” is changed to “Plex Media Server.3.log”,
“Plex Media Server.1.log” is changed to “Plex Media Server.2.log”,
“Plex Media Server.log” is changed to “Plex Media Server.1.log”,
and a new “Plex Media Server.log” file is started.

There are actually 6 log files being used, the 1-5 you mentioned and one without a number.

Would probably be helpful to see a full set of logs. You can download all the logs as a zip file by going to Settings/Server/Help and clicking the Download Logs link. Please ensure that Debug logging is turned on, verbose is turned off, and the Allow Plex Media Server tokens in logs is also turned off.


#20

@johnm_ColaSC Thanks! Attaching logs.