Plex on Popcorn Hour A410 Won't Find Media Server



After falling in love with the Plex Media server I went out and replaced my old WD Media hub with a Popcorn hour A410 so I can run Plex Media on it. However I have been unable to get the app to work, the error I get is that it cannot find the media server please check the ip and port. Im positive I have found the media server IP address on my Mac (the address that shows up at the top of the webpage when I start Plex) and I have checked the default port. Has anyone been successful on getting the Plex App to work on the Popcorn Hour A410? If so what might I be doing wrong 


Hi mdawe, do you mean in the address bar of your browser? In case yes, is it In case yes, that's your internal ip address:

To find your external ip address, please go to your "System Preferences" > "Network". Depending on how your Mac is connected, select WLAN or Ethernet on the left side and find your actual ip address below the "Status: Connected" information. Alternatively, you could open a "Terminal" window and enter:

ifconfig | grep "inet " | grep -v

I don't have a Popcorn Hour device, but if you have to enter the ip address manually and there is no automatic detection, you should make sure, your Mac has a static ip address. Otherwise you have to reenter the ip address in your Popcorn Hour every time your Mac gets a new ip address from your router.

Best regards.


I use the plex app on my a400. It works fine just make sure you are entering the right ip address. 

If plex is running on your mac the default address at the top is which is not the IP you want the IP of the machine itself most likely starts with 192.168.x.x or 10.10.x.x


Working fine with my A210. The IP you must enter is the IP of the machine wher Plex is running....not that is a localhost IP.

Sent from my iPad using Tapatalk


Thanks guys that worked!


I have THE SAME Problem..

I put the my IP Macbook but Poppy A200 say: Cannot connect to Media Server

can i have Help?



hallo everyone
I'm having the same problem as the "mdawe": I have two plex servers running, each with a different account: one server is running on my desktop pc, the other one on my wd mycloud nas.
Last week I replaced my old popcorn a-200 with a a-400 and was delighted to find plex on it. I entered the ip adress of my desktop, but it got refused with: "It cannot find the media server please check the ip and port." In a second attempt I tried to connect to my WD Nas, but again couldn't get into it.
I can see both of them running on my Ipad; ips are correct, port number the default one, which is fine when logging into with the Ipad, Macbook or Samsung Smart TV.
Any help would really be appreciated.