PMS on NAS to ATV3 via Airplay downmixes all 5.1 audio to stereo




I posted something similar in the IOS forum but this is probably a better place to ask for help.

I have PMS installed on a NAS - a WD PR2100. I have an ATV3 and i use it to play PMS movies via airplay, using the IOS app on my iPhone.

In the original release (that came with my NAS), PMS would always down mixed 5.1 audio to stereo. I upgraded to a later release, and it worked! In all supplemental releases however, it is back to transcoding 5.1 audio to stereo again. This happens regardless of the source format - DD, DTS or AAC, it simply won't output 5.1 audio.

I've tried reverting to the release where it worked, but the issue remains. I suspect a later release edited the config files on my NAS to dictate that airplay or ATV3 should have audio down mixed to stereo, and it's somehow not being updated or reverted when i install another release.

So my question is - does anyone have a fix for this?

Follow up question
i have a feeling i may be able to edit the config files if i can gain access to the root files on my NAS via SSH - applying a fix similar to this: however i've not done this before.

any thoughts?


PlexConnect and airplay are two different things. PlexConnect supports AC3 and AAC, but not DTS (because the ATV3 does not support DTS). DTS will be transcoded to AC3 by PMS. To install PlexConnect you need a device where you can run Python 2.7.x (unlike other media players, where you can install Plex or DLNA clients, PlexConnect cannot be installed in the ATV3 and requires a separate device, often the same one where PMS is installed).

PlexConnect does not announces itself as a player, but can coexist with airplay. When airplay is used PlexConnect is inactive on that ATV.

iOS supports AC3 in recent iDevices only. I don't know if you can airplay to ATV3 preserving AC3 (I have iOS on a iPad4 that does not support AC3, so I cannot test).


i'm happy for transcoding of audio to happen (e.g. AC3 to AAC, or DTS to AC3 or whatever), i just want the 5.1 channels to be preserved rather than downmixed to stereo.

i appreciate plexconnect is unlikely to be the way forward, i'm just looking for a fix for my issue and given that this forum seems to be the closest setup to mine (i.e use of ATV3) i figured it best to post here. Obviously i am using airplay which is different but presumably media support of the ATV3 is the same?


Airplay is a transmission protocol, when you use it you need to have both devices active (iPhone and ATV3) during the whole playback. It completely bypasses PlexConnect. If you insist on using airplay then this sub-forum is not the place to obtain help. When Apple created airplay it only supported stereo, later on it was "upgraded" to support video (and probably AC3 but I'm not sure).

Plex developed something called "Plex Companion" that would avoid both devices being active during play (device1 can tell PMS that the playing device is device2 and then disconnect). But PlexConnect does not supports "Plex Companion", therefore it is not advertised as a Plex player and you cannot "cast" from another device. And PMS does not supports airplay (would be an alternative to "Plex Companion"), there are some media servers (such as Synology DS Video) where clients can tell the server "please airplay directly to the ATV".

I think that your best option is to install PlexConnect. Shoudn't be a problem if you have python 2.7.x in your NAS. The only "problem" would be to autostart PlexConnect when the NAS is rebooted, every NAS has its own way of autostarting services and I do not recall if any other WD user has done it (I don't have a WD NAS).


ok thanks. not convinced i have the ability to install plexconnect, but may give it a go. I appreciate that airplay and plexconnect are different, just finding it frustrating that surround sound output used to work via airplay and now it's being down mixed to stereo. something has happened in plex configs for ATV3 or airplay, just not sure what!


Your problem has been reported by other users (see this), I'm not aware of any solution for it besides installing PlexConnect.


For anyone interested, this issue appears to have been resolved!

WD offered an upgrade download for Plex to version, which appears to have resolved the issue. I've not tried any later versions, but as this now works for me I've no reason to upgrade ,so won't be trying to unless a killer feature gets rolled out in a future release.

Happy days!