Problem with Plex Posters on Series

server-synology

#1

Hi,

Setup is a Synology 1511+
Plex Server 3.47.1
Media consists of Films, Music & TV Series
No optional plugins

Movies have the correct posters, metadata etc - so all good there

Music needs tidying up - but posters are there. The tidying up bit is my fault and is a WIP

TV Series - there are no posters on any of them, no metadata, nothing and I can’t see anything wrong.
Show and Seasons & episodes are showing up as blank
Agents: Shows:
Personal Media - Personal Media and Local Media Assets (TV) ticked
TheTVDB - Fanart.tv, the TVDB, The Movie Database, Local Media Assets (TV), Plex Theme Music - all ticked and in that order. API set in Fanart.tv
The Movie Database - The same as above

There are 5 different libraries with different show sets in them.
So in the mediafolder Media/Series/“Library” (e.g. Kids)/name.of.show/Season nn/episode(number-show-episodename).mkv or .mp4

When I click on help download logs I get an page not found error - so I assume I just copy the logs from ./Plex Media Server/Logs

I set up a PMS on a workstation - and that does download metadata and posters. I have tried comparing the setups and can’t find a difference

I have looked at the logs - but nothing jumps out at me although there are a number of errors. I could switch to the separate workstation as a permanent solution - but as I don’t need transcoding things seem quicker on the NAS as it has direct access to the media rather than across the network. Can someone with a lot more knowledge than me (not hard) have a look at the attached logs and point out the probably schoolboy error please?

Thanks



#2

We fixed series posters late yesterday. It should be released today


#3

Is this a problem specific to the Synology build as its strange it works mostly with a windows build but not the synology.
I assume I will have to do an update via git, probably tomorrow


#4

I have been struggling with this on QNAP for about a week now.


#5

for those with a plex pass there is a new PMS available with the fix. It’s on the downloads page


#6

We resolved it last night. Engineering was able to incorporate with today’s release


#7

OK - I am now running 1.13.2.5142-3ba6662e9
I have a partial improvement - but still no posters on TV Series. Movies and music I have posters, but not TV Series
If I hit refresh metadata on a library it goes through a scanning process and seems to end with a spinning wheel in the season but no poster. The improvement is that individual episodes now have posters - but not the overall series. Also no text metadata.


#8

@NugentS

Did you “Refresh All Metadata” in your TV series ?


#9

Yes.

I am currently exploring the “Plex Dance” as a possible solution. But this is going to take quite some time
:frowning:


#10

I have deleted every library
Cleaned and emptied the trash
Created a new (set of) Libraries
I am now checking the series names against TVDB manually and putting each series back in one by one. The episode names and season numbers were Plex compliant. But the Series names - not so much (in some cases but not all)

This seem to work - so far


#11

This is going to play merry hell with my backups…


#12

You have two choices:

  1. It works
  2. It plays hell with that first backup after the data is all updated

Please choose one.

:smiley:

(I know, it sucks, but the root cause was found and the new TheTVDB API is fixed. As long as they don’t update it again, we’re golden)


#13

How long should this take - the identifying of the series and downloading of metadata and posters.
I added 14 Series this morning. So far 2 have been identified with the other 13 spinning their wheels and 1 doing nothing so far.

What I have done is split the series into multiple folders and am then adding one by one (as one finishes) another folder into the library. That way I limited what I assume is a vast number of simultaneous requests and can easily monitor how things are going visually.


#14

@NugentS said:
How long should this take - the identifying of the series and downloading of metadata and posters.
I added 14 Series this morning. So far 2 have been identified with the other 13 spinning their wheels and 1 doing nothing so far.

What I have done is split the series into multiple folders and am then adding one by one (as one finishes) another folder into the library. That way I limited what I assume is a vast number of simultaneous requests and can easily monitor how things are going visually.

With 1.13.2.4152 in place, clicking “Refresh All Metadata” should effect an immediate scan and completion of all missing metadata.
Anything newly added will be added fresh.

There is a different underlying problem here.

Please cancel the can, Empty trash, clean bundles, and scan one more time. If this doesn’t resolve it, attach the ZIP file of the logs


#15

As requested
I restarted plex, empty trash and clean bundles - this set of shows is now turning up
I have also started a second plex server with rather more CPU etc to see if that makes any difference. They both refer to the same media store but I figure with more CPU and memory it can’t harm. Its just not the way I want it to run. Its also confusing that the announcements (butler) on one plex instance shows all the other instances actions.


#16

Aside from a bit of a DNS timeout issue and it cleaning up from the previous lack of images, your logs are clean.

2018-06-09 19:56:23,722 (7f86e1153700) :  DEBUG (networking:166) - Requesting 'https://tvdb2.plex.tv/login'
2018-06-09 19:56:24,142 (7f86e231d700) :  DEBUG (networking:166) - Requesting 'https://tvdb2.plex.tv/series/196921?lang=en'
2018-06-09 19:56:24,630 (7f86e1c01700) :  DEBUG (networking:166) - Requesting 'https://tvdb2.plex.tv/series/295647?lang=en'
2018-06-09 19:56:25,528 (7f86e231d700) :  DEBUG (networking:166) - Requesting 'http://127.0.0.1:32400/services/tmdb?uri=%2Ffind%2F196921%3Fexternal_source%3Dtvdb_id'
2018-06-09 19:56:25,732 (7f86e1153700) :  INFO (__init__:140) - JWT Error: (<urlopen error [Errno -3] Temporary failure in name resolution>) - 
2018-06-09 19:56:25,750 (7f86e1153700) :  DEBUG (networking:166) - Requesting 'https://tvdb2.plex.tv/series/164981?lang=en'
2018-06-09 19:56:26,127 (7f86e1153700) :  DEBUG (networking:166) - Requesting 'http://127.0.0.1:32400/services/tmdb?uri=%2Ffind%2F164981%3Fexternal_source%3Dtvdb_id'

Here you see it fail momentarily then retry and continue without incident.

I had requested you Cancel the Scan, Empty Trash, and Clean Bundles. You stated you “restarted, Empty, Clean bundles” which isn’t the same. I wanted the ‘Cancel’ state in the DB.

Either way, this system, after completing the current metadata retrieval in full: Scan, Empty, Clean one more time. Then one more “Refresh all metadata”. All those items with full metadata will simply refresh the poster locally. Those with it missing (if any) will retrieve it.

It’s perfectly ok for multiple servers to read the same media source.

As for the notification system, there is nothing I can do about that


#17

@NugentS said:
How long should this take - the identifying of the series and downloading of metadata and posters.
I added 14 Series this morning. So far 2 have been identified with the other 13 spinning their wheels and 1 doing nothing so far.

What I have done is split the series into multiple folders and am then adding one by one (as one finishes) another folder into the library. That way I limited what I assume is a vast number of simultaneous requests and can easily monitor how things are going visually.

TV Shows must be named according to the Plex guidelines. They will fail to match otherwise.

For TV Show files the template is this: TV Show Title - S01E01 - Episode Title.ext

TV Show Title = The name of the TV Show you have.
S01 = The Season number
E01 = The Episode number
Episode Title = Is the name of the episode. This is optional, but recommended.
.ext = is the file type, .mp4, .mkv etc…

All TV Show files MUST contain the season and episode numbers in the format shown.

TV Show files should be stored in a TV Show Title folder and the episodes should then be placed in Season folders.

For example:

Media
…|_ TV Shows
…|_ Game Of Thrones
…|_ Season 01
…|_ Game Of Thrones - S01E01 - Winter Is Coming.mp4

Go to the TVDB.com if you need to find any of the above information for your files.


#18

How important is the name of the Show folder?
In the example above - the Game of Thrones Folder
All the Seasons are correct as are the filenames of the episodes (thanks to Sonarr) but the Show folder may be a hang over from the past


#19

It is just as important as the file names. If it is incorrect then your series will not match. The easiest way to check is to go to the TVDB and search for the series you are adding. If for example it was listed as GOT then that would the name to use.

As I have shown above, though, is the correct series name for Game Of Thrones.