PS4 Pro Buffering for 1080p Plex Content; Base PS4 is Fine

playstation

#1

Hi all.

I have two PS4's in my house: a base model and a Pro.

The base PS4 is connected to the router via WiFi.
The PS4 Pro is connected to the same router via ethernet.

I can stream 1080p Plex content to my base PS4 just fine, but literally any quality of 1080p Plex streaming to the Pro stops to buffer every 5-10 seconds; it's unwatchable.

I can stream 1080p & 4k YouTube & Netflix stuff to my Pro without issue.

I did a test recently where I had my Pro and base PS4 stream the exact same quality 1080p file from my Plex server; base model was totally fine, but the Pro buffered every couple/few seconds.

I can rule out the Plex server because it's a beast, but also because the base PS4 has no trouble streaming from it.
I can rule out the Pro itself because it streams 1080p and 4k content just fine from other apps.
I can rule out the network connection because my base PS4 is only pulling ~30Mbps over WiFi and my Pro can use our full 150Mbps pipe via ethernet (I've done speed tests).

So yeah... that's my issue. Is anyone else seeing this? Is there anything else you can think of which can be tested? The only other thing I can think of is to maybe try connecting to the web player on my Pro and, if it even works, see how that goes. If the web player is fine, then I'll at least know it's the Plex app itself. In fact... I'm going to go test that and then update. ;]

Edit:
Okay, yeah, this seems specific to the Plex app on my Pro. I loaded a 1080p video through the web player on my Pro and I had absolutely no buffering. The playback itself wasn't quite as smooth (likely due to the generic browser) but there was absolutely no buffering. I let a video play for 15 minutes without issue. Loaded the same video (same playback and quality settings) through the native Plex app and it started buffering almost immediately. Oh, and before anyone asks, I've tried re-installing the app before. No difference.

Any help would be much appreciated.

Cheers,
- Tristan -


#2

I seem to be having the same issue since upgrading Plex Media Server to version 1.9.6.4429. Streams fine over WiFi to a web browser on all of my devices, but constantly buffering everying 3 - 5 seconds. Worked fine until the update.

Have you found a resolution to your issue?


#3

No resolution. I’ve tried to rule out absolutely everything I can and nothing seems to matter. It’s specifically an issue on my Pro; doesn’t matter if I’m wired or wireless, my Pro will not stream any quality of 1080p via Plex without buffering every few seconds. My base model PS4 is fine streaming over WiFi from the same Plex server. My Pro can stream up to 4k on anything else just fine.

Is there actual Plex support? I haven’t found anything other than forums, which is a bit ■■■■■■ when you’re actually paying for Plex Pass.


#4

Same here. Before the update PS4 played without problems the very same files that now constantly buffers every 5 seconds of so…


#5

I really wish someone from Plex would chime in here. It’s absolutely crazy to me that I have to output and watch Plex content at 720p on a 4k tv, but can output and watch the exact same content in 1080p on a 1080p tv just fine. Don’t even get me started on the months-old audio issue on the PS4 Pro that has a multiple-page thread on these forums already…


#6

well, the “white line on right screen” hasn’t even been fixed for PS4 and the bug was reported several times and is known since 2015. :frowning:
I wouldn’t get my hopes up for the ps4 version since it does not even support h.265 (yes, sony might be the culprit here).
I bought fire TV sticks for that reason.


#7

Same problem here from PS4 pro owner. Wifi that handles approx 50 mbit down, but cannot even play 8 mbit transcodes now. Interesting you could test with old PS4 and determine its a problem with the pro. Plex is unusable for me now. :frowning:


#8

Yeah, it’s crazy frustrating. I ruled out the Plex server as well, just for ■■■■■ and giggles. I moved my entire library and server to a Linux machine in my house and it’s exactly the same:

  • Streaming 1080p Plex media to the base PS4 is fine
  • Streaming 1080p Plex media to the PS4 Pro buffers every few seconds
  • It’s a different ethernet run to the router, so we can definitely rule the previous ethernet cable out

It’s ridiculous that I’m forced to watch Plex media in 720p on a 4k TV because of this. =/


#9

Anyone ever figure this out?

I can’t stream over 4mb/720p or so on my PS4 Pro over 100+mb internet connections while the server is on a gigabit connection. I know it’s not the internet, because my phone will stream original 10+mb files fine on the same connection as my PS4 Pro.

This is very annoying and no way I’d pay for Plex pass if this lackluster support on PS4 is all they’re offering. From what I see of the update history, the PS4 app has only received one update to 1.02.


#10

Sadly, no.

I was never able to get Plex streaming at 1080p or 4k on my PS4 Pro. It would always stop to buffer within seconds. I even rebuilt another PC of mine, threw a fresh Linux install on there, moved Plex to it and tried again so as to rule out my Win10 machine; no dice. Same issue. As with the Win10 machine, I can stream 1080p to my base PS4 just fine.

My tv has Chromecast built in, so I’ve just started casting directly to my tv. It’s hilarious/annoying that I can stream 4k wirelessly to my tv without issue, but couldn’t stream 1080p wired to my PS4 Pro.

I have an unexpected thing I can try testing next week or the week after (don’t have access to my Pro at the moment) and if I have time I’ll post back here with any findings.

Cheers,
- Tristan -


#11

I’m not sure if the problem is with the Plex App on the PS4, or a limitation of the PS4 itself. I can stream content to my PC just fine but video stutters if I try to play anything above 720p on the PS4 using Plex.

Also considering the Plex app on the PS4 does not have feature parity I was wondering if I should just abandon using the PS4 as a client altogether and maybe going with an Nvidia Shield or even just connecting an HTPC directly to the TV and do local playback instead.


#12

I can definitely stream 1080p to my base PS4. The Pro is more powerful, which is why it’s crazy that I can’t stream 1080p to my Pro.

Not sure why you wouldn’t be able to get 1080p on your base model, though. Is Richard Ayoade unnecessarily converting your stream?

I’d say check settings on your server and PS4 app to see if there’s anything going on.

Can you stream 1080p to other devices on your network from your Plex server?


#13

Same issue here with my PS4 pro. Ditched and old HTC because I thought that the Pro ist more powerful in any way but this is ridiculous :frowning: