Remote Access shows green then turns red

server-windows

#1

I moved to a new address and in the process we had to switch ISP and buy a new wireless router. Now my plex server will not allow remote access at all. I have gone thru all the trouble shooting documents and read everything I can on the forums and nothing will work.

I will get the green check mark for about 2 seconds then it turns red and tells me "Not available outside your network" below are all the details for my setup and my trouble shooting steps.

ISP: Charter/SPectrum
router: Netgear Nighthawk R7900P (firmware version: V1.2.1.6_1.1.86)
Plex Server: Windows 10 Pro/ Version 1709

Troubleshooting steps:
- turned UPnP on and off
- setup manual port forwarding to 32400 in the router, windows firewall
- tried using static IP address
- tried using IP reservation with my router
- checked and unchecked "manually specify public port"
- used open port check tool "canyouseeme.org" but was not able to get a open port

I have tried everything I can think of and everything the trouble shooting documents and forums say to check. can someone please help me. let me know if you need any screen shots or more detailed info. thank you


#2

Let’s do a little troubleshooting. First, open a web browser and go to http://whatsmyip.org. Write down the address. Next, go to your router’s settings page and find the WAN IP address. Write down that address.

Are those two addresses the same? If not, then you have a double NAT situation which is what is stopping you from having remote access.


#3

I have down the above and I get the same ip address in both places, I went thru these steps to confirm that I do not have a double NAT. what should I do next?


#4

Here’s what I always do for remote access. See if it helps you.

For manual port forwards, I recommend this procedure:
Set up a static IP for your Plex server.
Go into your router and create a manual port forward rule for port 47222 (just an example but don’t use 32400), for protocol TCP, that points to your Plex server’s IP and port 32400.
Save that and power cycle your router.
Go into the Plex server remote access settings, tick the box next to manual port, enter 47222, click apply, then disable remote access, shut down and restart the Plex server application, and enable remote access.
Go to http://www.canyouseeme.org and test port 47222.
Go to http://www.whatsmyip.org and compare that IP address with what your router WAN IP is and what Plex reports as your public IP.


#5

To add…

Many (most?) routers will be listed here - for step by step port forwarding instructions:
https://portforward.com/

No exact match, but one of these is probably close enough:
https://portforward.com/netgear/


#6

to kegobeer-plex

I tried all your steps and it will stay green for almost 10 seconds now but then it just goes back to Red after that. I am losing my mind, can someone please help me!!!


#7

Please list in detail how you have your network configured. For example:

Arris Surfboard SB6190 modem -> pfSense router -> Netgear ProSafe 24 port switch -> PC running Plex Server


#8

to Kegobeer-plex;

here is my setup for the pc that runs plex

Modem: Arris Surfboard SB6190
Router: Netgear Nighthawk X6S AC3000 Model: R7900P

my pc is hardwired to the Nighthawk.


#9

Ok, even though it shows red, can you see the open port when you go to canyouseeme.org?


#10

i am in China and I experienced the same situation. I think the situation started since plex allow google and facebook accounts logon, and China GOV banned acccess to both sites. I am not sure if there is some code in the auth website, but as I can see, the public ip showed in plex web is the VPN server address I use for accessing google and facebook although I log on with email account.


#11

I have the same symptoms and would also love a solution/resolution. Here is my set-up:

ISP: CenuryLink
Modem: Technicolor C2100T
WiFi: Eero mesh network
Switch: Netgear GS605 v2
Server: HP Z220 workstation

I have tried hardwiring the workstation to both the modem and switch and setting up port forwarding from either the modem or Eero or both and unable to reach the 32400 port through http://www.canyouseeme.org from any of these configurations.


#12

Honestly, I’m in the same boat here and I’m pulling my hair out.

I have almost the same system set-up as OP, I believe:

Modem: Arris Surfboard SB6190
Router: Nighthawk X4 R7500v2

Time Warner Cable (Now Spectrum) in to Modem in to Router with a cable to PC.

I’ve tried:

  • Setting up static IP on machine
  • Cycling Plex, Router, Modem, uPnP (in almost all variations)
  • Using a new static IP on the machine versus the old one
  • Manual port forwarding
  • Uninstalling AVG to remove AVG firewall

When I use canyouseeme.org it shows that it can not see the open port, and Double NAT tests suggest a Double NAT issue, BUT – the Arris Surfboard SB6190 does not appear to have an option to switch to Bridge functionality, based on the admin there. I attempted to set the router to Bridge, but that just killed my entire home network – so I don’t think that’s an option.

I’m afraid it’s a modem issue, but I’m not sure what else to try. Maybe an upgrade is needed (though that’s a shame, as the was the SweetHome recommended modem as recently as like this summer). I’m running Windows Defender w/ Firewall, but Plex is set to allow on both public and private.


#13

What seems to have worked for me… well at least for about 18 hours now… I’m using FIOS Verizon Gateway router… go into advanced, then universal plug n play, uncheck “Enable Automatic Cleanup of Old Unused UPnP Services”.

I now see the opposite but a better problem… when I log into plex to check the remote server it shows ‘red’ for about 1 second then a switch over to ‘green’. Fingers crossed this will solve the problem going forward… No port forwarding here, just normal FIOS setup basically.


#14

Same issue here - green success checkmark for just a second followed by red.

I have attempted to set up port forwarding on my CenturyLink ISP-supplied DSL Actiontec C1000A modem/router which is poorly documented and seems flaky to boot. I had pretty much eschewed the use of UPnP on this router (though I did try it unsuccessfully) and went straight to port forwarding.

Certain combinations of port forwarding rules and firewall settings - for just the Plex port ranges - seem to nuke all of my internet connectivity. I suspect that this box was not really intended or was tested to have all these router parameters adjusted from their default settings.

One interesting datapoint was that when I looked at my router logs I saw what I assumed was Plex activity on my server (a Synology NAS) on port 32415. Should we really be opening up a RANGE of ports for Plex beginning at 32400?


#15

I should also mention that at the same time that my server is showing the Red status on lack of connectivity to Plex, an open port test to my IP at http://canyouseeme.org shows that port 32400 is open. Mysterious-er and mysterious-er…


#16

If your server is running on Windows 10 try this:

“Win key + R” to open the Run box. Run “wf.msc” (either by doing a WinKey+R or searching for it). Make 2 New Rules: a.) Type is ‘Port’, b.) TCP with Specified local ports: 32400, and c.) “Allow the connection”. The second time through make the rule UDP instead of TCP.

I found this fix courtesy of a different thread here, but I was starting to suspect my ISP - canyouseeme.org could connect, the initial test was green but then immediately went red - the weird part was that Windows 10 wasn’t even showing these as blocked when I turned on logging.


#17

@ThreeWolfMoon said:
If your server is running on Windows 10 try this: …
I found this fix courtesy of a different thread here, but I was starting to suspect my ISP - canyouseeme.org could connect, the initial test was green but then immediately went red - the weird part was that Windows 10 wasn’t even showing these as blocked when I turned on logging.

Can you link that other thread here so we can follow that discussion as well?


#18

Same issues, super annoying…thanks for the advice will try the steps when I get home today - my IT department co-worker and I have been puzzling over this for days now! Funny thing is when I got home, I can reboot my router and then it goes green for a while, but then right back to red by the next day. Hoping it is just some setting issue and nothing more…


#19

I was having he same issue on one of my Plex servers. It was configured the same as the others and they were all visible from the Internet.
I’m using a Peplink One router with 2 WAN links active. This was a recent change to the router configuration. Previously the second link was used as a hot-backup. When I reverted the second link to act as a backup the remote access on the server immediately became green and has stayed that way for several hours.


#20

@ThreeWolfMoon said:
If your server is running on Windows 10 try this:

“Win key + R” to open the Run box. Run “wf.msc” (either by doing a WinKey+R or searching for it). Make 2 New Rules: a.) Type is ‘Port’, b.) TCP with Specified local ports: 32400, and c.) “Allow the connection”. The second time through make the rule UDP instead of TCP.

I found this fix courtesy of a different thread here, but I was starting to suspect my ISP - canyouseeme.org could connect, the initial test was green but then immediately went red - the weird part was that Windows 10 wasn’t even showing these as blocked when I turned on logging.

Thanks @ThreeWolfMoon , this solution fixed the problem for me. Brilliant!