Server doesn't show in drop down



My Plex server doesn’t show up as an option in the drop down (in the upper left corner).

  • The server is definitely running, I get notifications when DVR records and I can see things in the logs
  • It doesn’t show even if I connect with a local IP address (as opposed to

It seems to have happened when I plugged in an old Rasp Pi that had an old version of Plex Media Server on it that started on startup. The issue definitely seems to be something about what plex stores in the cloud as part of the configuration and not the local install because nothing changed on the local install and more over the local install (other than not being accessible via the web) seems to be working as expected.

Does anyone have any suggestions or investigating steps? Thanks for the help!

Here’s a screenshot, you can see I’m connected locally, wall-e is the rasp pi server that I have shut off, my Plex Cloud account is available, but my local raspberry pi isn’t showing in the list at all.


If you have two servers with the same name and/or on the same IP address, chaos will ensue.


Sorry I should have specified. The two local servers are on different machines on different IP addresses. One is at .43 (Wall-e) the other is .5 (Jetfire)

I hadn't run the pi in... months? a year? I just happened to plug it back in today.


Let's ask @uglymagoo to take over since he is the user who's graciously repackaged for Pi machines and supports them


I think I've misspoken something somewhere. The Pi server is turned off (now) and not the problem. The issue seemingly arose when I turned that server on.

The issue is the other server running on linux (Jetfire) with the latest version isn't showing in the drop down.


I restarted the plex service (service plexmediaserver restart) and that brought it back in the menu.

Thanks @ChuckPA for responding . Sorry I didn't try restarting earlier but I knew shows were recording and didn't want to interrupt them...


Is everything in order now?