Small percentage of files will not pull IMDb metadata

server-windows

#1

I created a brand new Movies library, with the "Plex Movie" agent, and set it to pull all metadata from IMDb (cast list, ratings, plot summary). This worked fine, but I've found that a few of my movies do not retrieve IMDb metadata. When I noticed this on one movie, I wrote a small program to scan the metadata xml files to see if there were other files failing to pull IMDb data.

Here is the full list:
* Lights Out
* Kubo and the Two Strings
* Ouija: Origin of Evil
* Suicide Squad

Interestingly, I found that another user had the same issue with Suicide Squad (http://forums.plex.tv/discussion/comment/1354255/), so it seems likely that the issue is not with my server setup.

Does anyone know what I can do to figure out what's going on here? I will be happy to post logs if someone can point me to the relevant log files.


#2

Someone will ask for your logs.. and maybe the same person, or some else, will ask for the movie file names and structure, to see that you have followed the correct format. You will also want to post the version number of PMS that you are using.

If your file structure is correct according the the Plex rules, your log files may show an issue.


#3

Let me know if there is anything else I can provide. Thanks!


#4

As a test, I just copied a random .avi file to a new location, and renamed it so Plex would think it was "The Beach" (In the thread I linked in the OP, the user had an issue with that movie). I made a new library, and this movie also failed to pull IMDb metadata. So it definitely seems to be related to the particular movies, and unrelated to my server setup.

Does anyone know how to look into this further? Did I provide the appropriate logs in my previous post?


#5

I am experiencing the same behavior. Suicide Squad will NOT pull in IMDB ratings for me, and it is driving me nuts. A small percentage of my movies just will not pull in IMDB ratings. :(


#6

Same problem with Suicide Squad. Not being able to manually add movies and not having a built-in way to check for unmatched media is a bit poor. Luckily, there are 3rd party tools - but the product should allow for some manual intervention since this certainly isn't the first or last time we'll have issues.


#7

Making Plex Movie the default agent is going to be a rather sure way to create disappointment in your life.

The Movie Database is where it all happens and is a lot more reliable.
It's a good idea however to Move Plex Movie to the top of it's Agent Listing, Move The Movie Database Agent to the top of it's Agent listing here:
https://support.plex.tv/hc/en-us/articles/200241558-Agents
I guess the idea is that if the movie doesn't exist in one database it will in another, but the inner workings of the mysterious Plex Movie Agent are indeed a mystery that only Plex can solve - but they're not talking.
It's also a GREAT IDEA to move Local Media Assets to the bottom of all your Agent lists, just in case you ever want to use an MP4/M4V file.

Other unpredictable things can then be avoided - like this one:
https://forums.plex.tv/discussion/262038/the-cast-is-not-loaded


#8

same problem here. Don’t know why some movies don’t show the imdb rating, and others yes. I have set up TMDB agent, with plex movie on top. And my media correctly named.
Is it IMDB database fault? TMDB database fault?

Same movies like Post #1. They must have something bad on the web databases.


#9

I am definitely having the same problem. Some movies absolutely refuse to get metadata from IMDB, including Suicide Squad and Kubo and the Two Strings mentioned here.
I believe someone from Plex team may look into the web databases of these movies to figure out what the problem is.
Also Silence and The Founder has the same issue.


#10

I too am having the same issue. I did a full refresh of all metadata and most of the 2600 movies pulled the IMDB rating correctly. Of the ones left most were able to be corrected using the fix match option. Some were a little more awkward and required me to unmatch the movie, delete the plug-in support cache and then re-match.

These are the ones left over that will not pull the IMDB rating at all regardless of what I do...

The Founder - tt4276820
Ouija: Origin of Evil - tt4361050
Silence - tt0490215
Suicide Squad - tt1386697
Lights Out - tt4786282
Bridget Jones's Baby - tt1473832
Bad Asses on the Bayou - tt3525346
USS Indianapolis: Men of Courage - tt2032572
The Space Between Us - tt3922818
Spy Hard - tt0117723
Peter & Wendy - tt4051850
Slash - tt4729990
Sand Castle - tt2582576
The Little Rascals - tt0110366
The Tourist - tt1243957
Untraceable - tt0880578
Churchill's Secret - tt4711762
Planes: Fire & Rescue - tt2980706
Saw V - tt1132626
A Cure for Wellness - tt4731136
Dragnet - tt0092925
Herbie Rides Again - tt0071607
Keeping Up with the Joneses - tt2387499
A Hologram for the King - tt2980210
Man of the Year - tt0483726
Stalingrad - tt1966566
The Do-Over - tt4769836
Carry On at Your Convenience - tt0066895


#11

Yeah, did the same. Those last movies are the issue we're talking about and
what needs to be investigated. Thanks for clearing it up.


#12

@chriskeens said:
Dredd - tt1343727

Dredd works fine for me, but I can confirm the issue for the other 6-7 movies on your list that I have.


#13

@crafty35a said:

@chriskeens said:
Dredd - tt1343727

Dredd works fine for me, but I can confirm the issue for the other 6-7 movies on your list that I have.

you are right. Dredd does indeed work, my mistake


#14

Hey - unfortunately this appears to have been a transient issue on the cloud side :/

I have refreshed all the movies in this thread so those should all be fixed. Thanks a bunch for the lists of movies and please feel free to post more (preferably with the IMDb IDs) if you find them.

If you have any other questions, I'll be watching this thread.


#15

Thank you! The movies in question do appear to be fixed on my end after a metadata refresh. I will be sure to let you know if I find others.


#16

Yay, thanks for fixing it. Nearly all fixed refreshing metadata but I have 3 movies left (from 2700). Can you check them @maxflix ?

(tt2125435) Beasts of the Southern Wild
(tt5513260) Surf's Up 2: WaveMania
(tt4669986) Loving


#17

Thanks...

I am still having issues with these ones though:

Peter & Wendy - tt4051850
Churchill's Secret - tt4711762
Carry On at Your Convenience - tt0066895
Inconceivable - tt3481634

These have previously worked but now don't seem to want to...

The Siege of Jadotville - tt3922798
And Now for Something Completely Different - tt0066765
The Omen - tt0075005
Mike Bassett: England Manager - tt0282744
United - tt1777034
Carry On Teacher - tt0052676
Gregory's Girl - tt0082477
Human Traffic - tt0188674
Bobby - tt4606514
Carry On... Up the Khyber - tt0062782
I.D. - tt0113375
The Belles of St. Trinian's - tt0046766
The Hot Potato - tt1641252
The Shipping News - tt0120824
Taxi - tt0152930
Taxi 2 - tt0183869
White Fang - tt0103247
Summer of Sam - tt0162677
The Intent - tt3842614
Instinct - tt0128278
The Wedding Video - tt2035670
Carry On Jack - tt0057919
Ordinary Decent Criminal - tt0160611
When Saturday Comes - tt0114917

*Edited to add more movies


#18

Hi,

Having issue with:

tt0109440
tt6464772
tt0084555
tt0075007
tt1934205
tt1601176
tt0217505
tt0283900
tt0120125
tt0328880
tt0076618
tt0453467
tt0371724
tt0095776
tt1872101
tt4669986
tt3859076
tt0105417
tt0381292
tt0292506
tt0187078
tt1349856
tt0173840
tt1473357
tt1345507
tt0214529
tt0100263
tt0364517


#19

Hi @F. Launay -

I checked the first few in your list and except for tt6464772 - I'm seeing IMDb ratings for all of them. If you are having trouble, please try clearing your HTTP cache and refreshing the metadata for those items.

For tt6464772 - we have a complicated deal with IMDb and are only allowed access to metadata for films that are specifically labeled as 'Movies' but this film is marked as a 'Video'. A silly distinction, I know, but unfortunately it's the rules by which we are bound.


#20

Everything seems to be working OK now and everything seems to have pulled correctly... apart from these...

Peter & Wendy - tt4051850 (TV Movie)
Churchill's Secret - tt4711762 (TV Movie)
Inconceivable - tt3481634
Wonder Woman - tt0451279
The Bad Batch - tt4334266

I'm assuming that the 'TV Movies' come under the same issue as the 'Videos'?