Stuttering Playback issue on PS4



Hi guys,

So I have never had any major issues with Plex, but recently I have been having an issue with the app on my PS4.

The problem is the playback starts pausing and shows the three dots (•••) on the screen and then it might start playing again, but then after just a few seconds of playback it stops again.

However watching on the Plex app on my iPhone using the same home network connecting to the same server on my MacBook - it plays perfectly.

Anyone have ay resolutions for this problem.



I haven't used Plex before it went for free, but I've been facing the same issue since I use it. For the first time when I was watching a 720p movie from a MacBook Pro mid 2012, there wasn't an issue for more than an hour, then a couple of times the movie stopped because of buffering (I guess). Since then these three dots come up randomly, which makes impossible to enjoy a movie.

Offtopic: in 2010 watching a movie streamed from an old (2005) HP laptop to an Xbox 360 in 720p quality was completely fluent. Today I cannot absolve it with a PS4 and a MacBook Pro.


I'm having the same issue. I get a lot of stuttering/buffering when playing a video from my Macbook to my PS4. I can easily play these same movies on my Apple TV 4th gen, my iPad, and my iPhone. Could the file format have anything to do with it? I wonder if the server is having to transcode for the PS4 and it can't keep up.


This precise situation happens on my PS4, too. I tried to play some PS4 game footage from my Raspberry Pi 2 and Plex for PS4 plays about four seconds until it pauses.

  • edit * Tried the troublesome file again yesterday. No stuttering.

  • edit * Tried the troublesome file again yesterday. No stuttering.

What kind of file? Can you please share your solution? Thanks in advance!


I wouldn't say it is a solution because the same file that caused problems the other day worked fine the next day.

It was just some PS4 game footage my son saved. He clicks the share button on the controller and the PS4 saves 15-minute snippets of video.
I copied the PS4 Game video footage to a USB stick. Then I edited and saved the footage as an mp4 file using iMovie 10.x on a mac pro.
One day the playback froze intermittently every time I tried it, and the next day the footage played back flawless.
IIRC it was MP4 level 3.1.

Attached file stats from media-info in the attachment below.
Attached expanded ffprobe output, too.



I'm facing a quite similar problem, so I was thinking of asking here for advice. The problem is when I play a video file (.mkv) on my PS4, it first shows the three dots (•••) on the screen and after that it starts playing video with major stuttering. The problem does not appear with all video files, which makes no sense. I'm trying to play files locally in same network and I'm using wired connection.

Solutions what I have tried so far:
- First I thought that file is corrupted --> Tried to play video on my computer --> Works perfectly with VLC and Plex Web Player.
- Tried same file with Universal Media Server --> Works perfectly with PS4 mediaplayer.
- I went through all available client settings on my PS4 Plex App (with/without direct play/stream etc.) --> Problem still there.
- The original bitstream of the video file is 2,2 Mbps, when I force it to play lower quality 2 Mbps, it plays fine but quality drops alot. Some other videos with much higher bitrate plays smoothly, so I assume it's not a network issue. Also I'm sure that my PC is capable to transcode the video file (Intel Core i5-4670k, 8,0GB RAM, ATI Radeon HD 6950 2GB).
- I also tried older version of Plex Media Server --> No difference.
- I also tried different PMS transcoding settings and there was no help for that.

I'm not an expert, but it seems to be some kind of transcoding or compatibility problem, because video runs fine when I put lower bitstream on my PS4 (and then my PMS should do transcoding, right?). So, what I'm missing or what could cause the problem?

Thanks in advance.


I solved it two ways. I got a faster computer for plex and I upgrade to an Eero WiFi network. So it was an easy but expensive fix.


That's not really a solution. I have the same problem with the PS4 plugged into a gigabit ethernet connection, whereas all of my other players (AppleTV, Roku 3, Roku streaming stick, Roku TV) do not have this problem at all. It seems to be a PS4 issue.