The server "X" does not have a valid connection for casting. Check that the server is claimed ...

server-windows

#1

Hello !

I am trying Plex to view on my chromecast movies and tv-shows. I installed it, I can watch movies on the Plex tab on chrome, and when I want to cast it, I have a message asking me if I want to continue payback on chromecast. I say yes, and... nothing happen.
When I try again, I receive this message :

"The server "X" does not have a valid connection for casting. Check that the server is claimed in server settings."

Where should I check if my server is claimed, and how can I fix this issue ?

Thanks a lot !

Hélianza


#2

Same problem here. Started after upgrading plexmediaserver from 1.7.5.4035-313f93718 to 1.8.4.4249-3497d6779. This is a Debian GNU/Linux 8.9 (jessie) and a Chromecast v1.
It only happens when casting from Google Chrome on Windows (10, 64-bit). IOS Plex client IOS (iPhone 5S) and Google Chrome on MacOS Sierra work.

Web client debug logs show a 'Bad Request' when attempting to cast any movie. The log is attached.


#3

I get -

"Playback Error
The server "X Plex" does not have a valid connection for casting. Check that the server is claimed in server settings"

Anyone any idea how to fix this so I can cast?


#4

Are you logged into your Plex account?


#5

I don't know for the others, but I was.


#6

Same problem here with OSX Sierra and Chromecast v1, server Version 1.9.1.4272.
I just restarted my chromecast and that fixed it.


#7

Hi, after update to the last Plex server version I have the same problem with windows 10 and chrome browser. Also from mobile does not connect any more.


#8

Problem remains with version 1.9.1.4272. How could we get attention from a developer or power user for this problem? I have even provided a log file clearly showing a bad request in Plex Web Player.


#9

same problem here.
windows 10
latest chrome and vivaldi browsers


#10

same issue here. latest plex + chrome on windows


#11

I ended up solving it by fiddling with some settings (Show Advanced button):

Settings/Web/General/Allow Fallback to Insecure Connections: changed from 'On same network as server' to 'Always'
Settings/Server/Network/Secure connections: changed from 'Preferred' to 'Disabled'
Settings/Server/Network/List of IP addresses and networks that are allowed without auth: just removed my local LAN and left this field blank
Settings/Server/Network/Enable HTTP Pipelining: unchecked it

After changing this and manually restarting Plex Media Server processes, by running 'systemctl restart plexmediaserver', the error went away.

BUT: after changing every setting back to their defaults, and restarting plexmediaserver, just to reproduce the problem and locate wich specific setting was the culprit, the error had not returned. 8-O

My guess is that something was changed in Plex Web Client Version 3.20.5 that messed with authentication. Even after logging off and on again with my Plex username the problem kept happening. But only with Chrome on Windows. Unfortunately I did not have the chance to find out specifically which setting "solved" it.

Things are still not 100%, as they were previously with version 1.7.*, every now and then I'm getting errors related to 'can't play this media' or something on Chromecast. Despite the errors, I have been successfully streaming movies to my Chromecast v1 from Windows.

I hope someone else could investigate this further.


#12

same problem, tried the steps from @rofz but didn’t help me.
been at it for 2 hours now -_-’


#13

@rofz tips worked for me. Thanks!


#14

Just chiming in since I’ve had the same issue. Signing out and back in again seems to have fixed it for me…


#15

changing the Settings/Server/Network/Secure connections: changed from ‘Preferred’ to ‘Required’ fixed the problem.
i use linux mint with chromium to cast to localhost (chromecast).


#16

Doesn’t work for me, rofz!!?? Anyway, thanks.


#17

Ended up doing things indicated by rofz. Worked fine with me.

thanks rofz.

I think that changing a network settings and saving the configuration then restarted Plex service.
then reverting back the setting to its initial state and saving again the configuration and restarting the plex service one more time. should do the business.


#18

I guess it’s my turn for this error. Has anyone found a solution?
I’ve tried rofz fix.
I’ve tried logging out and in again.
I’ve tried to release the server and claiming it again.
Nothing works.

Local play works fine, but Chromecast to my TV is not working.
OS: Windows 10 Home Version 1703
Plex: Version 1.10.1.4602


#19

So, I tried to uninstall Plex and then reinstall it. Still not working.
Then I uninstalled Plex, searched the entire harddrive for any filename containing "plex* and deleted it all. Rebooted and installed an older version of Plex. Still not working.

Then I installed Plex on an Ubuntu box and tried to stream that server via the Chrome browser on Windows 10… “Playback Error”.

The odd thing is that I can use the Plex App on my Android phone to stream to my ChromeCast, and it works just fine.

wtf?!?


#20

Hello weirdlabs,

which older version did you try?

Issues started to me after migrating from server version 1.7.* to 1.8.. I never had the chance to downgrade it back to 1.7. due to the fact that I do not know if the database would be backwards compatible and I would really prefer to not recreate it by hand (I have around 30-35 libraries).

Right now, I’m on version 1.10.1.4602-f54242b6b. The videos are playing but they ALWAYS show the “There was a problem selecting this stream” error before actually starting to play.

The latest problem, which started last week, is that MOST of my movies/videos (even the newly downloaded ones) are starting playback at around 10-11 minutes ahead, not at the initial zero position. Odd.