Two letters country tags


#1

Hep!

I noticed many movies now receive a 2 letters country tag which is quiet frustrating when you don't know the code for obscure countries like Cameroon, Chile or whaterver. I'd much prefer having the full country name there. Is there a way to change that?


#2

Unfortunately, both 2 and 3 letter language codes are a part of a standard and Plex follows that standard.

In order to change it, you would have to change the standard.

For more information on languages codes, Google Language codes.

Here is one example: https://www.loc.gov/standards/iso639-2/php/code_list.php

For your examples, Cameroon is a mostly French speaking country and the code is fr or fra. Chile is mostly a Spanish speaking country and the language code is es or spa.

If you need to use these codes often, then make a bookmark in your browser for the page I linked to, to make it easier to find when you need it.

Not much help I know, but that's how it is with Plex.


#3

@trumpy81 said:
Unfortunately, both 2 and 3 letter language codes are a part of a standard and Plex follows that standard.

I can understand that. But then why does it uses 2/3 letters codes sometimes and the whole country names some other times. That's not what I call "Following a standard", it just makes a mess of the whole country thing.

@trumpy81 said:
For your examples, Cameroon is a mostly French speaking country and the code is fr or fra. Chile is mostly a Spanish speaking country and the language code is es or spa.

Yes, but then again, plex files it under CR and CL repectively. Users should not need a code list to search for anything. I should be simple.


#4

If you are using Plex to download the subtitles, then no intervention by you should be necessary. The appropriate language codes should already be applied.

Plex uses CR because there is no code expressly for Cameroon. In this case Plex is applying es-CR or Spanish (Costa Rica) which is incorrect, but if you were to use French as the language then the code would be correct. For Chile it applies es-CL or Spanish (Chile).

If you think you can make the process 'simple' then be my guest. I look forward to seeing your working examples, but remember, you must stick to an accepted standard for the language codes.


#5

But I wasn’t talking about the subtitles, which are fine, but the country tags, as shown in this picture:


#6

Apologies, I thought you were referring to subtitles. In that case it is very simple, only countries that produce mainstream Movies are included in the list. Cameroon and Chile are not known for film producing which would explain why they are not included in the 'country' list.

I have no idea why some of the countries are listed with two letter codes though. I will ask the devs about that and I will let you know if I hear anything in regard to this.


#7

I've just checked my library and can confirm both France and FR exist together but there are no movie overlaps when I actually filter using either country. Is this based on the database the film information is sourced from? I think I use TMDb for movies.

Even weird non-countries like West Germany are present so there appears to be something weird going on with where this country information is sourced from.


#8

Yes the countries and the codes are derived from the various databases and what they return in respect to country and codes.

I have submitted a GHI for this to be looked at, but I have no idea if/when any changes will be made.


#9

One I see as a problem example is for the film The Act of Killing IMDb: http://www.imdb.com/title/tt2375605/ and TMDb: https://www.themoviedb.org/movie/123678-the-act-of-killing

My Plex server library lists the country for the film as: DK and I also have Denmark as an option to filter by in my library which displays other films and not The Act of Killing.


#10

I added that film to my library and Plex added the Country tag as DK. I would expect that to match if you select DK as the country to filter on, but it does not match Denmark, since that tag does not exist for that film.

For France & FR I get two different results when selecting either of these filter terms.


#11

Same here. Any fix?


#12

I have submitted a GHI for this to be looked at, but I have no idea if/when any changes will be made.


#13

Please fix


#14

It seems to have been silently fixed, I refreshed my collection metadata and bam, 99.9% is tagged correctly, only a few of them are not. Can someone confirm?


#15

The problem is back.


#16

What do you mean the problem is back?

You are aware that some countries have both full names and two letter codes and that some countries only have two letter codes. The country selector is looking a whole lot better than it did before.

Countries with two letter codes and full names are correctly displayed, as are countries that only have two letter codes.

Without the two letter codes, you would not be able to filter using those codes, so you would never be able to find those Movies. Remember, that these codes are supplied by the various online databases and not by Plex.

Compare this list with the earlier list shown in this thread, I’m sure you will agree that it is much better than the previous effort:


#17

I do not understand the attempt to justify. Regardless of whether IMDB always provides the name of the country using ISO 3166-1 alpha-2 (because the TMDB agent sends the full name except when no one has added the country of production), a Plex script must be able to convert those codes to the name of the country and offer a clean and consistent database. It is logical and reasonable.

When I say that the problem returned it is because a few days ago when adding a new library using the IMDB Plex Movies agent the country appeared with its name in all the movies but doing exactly the same a few days later they were added again with the code ISO 3166- 1 alpha-2. I do not know why.

Try yourself adding a new library using the Plex Movies agent and you will see that it happens. Regardless of whether TMDB or IMDB is selected inside the Plex Movies agent.

If you add a new library using the TMDB agent and secondly Plex Movies, the problem is solved. But I do not want to use the TMDB agent, I want to use the Plex Movie agent as the primary agent because if I use the TMDB agent as the primary agent it could not include Open Subtitiles or Cine Material.

Never in the many years that Plex has existed there was a problem like this. Always the country was deployed with the full name, how it should be, not ISO 3166- 1 alpha-2 code. It is a problem of the agent "Plex Movies" that the guys of Plex must solve. And it's incredible that they do not care.


#18

@trumpy81 said:
You are aware that some countries have both full names and two letter codes and that some countries only have two letter codes. The country selector is looking a whole lot better than it did before.

Just to be concise, when I still had this problem, none of the movies had both tags. NL and Netherlands for example gave two different sets of movies.


#19

Please fix


#20

Same issue here...
Much obliged for a fix !