Unable to connect to content server

samsung-smart-hub

#1

Never been able to get this working from SmartHub TV with app from Samsung App Store. Tried again today with no luck. What’s the deal to make it work?

App and PMS are both latest code. I can browse all the shows and movies it’s connected just won’t play anything


#2

Seems to work only on direct stream not auto or direct play.


#3

You are probably using secure connections, if s,o please set them to preferred on the server and off on the app.
With Direct streaming or Transcoding , the server handles the certificates and that works, but not all models accept the Plex certificates when in direct play.


#4

Server is set to preferred but need to check the app to disable. Where is it in the app?


#5

It’s under preferences > sysytem.

Tip: you can download the manual here.


#6

Hi Orca,
I have a couple of Samsung tvs that were working totally fine, then out of the blue began having issues where anything attempted to play on plex gave an error of “Unable to connect to the content server” . My Plex Server Security settings is set to “preferred” as you mentioned, and Secure Settings on the Samsung Smart TV App are disabled.

The only way to get them to play anythign and not give the error is to set the Player Playback to “Transcode” instead of “Auto” but that is just so intensive on the server, and those TVs before used to Direct Play pretty much everything!

Not sure what happened from one day to another. Is there anything else I can test or shoudl try?

This is one of them (2012 E-Series with Latest Firmware 2004.0):

This is the other Samsung also with latest firmware:


#7

The most obvious would be that the file can’t be direct played by your model, but the app should tell you if so.
I know 2012 models can’t play HEVC for instance.

Also check if the server maybe has a limit set for the download speed. (it’s under remote access)
If so the server will not allow you to use more bandwidth than given, which will result in transcoding, to reduce it.

To be really sure, enable “Send Debug to PMS” and check the Plex media server.log for [PlexForSamsung] messages
They should show exactly why it picks transcoding instead of direct play.


#8

Thanks for the Reply Orca,
I checked and I have no speed limit under remote access, and maybe I did not explain it properly.
I do not mind when it forces transcode when it needs to, its bound to happen. But what happened from one day to another a while back is that the user was getting the “Unable to connect to the content server” and absolutely nothing was playing, not a single thing, when before it played just fine, some direct play, some transcoding if it needed to, but it decided on its own. The only way to get those 2 tvs (2012 and 2015) to play anything at all was to go into player and change it from “Auto” to “Transcode” and force transcoding on everything, having it on Auto will just simply not play any media at all.


#9

The only way I can think of, is that transcoding is needed because of certificates being used.
I know 2012 does not support playback over https, but it will still show all movies in the app.
Are you sure that the server you connect to isn’t running https?

Check the log file > how to create one


#10

I know for a fact both of those users’ tvs played content perfectly before, and few months ago, it just started giving that cannot connect to content server error.

Yesterday I checked to make sure on both that in the App secure connections was indeed off.

Here is the server, that also has it set to preferred, and no certificates of any sort .

I have asked the user if whenever they are home if they can change playback back to Auto and get the error a few times on different media to try and pinpoint some logs. Any other tests I can do? Those are the only ones having issues, my samsung tv works fine but its 2016 version, as well as Roku TVs. Would any custom access server URLs affect this at all?


#11

Something must have changed. Things do not change overnight on their own.
The trick is to find out what is different now. New router, firewall, changed configurations?
Is your server logged in to your Plex account? If not, the info in the cloud could be wrong and clients may have to connect through relay, which has a bandwidth limitation.
Check how the server is listed on the client and see if that matches with your actual IP address.


#12

I know and I cant pinpoint the issue, and unfortunately they did not tell me the exact time, just said a few months back. The only thing I can figure is that a Plex Server update at some point caused it.

-The router for sure has been stable as I have not switchced routers.
-The server is logged in to my account (should i log out and log back in?)
Where do they have to go to view how the server is listed on the client on the samsung? So i can have them send me pictures of it.

Anything specific to log? Grab the logs of them getting the errors? Change secured from Prefered to disabled? Anything you can think to try or first get some logs?


#13

If a user connects to your server, ask them to temporarily enable the option “Send debug to PMS” and reproduce the error.
Then grab the Plex media server.log from your server. It should have lines with [PlexForSamsung] in it.
It should show, what’s happening


#14

Is your PMS and your device on the same subnet? For example my PMS is on 10.1.11.0/24 and my TV on 10.1.10.0/24. I also enabled “Internet upload speed 6 Mbps” and “Limit remote stream bitrate 3Mbps” under “Remote access”.
I had the same problem, i also was not able to play auto or direct play and got the error with the content server.
The solution was to put 10.1.0.0/16 in “Lan Networks” under “Network”.

The PMS knows now that all devices with 10.1.x.x are on the same LAN and 10.1.10.x is not WAN for the PMS anymore and the bandwith limitation does not take effect.

I think that bandwith limitation was the cause that i got this server content error with auto and direct play.

I hope that helps…