WD My Cloud Home - PMS won't add library folders from the WD Drive



EDIT: It appears that this was an intentional choice… removing the ability to select a folder on the drive to associate with a library. This is a serious limitation for anybody who wants to organize their media/libraries into more than the “Movies, Photos, Music, TV Shows, Home Movies” categories provided. Where should I put tutorials, live concert footage, or other items?

EDIT #2: A workaround for this is to use PMS collections/labels feature for content, and assign filters to new libraries… however this is a per-user preference that cannot be assigned by default for the library itself.


I’ve recently purchased the latest WD My Cloud Home 4TB single bay HD mostly because of Plex’s recent email announcing its ability to host PMS and transcode. (so excited.)

I’m happy to say that the server does in fact work, and transcoding does seem to be pretty good. A bit slow to get going, but very happy with the results thus far.

That said, I’ve run into an issue:
PMS doesn’t appear to recognize custom library folders on the WD My Cloud Home drive. This makes having custom libraries apart from the defaults impossible.

I have tried disabling the plex service on the My Cloud Home drive, removing the server from my plex account, rebooting the drive and reinstalling the plex service again. It appears that the default library folders are created immediately after the service is enabled/installed. Any additional modifications to the PMS libraries - during setup or post setup take no effect.

Adding a new library to the PMS is successful and the library appears in the plex database, but no physical drive folder is created, thus providing nowhere to put media that should be in the new library. Creating a drive named the same as the library does nothing to link them either.

I’ve tried rebooting the WD My Cloud Drive after creating a new library and library folder to see if it’s a recognition issue, I’ve waited for 1hr to see if it’s just a weird bug that fixes itself and I’ve reinstalled PMS and gone through the server setup process with and without custom libraries.

Attached, a view of the library folders on the drive, and a view of the custom plex libraries (some of the default libraries were removed and a new custom one added). To note, the screenshots are from the mobile app, but I have been using my Win10 pc to run WD My Cloud Home drive configuration and PMS setup.

Server is running “Inital Release” build Version
Logs are attached.

Would love to see this issue resolved as I’m not confident in moving my media over to the drive until PMS is fully functioning & I don’t need to reinstall it again.



Can you clarify if and how you resolved this? I am having the same issue. Only fix I have found is to map the drive to my iMac and use it as the server.


I ended up relabeling all of my content folders that needed to share a single library folder with a category title included in the name to keep them somewhat grouped/organized in the file structure. The plex libraries are still the limited default libraries provided. I’ve been using the filter and search options with content tags to get more granular “Anime” “Guitar Lessons” “Tutorials” results.

File structure now looks like:

WD My Cloud Home\Plex\Shared TV Shows\Anime - Cowboy Bebop\Cowboy Bebop - S1 - E01.m4v
WD My Cloud Home\Plex\Shared TV Shows\TV - The Simpsons\Season 01\The Simpsons - S1 - E01.m4v


This will allow me to easily split content back out of the default library folder if/when the ability to have custom libraries exists on the My Cloud Home.

Only complaint is sometimes the auto match really screws up and I have to manually correct it the first time new content is imported to the library.


@TheGreatRaja so if I have all Star Trek in one folder and all Law & Order in another folder, using your workaround I would do what - search for "Star Trek within PMS if I want a Star Trek marathon? I want to better understand your process. I don’t want The Golden Girls popping up when I have Law & Order on shuffle. This was so easy on my HTPC Plex server.