Xbox 360 does not load

xbox-360

#1

I cannot get my Xbox 360 to load PLEX APP!! Every time I start PLEX on Xbox 360 I have an hour glass and never connect to my cloud media. My iPhone is working fine and connecting. Of course I linked my Xbox to my account. Am I missing something?


#2

I've been experiencing this problem for the past few weeks. I've already deleted the app, cleared the cache, re-downloaded, re-signed in with another PIN, and it just keeps searching. Is there something going on right now?

Thanks!


#3

I am running into the same issue. I have the spinning wheel trying to log into Plex. I have removed my xbox from the list of devices on my Media server, uninstalled and reinstalled Plex twice on my Xbox and still unable to get it to connect. It worked before the Cloud upgrade fine. Since the upgrade, I cannot get it to connect to the server. Any suggestions would be nice.

Thanks


#4

I've also tried to move it to a different HD and format the drive that the application is installed to and it still sits @ the splash screen. I have one of the older Xbox 360's (White with 20 GB HD on top)


#5

I have two Xbox 360 slims, and I see the same problem on both of them. I see the hour glass forever, and it never gets any further.


#6

I've been having issues with the Xbox 360 version of the Plex app for a while now. Lots of buffering types of issues or it just doesn't work at all. Xbox One, Chromecast, Chromecast Ultra, Apple TV, Chrome all seem to be fine.


#7

Make sure on your XBox 360 that you check your settings...go to System / Console Settings / Connected Devices / Play To ... ON


#8

So has the app for the 360 officially been abandoned or what? I haven't been able to use plex on my 360 for at least 3 months now. I thought it was my network but it works on my XOne, PS4, and most other devices.


#9

I keep trying to get Plex on my xbox360, I hit "sign in" & it takes me to a black screen that only says: "PLEX No Account? Sign Up"... I, like you all, can sign in just fine on my phone, but can not get beyond this screen. I've even tried to sign up with my existing information, but it tells me tbat I entered an invalid email address


#10

as soon as i set Allow Fallback to Insecure Connections ---- on same network… the 360 worked flawlessly.

Settings— web— general…


#11

Tried both web allow fallback and the vonsole settings… Still hour glass no loading