Cannot start using plex!

server-western-digital

#1

Hi... I installed the plex app on a fresh WD myCloud EX2 Ultra following the instructions on the WD site. After going over to configure plex I log in the PMS, but then the media server is not found (i.e. on the left top of the plex page I read "Search for server" and below "No server found..."! I've tried different times, tried uninstall/reinstall, completely purge plex (via ssh), again reinstall... same thing!

Please, could anyone advice me in any direction?
Regards, Joe


#2

@JoeDoe18 said:
Hi... I installed the plex app on a fresh WD myCloud EX2 Ultra following the instructions on the WD site. After going over to configure plex I log in the PMS, but then the media server is not found (i.e. on the left top of the plex page I read "Search for server" and below "No server found..."! I've tried different times, tried uninstall/reinstall, completely purge plex (via ssh), again reinstall... same thing!

Please, could anyone advice me in any direction?
Regards, Joe

could you locate the logs and copy out and zip the copy and attach
https://support.plex.tv/articles/200250417-plex-media-server-log-files/
https://support.plex.tv/articles/202915258-where-is-the-plex-media-server-data-directory-located/

Best to capture the logs after restart

If debug logging is disabled - then may need editing Preferences.xml to re-enable it


#3

Sorry, I wasn't available for a couple of days... but now, please, find attached the logs...

Regards, Joe


#4

sorry, I've put the logs together in a tgz, but the forum does not allow this... can I mail them to you?


#5

Why not zip the tgz and attach the zip


#6

ok, I'll try, here the zip...


#7

Is this hosted externally or on your home network ?

You have a public IP address for the server

Apr 10, 2018 15:01:15.367 [0xb40d8000] DEBUG - * 4 egiga0 (141.79.xxx.xxx) (loopback: 0)

You can only configure a server that is hosted on a Public IP range address through ssh tunnelling
See this support article https://support.plex.tv/articles/200288586-installation/
and read section headed On a Different Network

Alternatively, if this is in your own home network, change your local network subnet to be within the defined range for private networks - see https://en.wikipedia.org/wiki/Private_network


#8

Indeed, the server is located at my university and has a public IP, that’s correct... so, what do I need to do, if my local PC, from which I do the configuration, is located in a different subnet?


#9

read the suppport article i linked and the section i referred to.
You would need to be familair with linux


#10

OK everything works! Thanks a lot!!!