Can't update, "check for updates" is greyed out?

server-mac

#1

Mac Mini server running High Sierra 10.13.1, Plex Pass channel. On Plex version 1.9.7.4441, and 1.9.7.4460 is available but the update button is greyed out.

There's no explanation in the interface of what's preventing the update, any suggestions?


#2

I had the same problem on the exact same setup. The following worked for me:

  • Close Plex on your Mac Mini
  • Sign into the plex website in your web browser
  • Go to the plex downloads page
  • Choose Download PMS
  • Run the installer then open plex, it should be up to date and the “Check for Updates” button should no longer be greyed out.

#3

@mwhite52 said:
I had the same problem on the exact same setup. The following worked for me:

  • Close Plex on your Mac Mini
  • Sign into the plex website in your web browser
  • Go to the plex downloads page
  • Choose Download PMS
  • Run the installer then open plex, it should be up to date and the “Check for Updates” button should no longer be greyed out.

Every once in a while an update rolls out that requires this sort of manual install.

Check this list to compare your version to the most recent:


#4

I’ve done a manual install about 4 times now. Immediately upon installing this way “check for updates” is fine, but after a while (can’t say how long) it goes back to being greyed out. Currently downloading 1.11.something, going from 1.10.1.4561.

Edit: You know what? I always install updates anyway so I’ll just set it to run them during maintenance. That way I won’t have to worry about the button being greyed out.


#5

Same issue - has only reared its head in the past few weeks.


#6

Same issue on Version 1.9.6.4429. My server frequently says it is not available outside my network for no particular reason also. I wish they made older versions available for download as well.


#7

Same issue on Windows 2012 R2 Server


#8

Looks like the automatic update didn’t run. Still had to download the latest one manually.

Looks like the “check for updates” button is usable when there is no update. As soon as there is an update, it greys itself out so you can’t use that method to update. Have to just run updates manually, which is frustrating.


#9

Same with 1.9.7.4460 on Windows 7 x64… manually updated to 1.11.0.4666 and update checking is working again now…


#10

Same issue here.


#11

same issue here. PMS on Mac OS. I am on 1.9.7.4730 on beta channel


#12

I fixed my issue on my Mac Plex server.

  • Quit Plex media server
  • Open the preferences plist ~/Library/Preferences/com.plexapp.plexmediaserver.plist
  • Backup your com.plexapp.plexmediaserver.plist just in case.
  • delete ButlerTaskSkippedVersion
  • Save
  • Restart Plex Media Server

#13

@dhausman This was the permanent fix for me as well, thank you!


#14

@dhausman said:
I fixed my issue on my Mac Plex server.

  • Quit Plex media server
  • Open the preferences plist ~/Library/Preferences/com.plexapp.plexmediaserver.plist
  • Backup your com.plexapp.plexmediaserver.plist just in case.
  • delete ButlerTaskSkippedVersion
  • Save
  • Restart Plex Media Server

THIS.

Manually installing does not fix, you have to manually install each time. However, this solution has permanently resolved it for me. THANKS!!!


#15

Also for I’ve used the following app to edit the preference plist file:

http://www.nightproductions.net/prefsetter.html

It’s free and worked like a charm. Hope this helps :slight_smile:


#16

@dhausman has the correct solution for this issue. The answer should be changed to this one!


#17

For those who want to tackle this from the commandline. (May require Xcode installed)

defaults read ~/Library/Preferences/com.plexapp.mediaserver ButlerTaskUpdateVersionSkipped

defaults delete ~/Library/Preferences/com.plexapp.mediaserver ButlerTaskUpdateVersionSkipped


#18

Actually its:

defaults read ~/Library/Preferences/com.plexapp.plexmediaserver ButlerTaskUpdateVersionSkipped

defaults delete ~/Library/Preferences/com.plexapp.plexmediaserver ButlerTaskUpdateVersionSkipped

Minor typo in previous post.


#19

@dhausman said:
I fixed my issue on my Mac Plex server.

  • Quit Plex media server
  • Open the preferences plist ~/Library/Preferences/com.plexapp.plexmediaserver.plist
  • Backup your com.plexapp.plexmediaserver.plist just in case.
  • delete ButlerTaskSkippedVersion
  • Save
  • Restart Plex Media Server

Did all this but as soon as I open Plex media server again the update button is still greyed out and if I reopen plexmediaserver.plist the ButlerTaskUpdateVersionSkipped is back again do you also need to delete the 2 underscores separating them from the next and beginning lines? I think I made sure there was no instances of Plex still running in activity monitor too ! Please help :slight_smile:


#20

defaults will only work if the plist is registered globally. if that’s not the case for you (it wasn’t for me), then from terminal, you can run the following:

/usr/libexec/PlistBuddy ~/Library/Preferences/com.plexapp.plexmediaserver.plist

It’s useful to run /usr/libexec/PlistBuddy -h first to get usage.

Once in, use Print to display the plist, and Delete : ButlerTaskSkippedVersion to delete, then Save