DS918+ Plex on LG TV - No Files OR Invalid File

server-synology

#1

I have read many of the message threads regarding getting Plex to work with an LG TV. My LG TV was purchased in 2011. I installed my Synology DS918+ NAS and Plex Server in the Fall 2017. I followed the instructions regarding IP authentication and everything worked fine. In the LG TV, I would click on SmartShare then the Plex icon. It would show folders for Movies, etc. Everything would play without a hitch. It went on this way for 3 or 4 months.

Then after a couple of power outages (one that last 10 hours or so) in the last week, I noticed that the Plex icon was not even visible in SmartShare on the LG TV. I did an manual update of Plex on the NAS and signed out of the client server and signed back in. No change - the Plex icon was not visible. The LG TV was connected to the network via a wired connection.

Last night we had another power blip. Checked the LG TV and the Plex icon is back. However, when I click on it, it says No Files. The IP authentication is set as shown below:

This afternoon, I turned off everything - modem, router, all network switches, and LG TV. Turned off Plex and the Synology NAS. No change - still them same thing.

Now I should point out that I can view the videos on the LG TV by clicking on the Server Name icon. It shows the files and a very small % of them will play - mkv files that that ripped from DVDs that I own. Not all of them will play but some. The other files will not play and I get a message stating Invalid File.

Please note that I have played all of these vidoes before using the Plex icon on the LG TV. They play fine on my Samsung TVs using the Plex app.

The log that I downloaded is attached. I would appreciate any help you could give.

David


#2

For the LG TV using LG SmartShare to be found it needs to be on the same local network subnet as the server and the IP Address of the LG TV whitelisted in the allowed networks without Auth list

What is the IP Address of the LG TV ?
You have whitelisted 10.10.10.0/255.255.255.0

The server appears to be on a different subnet with IP Addresses of 192.168.1.4 and 192.168.1.15
So the LG TV IP Address needs to be a 192.168.1.xx IP address and that would be the one you specify on the server network settings


#3

There might actually be issues using the old legacy Smartshare LG mechanism with current versions of Plex Media Server as the smartshare does not bother sending to Plex Media Server timeline updates on playback and this is needed for the streaming bandwidth control for playback


#4

The IP address of the LG TV is 192.168.1.18.


#5

So on the screen you took the screenshot of, you need to enter 192.168.1.18 in the field List of IP Addresses and Networks that are allowed without auth

But as i said - you may find this old legacy software will not work well with Plex Media Server.


#6

That didn’t work either. When clicking the Plex icon I got the dreaded NO FILES. I did notice that about 1 out of 20 times a video would play from the Server icon. The rest of the time I would get the INVALID FILE note. I could play and video stop it. Go back on screen, click the same file and it would state INVALID file. It’s not a very consistent error.

It plays .wma music files wonderfully. Not from the Plex icon though. Nothing works through the Plex icon.


#7

@“dloftis@vt.edu” said:
That didn’t work either. When clicking the Plex icon I got the dreaded NO FILES. I did notice that about 1 out of 20 times a video would play from the Server icon. The rest of the time I would get the INVALID FILE note. I could play and video stop it. Go back on screen, click the same file and it would state INVALID file. It’s not a very consistent error.

It plays .wma music files wonderfully. Not from the Plex icon though. Nothing works through the Plex icon.

Could you get logs for the no files issue
Restart the server to get fresh log files
Confirm that the lg tv up is still 192.168.1.18 by looking at the tv network settings - you may need to setup a dhcp reservation in the router to make sure it does not change on dhcp renewals

Then reproduce the error - note down the time and get the logs zip

For other playback issues using smartshsre - these could be because this software does not send playback timeline updates which are needed for control of streaming bandwidth usage


#8

I am truly a amateur at this. Can you walk me through how to extract the logs for that specific event?


#9

See
https://support.plex.tv/articles/201643703-reporting-issues-with-plex-media-server/
https://support.plex.tv/articles/200250417-plex-media-server-log-files/