Enabling (or troubleshooting) Remote Access

server-qnap

#1

I'm going on holiday next month and want to be able to access my library. Trying to enable Remote Access keeps failing, though does (for the briefest of moments) flash up that it is enabled.

Running the latest build on QNAP, NAS which is connected directly to my BT broadband router.
I can see the ports being created on the router itself (BT Smart Hub 6)
I don't see any activity in the Plex Media Server log

As a sanity check, I also setup a PMS on my Mac, and it is having the same challenges...

Could really use some advise or pointers...

thanks
Scott


#2
  1. Is the IP reported by http://www.whatsmyip.org/ in a CGNAT range (100.64.0.0 - 100.127.255.255) ? If yes, you need to contract a fixed IP from your ISP
  2. Does that IP matches the WAN IP reported by the router to where QNAP is physically connected ? If not you are in a double NAT situation
  3. You can find these and other debugging instructions here

#3

Thanks for the suggestions moody_blue.
I tried 2 & 3, as 1 was not applicable, and still no joy. Is there anything written to a log anywhere that I can use to debug?


#4

Sometimes PMS logs will tell us why this happens, pls post them, following the process (restart PMS, verify that debug is enabled and verbose is disabled, reproduce the problem, post the zip with all logs).


#5

Logs attached.
I did have a look in there and found nothing specific to events relating to Remote Access, but I’m not here to judge :slight_smile: