Local Media Assets Ignored?

server-nvidia-shield

#1

Has anyone updated to PMS Version 1.12.1.4885 and noticed local media assets are not being used when set as first agent?

Just added this movie to my library:

You can see the local artwork is not being chosen automatically:

Here’s how the agent looks (local assets first):

Here’s how the files look:

I don’t think I’m doing anything different to before? I’ve recently started grabbing artwork like moviename.jpg moviename-fanart.jpg for my collections but even without that artwork present the same thing happens after metadata refresh.


#2

+1 I have same issue after updated to 1.12.1.4885


#3

Good to know I’m not alone! No sign of any update yet. Not sure if this affects all PMS or just the SHIELD version.


#4

@niallobr said:
Good to know I’m not alone! No sign of any update yet. Not sure if this affects all PMS or just the SHIELD version.

Yeah it is Shield version PMS causing this problem. I installed another PMS on my Synology ds916+ for test, which is the same version(1.12.1.4885) and it has no problem loading local media assets. Hope this will be fixed soon. I have customized posters for every contents I have(about 600 movies and 120 TV shows) and that’s way far more than I can change posters manually one by one.


#5

Yeah I’m in the exact same boat with the customised artwork, I probably only noticed this because of my obsession with updating the artwork for every new movie!

Tagging @gbooker02 and @“Chris C” for visibility, happy to provide logs if I can.


#6

Still happening on the latest server version (Version 1.12.2.4929)

@gbooker02 @“Chris C” any help would be appreciated.


#7

Ah luckily I’m not alone, same problem here on 1.12.3.4973


#8

It sucks. I’ve just moved my server from the Shield to a new custom build but still had the issue on the latest update to the Shield. I’ll still keep an eye on this thread and mark this as answered if/when we do get a solution.

It looks like the devs are currently either not aware of it or it’s not high priority for them. Hopefully it gets some love soon.


#9

when is this going to be fixed? :frowning:


#10

Version 1.13.0.5023, still no fix.


#11

+1, still no fix
I’m having the same issue with Plex server scanning my music collection.
I’ve tried creating numerous small dummy music collections that follow Plex’s prescribed schemas and suggested solutions from other users in forum posts, all without success.
The plex scanner finds the cover art assets (you can see and apply them manually when you edit, as for OP) but does not display them automatically as it should.

Unfortunately from searching the forum posts this is an intermitent problem that keeps recurring between updates.
A pity that the back end server for Plex is still in such an early and buggy state of development, because the front-end looks quite nice if could just access the server collections properly.


#12

Yep, it’s a real deal breaker. I spent endless hours on writing scripts so all my music (20.000+ songs) is being tagged automatically following the ID3 specs, including cover art. So it sucks that all the hard work doesn’t come to it’s right. Of course there are alternatives for Plex like Emby, but I bought the Shield specifically to fungate as media server with Plex.


#13

This is such a bummer. I also have a music library which contains 600+ artists, 1500+ albums, all of them don’t pick local media assets like album covers(separated jpg files and embedded cover arts too) and backgrounds(fanarts). There’s no way to set these assets manually since library is HUGE. How come Plex devs don’t fix this?


#14

SIGH… this is a bummer as well… They just updated the shield to put the database on a expanded Media so I did this and created whole new set up. With 4500 albums… this BLOWS hard. I remote into my PC while I am at work and spend 6 hours a day just clicking! Probably get fired!!! thanks PLEX :wink:

But yea… this needs to be fixed.


#15

I have the same problem with TV Shows!


#16

I’m not sure if this is still being considered, but I recently setup a Shield TV PMS and I have the same issue.

No matter what I try, Plex ignores the local poster/art.

What’s odd is, if like in the OPs Nausicaa example, I manually select the correct (local) poster, even of future Metadata refreshes it sticks with that one. But I don’t want to manually select hundreds of posters in my library when they should work automatically.


#17

Version 1.13.2.5154 on Centos 7,I ran into the same problem, then I tried to modify the library directory permissions to plex user (chown -R plex.plex /library directory) and recursively modify the file permissions under the library directory (chmod -R 775 /library directory) And then refresh all the metadata, you can normally recognize the poster.jpg file. But now I don’t know how to solve the problem of how to inherit the plex user’s permission from the movie file newly added to the library directory. Every time you have to manually modify the permission plex server to recognize the poster.jpg.


#18

bump

Any fixes yet?